revere521

Raspberry Pi support

14 posts in this topic

Can you include a .deb file for the armhf architecture, or allow us to compile from source?  I'm specifically looking for support for the Raspberry Pi, but i'm sure other device platforms that use linux arm would be interested.   I searched and didn't see this posted here yet (sorry if i'm wrong)

Edited by revere521

Share this post


Link to post
Share on other sites

I think they are working on a rbpi version

Share this post


Link to post
Share on other sites

I am also interested in seeing support for a Raspberry Pi version

Share this post


Link to post
Share on other sites

I contacted support about this topic, they said to me that it'll be released in synergy 2.1, due to early 2018.

  • Like 1

Share this post


Link to post
Share on other sites

How do other people have a rasperry pi 3 version already?  Have they just been compiling from source? 

 

https://www.virtuit.com.au/2017/08/26/installing-synergy-raspberry-pi/

for example:  im new to linux, and i thought symless would help me bridge the gap -> i realize it is only a few bucks i've spent, but since rasperry pi said debian in the help menu, I thought it worked.  oops.

Share this post


Link to post
Share on other sites

you can compile version 1.8 for the raspberry pi; but you have to use version 1.8 for the server as well, thats what I am doing until v2 supports the pi.

Share this post


Link to post
Share on other sites

It is asking for a serial key?  It don't see it on the account page. This is so difficult.

 

Share this post


Link to post
Share on other sites

I would start here  that's the post regarding what appears to be the latest v1 build.

Synergy 1 and Synergy 2 have separate registrations; but in the past I was able to use synergy 1 before I purchased it.  I'm not sure if you still can, but i think you can just click past the serial/login and finish the setup.  

 

Share this post


Link to post
Share on other sites

Thanks.  Ya, i tried to post there, topic locked.  Oh well.  I'll just ask for a refund I guess. 

Share this post


Link to post
Share on other sites

Just wanted to reply and say I got this working.  I think I followed instructions on building 1.4 from source on a rasperry pi 3, 

 

then I installed 1.8.8 on windows, and used windows as the server and it worked.

 

So, awesome. 

Edited by condor85

Share this post


Link to post
Share on other sites

Yes!  Please support a raspberry pi version for synergy 2...
4 of my friends and I use this with our pi, and just find it hard to live with out this lovely piece of software!
 

Share this post


Link to post
Share on other sites

Synergy 2 now supports Raspberry Pi.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now