onscreen

Synergy and gaming

27 posts in this topic

When playing FPS games such as Quake Champions whenever the mouse is moved to the screen edge the game tabs out to desktop as synergy attempts to move the cursor to the other screen.

I have tried various curser locking programs but none work, is there any way to create a hotkey that toggle locks the cursor to the main computer?

Share this post


Link to post
Share on other sites

Scroll lock locks the cursor to what ever screen you are on.

Stuart

Share this post


Link to post
Share on other sites

Try this:

while you are on the screen where you want the cursor locked, press the Scroll-Lock key on your keyboard.

This is an old feature of Synergy that still works on my 2.0-stable version.

Share this post


Link to post
Share on other sites

This worked thanks.

Are there any keybindings to jump the cursor to the other computer? This is handy as it does not tab out the fullscreen game on the main computer.

Share this post


Link to post
Share on other sites

Good answer Stuart. It's been discussed on the forums, but don't expect it before version 2.4 or so, IMHO.

Share this post


Link to post
Share on other sites

Thanks for this, it would be cool if we had some info in the application that showed stuff like this.

Share this post


Link to post
Share on other sites

I'm gonna add some links to previous posts that also mention both the minimizing problem and the locking cursor problem. They may include more info on what the problem is and/or a current workaround

 

Share this post


Link to post
Share on other sites
On 08/11/2017 at 2:45 PM, stuart macmillan said:

Scroll lock locks the cursor to what ever screen you are on.

Stuart

Hi,

Windows laptop here. No scroll lock key, other options?

Thank you!

Share this post


Link to post
Share on other sites
1 hour ago, findev said:

Hi,

Windows laptop here. No scroll lock key, other options?

Thank you!

Is it hidden under an "Fn" (function) button?

IMG_1320.png.27091fe1f6c303013e63eeb2235eca3c.png

Share this post


Link to post
Share on other sites

Hmm, probably that's under F6, will test tomorrow. Thank you!

 

 

IMG_0568.jpg

Share this post


Link to post
Share on other sites
5 minutes ago, findev said:

Hmm, probably that's under F6, will test tomorrow. Thank you!

 

 

 

Could be, or that's the quick lock (similar to Win+L).

I did do a quick google and found this: https://support.office.com/en-us/article/Turn-off-Scroll-Lock-a78492cc-c124-4782-a38b-df46669520e0

Not super helpful, but would enable a scroll lock.

EDIT: You're right, if that's the same model you own in the picture: http://www.dell.com/support/article/us/en/04/sln295380/dell-latitude-e5550-keyboard-guide?lang=en

Edited by Jay M
More info

Share this post


Link to post
Share on other sites

Thanks Jay. I'll post my results later. For now just used Steam's streaming capabilities.

Share this post


Link to post
Share on other sites

Another option to getting your scroll lock on, without using a physical keyboard, is the on screen keyboard, OSK
This has been in windows for a few generations now, so you should have it available when you search for it, alternatively it is in the accessibility options in the control panel. 
I would assume this will work the same as the hardware key, however it would need to get tested. 

 

image.thumb.png.a580620561f6a99f58eccd74af8b8637.png


In all honestly I was having this exact issue in many of my fullscreen games... I want to go home and test this now, haha, sadly i have a few hours of work left ~_~

Share this post


Link to post
Share on other sites

Tested the Dell Latitude's combination for the regular OS usage and it seems to work. Haven't tried games yet, but I suspect it will be ok too. For now still using the Steam's streaming.

Thank you!

Share this post


Link to post
Share on other sites
3 hours ago, VttkLazer said:

Another option to getting your scroll lock on, without using a physical keyboard, is the on screen keyboard, OSK
This has been in windows for a few generations now, so you should have it available when you search for it, alternatively it is in the accessibility options in the control panel. 
I would assume this will work the same as the hardware key, however it would need to get tested. 

 

image.thumb.png.a580620561f6a99f58eccd74af8b8637.png


In all honestly I was having this exact issue in many of my fullscreen games... I want to go home and test this now, haha, sadly i have a few hours of work left ~_~

Just tested it on my setup (Mac -> server, Windows -> client) and it doesn't work.. I guess the scroll lock command must come from the server and not the client.

 

EDIT: If I user my windows as the server then this works. Sadly I need to use my mac as a server, so this does not work for me. But for the other cases where you are using windows as server and your computer does not have a scroll lock key this is a workaround to the problem

Edited by aristizabal95
typo

Share this post


Link to post
Share on other sites
14 minutes ago, aristizabal95 said:

Just tested it on my setup (Mac -> server, Windows -> client) and it doesn't work.. I guess the scroll lock command must come from the server and not the client.

 

EDIT: If I user my windows as the server then this works. Sadly I need to use my mac as a server, so this does not work for me. But for the other cases where you are using windows as server and your computer does not have a scroll lock key this is a workaround to the problem

I haven't used a Mac in years, so I'm not sure how helpful this will be.

Also, I don't know if scroll lock toggle functionality is supported on the Mac Synergy app, but I found this: https://www.apple.com/shop/question/answers/readonly/which-function-is-equivalent-to-the-pc-scroll-lock-key/QF2Y4XCJACT4FYFDA

It suggests:

  • F14 (extended keyboard)
  • Shift+F14 (extended keyboard)
  • Virtual Keyboard (keyboard icon in taskbar)
  • Shift+Fn+F12 (Macbook pro?)

Share this post


Link to post
Share on other sites
12 minutes ago, Jay M said:

I haven't used a Mac in years, so I'm not sure how helpful this will be.

Also, I don't know if scroll lock toggle functionality is supported on the Mac Synergy app, but I found this: https://www.apple.com/shop/question/answers/readonly/which-function-is-equivalent-to-the-pc-scroll-lock-key/QF2Y4XCJACT4FYFDA

It suggests:

  • F14 (extended keyboard)
  • Shift+F14 (extended keyboard)
  • Virtual Keyboard (keyboard icon in taskbar)
  • Shift+Fn+F12 (Macbook pro?)

I've already tried them all but none works. I have an extended keyboard. Also tried downloading a virtual keyboard app but still no scroll lock functionality. Couldn't find it again, but I read some time ago that OSX does not have scroll lock functionality, and instead the app that wants to use it must include this functionality. I guess I have to wait for the day I can modify Synergy hotkeys

Share this post


Link to post
Share on other sites

Scroll Lock is locking the mouse to one screen in Synergy 2. However, many (most?) games also required the relative mouse setting in Synergy 1 for the mouse to behave properly. There is no such option in Synergy 2. Either adding a configuration option to use the relative mouse mode is needed or having Synergy 2 automatically toggle to that mode when Scroll Lock is used to lock the cursor is needed before I can use Synergy 2. I am currently moving back to Synergy 1 and am seriously considering a request for a refund on Synergy 2 based on the response I got from support. I cannot use Synergy 2 in this current state.

Edited by Themicles

Share this post


Link to post
Share on other sites

I want to be able to full screen game on one computer, and move to my second computer without the game tabbing out. That was doable with Synergy 1. 

Share this post


Link to post
Share on other sites
On 12/16/2017 at 8:46 AM, Themicles said:

Scroll Lock is locking the mouse to one screen in Synergy 2. However, many (most?) games also required the relative mouse setting in Synergy 1 for the mouse to behave properly. There is no such option in Synergy 2. Either adding a configuration option to use the relative mouse mode is needed or having Synergy 2 automatically toggle to that mode when Scroll Lock is used to lock the cursor is needed before I can use Synergy 2. I am currently moving back to Synergy 1 and am seriously considering a request for a refund on Synergy 2 based on the response I got from support. I cannot use Synergy 2 in this current state.

There actually is a config option for the relative mouse, but there isnt a options menu so you gotta manually change it in the files. you can find it in AppData\Local\Symless\synergy.conf, you can open it with notepad and edit the things inside.

the option is called relativeMouseMoves. theres also some other options like screen saver sync and switch corners(i got no idea what this does?)

Share this post


Link to post
Share on other sites

I don't think you can successfully change config via the synergy.conf file.  I tested this by changing the setting, restarting the service and checking the config.  It reverts back to false.

Share this post


Link to post
Share on other sites

I will test it later, though I see someone already did and it reverted. Here's hoping that since it is still in the code, that they'll allow us to configure that option properly in a future version. Yeah, the auto-config and any keyboard/mouse can be used to control any connected computer are steps forward. But some of the configuration options we've lost are definitely steps backward. While I don't have a need for hotkeys right now, I know from looking at forum posts, many used them, and those too are missing. :-/

Thanks for the tip HenryC. Hopefully there's a way to work around what VooPoc reported.

Share this post


Link to post
Share on other sites

The config file gets updated from the cloud service. I have read a few posts that have changed the file to read only. Maybe try that. 

It will mean that UI changes will not be implemented.

stuart

Edited by stuart macmillan

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now