IT Troll

Cannot relaunch Mac GUI

15 posts in this topic

yes, on linux if I "force" close the window it sometimes doesnt start again.

saldy my WM only allows this way of closing a window, but other WMs have the same issue.

WM stands for window manager btw(basicly the GUI of the OS)

Share this post


Link to post
Share on other sites

I'm not force quiting, just clicking the regular close button on the window.

Share this post


Link to post
Share on other sites
5 minutes ago, IT Troll said:

I'm not force quiting, just clicking the regular close button on the window.

I dont know how the closing is handled in mac, but it might have give the same result.

Share this post


Link to post
Share on other sites

I'm seeing the same problem. Worse, I need to revert due to lack of CMD-key mapping and there's no way to find or shut down the old process. That's a major bug.

Share this post


Link to post
Share on other sites

Syn 2.0 stable/Mac OS X 10.11.4/Ubuntu 16.04.   I'm experiencing an inability to get the GUI back after first load, also am unable to kill the synergy application using Force Quit.  Killing the process with Activity monitor doesn't seem to remove the zombies.   This becomes a problem after a computer goes to "sleep" and I want to start using the mouse.  Restarting on Ubuntu is no problem, but attempting restart on Mac was impossible today without full reboot.  Occasionally, I've had to hard power off (assuming due to unkillable application).  Notice to two synergy icons in picture below, and the "Application Not Responding" message.

 

Screen Shot 2017-11-07 at 3.26.45 PM.png

Share this post


Link to post
Share on other sites

It's a known bug, we're working on it. The workaround is to run this from Terminal:

open -n /Applications/Synergy.app

macOS is confusing the core for the config app, so it thinks it's already open.

  • Thanks 1

Share this post


Link to post
Share on other sites

Good to hear it is not just me.

Being able to see the GUI is kind of fundamental for a stable commercial release. ;)

Share this post


Link to post
Share on other sites
16 minutes ago, IT Troll said:

Being able to see the GUI is kind of fundamental for a stable commercial release. ;)

We're urgently working on a fix for this.

  • Like 1

Share this post


Link to post
Share on other sites
10 hours ago, Nick Bolton said:

It's a known bug, we're working on it. The workaround is to run this from Terminal:

open -n /Applications/Synergy.app

macOS is confusing the core for the config app, so it thinks it's already open.

this works for me, thanks!

 

Share this post


Link to post
Share on other sites

I have this problem too on the Mac side.  The "open" workaround is working for me.

Generally speaking I have to say Synergy 2 (all the betas I tried and now the 2.0.0-stable) are NOT very stable using Windows 10 x64 and Mac OS Sierra (10.12.6).  It seems like most anything will interrupt the connection, locking the screen on either side, waiting overnight, and often for no discernible reason.  Restoring it is often bringing up the GUI on one side, hit F12, bring it up on the other side, hit F12, lather, rinse, repeat, and then it comes up for a while.  When that doesn't work, killing the service on the Mac and/or restarting it on the PC seems to get it going again.  It works, but the whole point is to be efficient with the K/M - having to spend all this time to make the connection work, often, is not efficient.

Also I discovered something that is probably obvious to most Synergy 2 users, but it was not to me, so I will share it:  You can pass control from one side to the other by just hitting the space bar on the desired side.  In other words, space bar on the Mac and it takes over using Mac keyboard and mouse.  Then hitting space bar on the PC side, and it takes over using PC keyboard and mouse.  I gather Synergy 2 doesn't enforce the concept of Server and Client in the same way as Synergy 1.  That's OK and sometimes just hitting the space bar on one side then the other fixes the connection.  Still not super efficient, but better than the rigamarole mentioned above.  I don't usually need to pass control from one side to the other, but when the key mapping is not working correctly for some reason, it helps.

Share this post


Link to post
Share on other sites

Just upgraded to 2.0.1, I can't find a change log, but it looks like this GUI problem is still not fixed. :|

Edited by IT Troll

Share this post


Link to post
Share on other sites

Just upgraded to 2.0.2, I can't find a change log, but it looks like this GUI problem is still not fixed. Must be a really tough one to crack. :/

Share this post


Link to post
Share on other sites

just wanted to add a me too on this bug. Glad to hear its being worked on

 

Share this post


Link to post
Share on other sites

Dec 15th, v2.0.3 I don't know how this can be considered stable. I feel sorry for anyone who's paid full price for an app that won't even open. I mean the workaround works, however this is not good UX.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now