Sign in to follow this  
Isaac To

Copying text from OS X to Windows (1.7.2 and 1.7.3)

3 posts in this topic

Copying text from OS X to Windows fails most of the time on both 1.7.2 and 1.7.3. I am running OS X 10.10.3 and Windows 8.1.

Share this post


Link to post
Share on other sites
Have you found a fix? I have this problem all the time. The only fix is to stop and start the server process, clipboard transfers fine for a few days again. Happening right now between synergy-v1.7.3-stable-efd0108-Windows-x64 (server) and synergy-v1.7.3-stable-efd0108-Linux-i686.deb

Share this post


Link to post
Share on other sites
I have a feeling that certain apps are 'more sensitive' to copy & paste not working.. One stupid thing I tried was that often copy & paste from a browser on windows to 'somewhere' on osx doesn't work. However if I copy & paste from e.g. the browser on windows to notepad on the same machine, then ctrl+a / ctrl+c from notepad - and [i]then[/i] paste on osx it DOES work ( most of the time ). Haven't tried enough to be able to really tell accurately when it does or does-not work, but I'll try and keep and eye on it and try and pinpoint it down further. However I think we can all agree that's it's [b]really [/b]annoying when it doesn't work, and it would be nice if this issue were looked into.

Share this post


Link to post
Share on other sites
Isaac, Ryan, and JHP, It would be helpful to get some more details about the clipboard issues. Some issues have a simple work-around, others have been fixed already in the latest nightly version, still others might be solved for the 1.7.4 version. I don't know enough about your issues to have much insight, be here are some workarounds that often work: - turning off clipboard manager programs such as Glipper/Glippy/Klipper) - copy/pasting first into a plain-text app on same system, then copying that content to paste into other system - disabling SSL - after copying, moving mouse to destination system then back to origin system then to destination system again before paste - if a system is in elevated mode, running not-elevated (or vice-versa) I hope you will let us know the answers to these questions: - exact behavior when something crashes/doesn't work - does Synergy continue working otherwise? - minimum steps to make Synergy work again if it closes/crashes/stops - Synbergy log content for each system involved, with logging level set to at least Debug - SSL enabled? - Synergy in "elevated" mode? - size of content copied (exact size in bytes, if possible) - where copied (application, OS, is it a Synergy server or client)? - where pasted? - problem occurs one-way, or both-ways? - if successful in copy-pasting opposite way, does copy-paste the original way then work? - intermittent? - copying plain-text? - are any non-English characters involved? - are any clipboard managers such as Glipper, Glippy, or Klipper running?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this