jml

Beta 5 non-functional on Mint 18.1

3 posts in this topic

Cleaned out all Synergy installations, reinstalled, rebooted. Service starts correctly but F12 does nothing. Clicking on the Synergy icon brings up the usual blue background but there seems to be no functionality (right- or left-clicking does nothing). Suspect a UI issue interfacing with Cinnamon.

Service startup:

● synergy.service - Synergy Service
   Loaded: loaded (/lib/systemd/system/synergy.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2017-11-03 07:26:21 EDT; 2min 9s ago
 Main PID: 2234 (synergy-service)
   CGroup: /system.slice/synergy.service
           └─2234 /usr/bin/synergy-service

Nov 03 07:26:21 brie synergy-service[2234]: [ Service ] [2017-11-03T07:26:21] info: starting service...
Nov 03 07:26:21 brie synergy-service[2234]: [ Router  ] [2017-11-03T07:26:21] debug: router log path: /var/log/synergy/synergy-router.log
Nov 03 07:26:21 brie synergy-service[2234]: [ Router  ] [2017-11-03T07:26:21] debug: ID = 805154543, Name = ''
Nov 03 07:26:21 brie synergy-service[2234]: [ Service ] [2017-11-03T07:26:21] debug: setting core uid from config: 1000
Nov 03 07:26:21 brie synergy-service[2234]: [ Service ] [2017-11-03T07:26:21] debug: creating rpc endpoints
Nov 03 07:26:21 brie synergy-service[2234]: [ Service ] [2017-11-03T07:26:21] debug: rpc endpoints created
Nov 03 07:26:36 brie synergy-service[2234]: [ Service ] [2017-11-03T07:26:36] debug: saying hello to config ui
Nov 03 07:26:36 brie synergy-service[2234]: [ Service ] [2017-11-03T07:26:36] debug: config ui opened, forcing connectivity test
Nov 03 07:26:36 brie synergy-service[2234]: [ Service ] [2017-11-03T07:26:36] debug: handling local profile screen set changed, mode=unknown
Nov 03 07:26:36 brie synergy-service[2234]: [ Service ] [2017-11-03T07:26:36] debug: setting core uid from rpc: 1000

Nothing of real value in the logs (so short that I'll paste them here):

[ Service ] [2017-11-03T06:53:32] debug: service log path: /var/log/synergy/synergy-service.log
[ Service ] [2017-11-03T06:53:32] debug: install dir: /usr/bin
[ Service ] [2017-11-03T06:53:32] info: starting service...
[ Service ] [2017-11-03T06:53:32] debug: core uid is unknown
[ Service ] [2017-11-03T06:53:32] debug: creating rpc endpoints
[ Service ] [2017-11-03T06:53:32] debug: rpc endpoints created
[ Service ] [2017-11-03T06:56:24] debug: core process is not running, ignoring shutdown
[ Service ] [2017-11-03T06:56:24] debug: core process is not running, ignoring shutdown
[ Service ] [2017-11-03T07:00:20] debug: service log path: /var/log/synergy/synergy-service.log
[ Service ] [2017-11-03T07:00:20] debug: install dir: /usr/bin
[ Service ] [2017-11-03T07:00:20] info: starting service...
[ Service ] [2017-11-03T07:00:21] debug: core uid is unknown
[ Service ] [2017-11-03T07:00:21] debug: creating rpc endpoints
[ Service ] [2017-11-03T07:00:21] debug: rpc endpoints created
[ Service ] [2017-11-03T07:02:05] debug: saying hello to config ui
[ Service ] [2017-11-03T07:02:05] debug: config ui opened, forcing connectivity test
[ Service ] [2017-11-03T07:02:05] debug: handling local profile screen set changed, mode=unknown
[ Service ] [2017-11-03T07:02:05] debug: setting core uid from rpc: 1000
[ Service ] [2017-11-03T07:10:21] debug: core process is not running, ignoring shutdown
[ Service ] [2017-11-03T07:10:21] debug: core process is not running, ignoring shutdown
[ Service ] [2017-11-03T07:10:21] debug: service log path: /var/log/synergy/synergy-service.log
[ Service ] [2017-11-03T07:10:21] debug: install dir: /usr/bin
[ Service ] [2017-11-03T07:10:21] info: starting service...
[ Service ] [2017-11-03T07:10:21] debug: setting core uid from config: 1000
[ Service ] [2017-11-03T07:10:21] debug: creating rpc endpoints
[ Service ] [2017-11-03T07:10:21] debug: rpc endpoints created
[ Service ] [2017-11-03T07:12:12] debug: saying hello to config ui
[ Service ] [2017-11-03T07:12:12] debug: config ui opened, forcing connectivity test
[ Service ] [2017-11-03T07:12:12] debug: handling local profile screen set changed, mode=unknown
[ Service ] [2017-11-03T07:12:12] debug: setting core uid from rpc: 1000
[ Service ] [2017-11-03T07:13:01] debug: core process is not running, ignoring shutdown
[ Service ] [2017-11-03T07:13:01] debug: core process is not running, ignoring shutdown
[ Service ] [2017-11-03T07:26:21] debug: service log path: /var/log/synergy/synergy-service.log
[ Service ] [2017-11-03T07:26:21] debug: install dir: /usr/bin
[ Service ] [2017-11-03T07:26:21] info: starting service...
[ Service ] [2017-11-03T07:26:21] debug: setting core uid from config: 1000
[ Service ] [2017-11-03T07:26:21] debug: creating rpc endpoints
[ Service ] [2017-11-03T07:26:21] debug: rpc endpoints created
[ Service ] [2017-11-03T07:26:36] debug: saying hello to config ui
[ Service ] [2017-11-03T07:26:36] debug: config ui opened, forcing connectivity test
[ Service ] [2017-11-03T07:26:36] debug: handling local profile screen set changed, mode=unknown
[ Service ] [2017-11-03T07:26:36] debug: setting core uid from rpc: 1000

[ Router  ] [2017-11-03T06:53:32] debug: router log path: /var/log/synergy/synergy-router.log
[ Router  ] [2017-11-03T06:53:32] debug: ID = 3533594351, Name = ''
[ Router  ] [2017-11-03T07:00:21] debug: router log path: /var/log/synergy/synergy-router.log
[ Router  ] [2017-11-03T07:00:21] debug: ID = 770494191, Name = ''
[ Router  ] [2017-11-03T07:10:21] debug: router log path: /var/log/synergy/synergy-router.log
[ Router  ] [2017-11-03T07:10:21] debug: ID = 1791827695, Name = ''
[ Router  ] [2017-11-03T07:26:21] debug: router log path: /var/log/synergy/synergy-router.log
[ Router  ] [2017-11-03T07:26:21] debug: ID = 805154543, Name = ''
 

 

 

 

Share this post


Link to post
Share on other sites
On 11/3/2017 at 11:40 AM, jml said:

Clicking on the Synergy icon brings up the usual blue background but there seems to be no functionality

How about with RC1?

Share this post


Link to post
Share on other sites

Unfortunately I'll be OOO till the 13th. Will try it then and post results...

  • Thanks 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now