Cheryl Lomedico

Problem connecting to background service

10 posts in this topic

Installs on Win10 and Mac (Sierra) went smooth...  synergy desktop kept restarting in task manager. Had to stop it for Windows client to install. Had to reboot for both to see each other. 

so it has been about 15 mins... I will update if there are issues throughout the day.

 

Share this post


Link to post
Share on other sites

Hi, I'm on Mac OS 10.11.6. Synergy 2 beta 4 was working fine. it told me to update to beta5, and now it doesn't work at all.. (my PC works fine it seems). I restarted my mac pro, still nothing. i opened the Activity monitor app but there is no "Synergy-service" process... just a "synergy"  one. What do I do?

Share this post


Link to post
Share on other sites

Report on Linux for 2.0b5 sent, here is MacOS report. Running 10.11.6, after installing beta5 I launched and got screen informing me it was having trouble connecting to backend. I tried manually starting synergy-service with this result:

[stable][email protected]:~/Library $ sudo su -

Password:

san-2mjaffe-m:~ root# cd /Applications/Synergy.app/Contents/MacOS/

san-2mjaffe-m:MacOS root# ls -l

total 64384

-rwxr-xr-x  1 mjaffe  admin    388144 Oct 30 17:31 crashpad_handler

-rwxr-xr-x  1 mjaffe  admin   9890896 Oct 30 17:31 synergy-config

-rwxr-xr-x  1 mjaffe  admin   3428144 Oct 30 17:31 synergy-core

-rwxr-xr-x  1 mjaffe  admin  10539200 Oct 30 17:31 synergy-service

-rwxr-xr-x  1 mjaffe  admin   8710752 Oct 30 17:31 synergy-tests

san-2mjaffe-m:MacOS root# ./synergy-service &

[1] 69557

san-2mjaffe-m:MacOS root# [ Service ] [2017-10-31T11:13:47] debug: service log path: /var/root/Library/Synergy/synergy-service.log

[ Service ] [2017-10-31T11:13:47] debug: install dir: /Applications/Synergy.app/Contents/MacOS/.

[ Service ] [2017-10-31T11:13:47] info: starting service...

[ Router  ] [2017-10-31T11:13:47] debug: router log path: /var/root/Library/Synergy/synergy-router.log

[ Router  ] [2017-10-31T11:13:47] debug: ID = 0, Name = ''

[ Service ] [2017-10-31T11:13:47] debug: creating rpc endpoints

[ Service ] [2017-10-31T11:13:47] debug: rpc endpoints created

[ Service ] [2017-10-31T11:14:00] debug: saying hello to config ui

[ Service ] [2017-10-31T11:14:00] debug: config ui opened, forcing connectivity test

[ Service ] [2017-10-31T11:14:00] debug: handling local profile screen set changed, mode=unknown

[ Service ] [2017-10-31T11:14:01] error: can't send profile snapshot, not yet received from cloud

[ Service ] [2017-10-31T11:14:02] debug: connecting websocket

[ Service ] [2017-10-31T11:14:02] debug: cloud client connected

[ Service ] [2017-10-31T11:14:02] debug: websocket connected

[ Service ] [2017-10-31T11:14:02] debug: comparing profiles, id=-1 this=v-1 other=v14

[ Service ] [2017-10-31T11:14:02] debug: profile id changed, -1->7692

[ Service ] [2017-10-31T11:14:02] debug: profile name changed, ->default

[ Service ] [2017-10-31T11:14:02] debug: profile server changed, -1->18887

[ Service ] [2017-10-31T11:14:02] debug: profile screen set changed, added=2 removed=0

[ Service ] [2017-10-31T11:14:02] debug: profile changed, storing local copy

[ Service ] [2017-10-31T11:14:02] debug: handling local profile server changed, mode=unknown thisId=18887 serverId=18887 lastServerId=-1

[ Service ] [2017-10-31T11:14:02] debug: starting core server process

[ Service ] [2017-10-31T11:14:02] debug: starting core process with command: /Applications/Synergy.app/Contents/MacOS/./synergy-core --server -f --debug DEBUG --name san-2mjaffe-m.corporate.local.tivo.com --enable-drag-drop --profile-dir /var/root/Library/Synergy --log /var/root/Library/Synergy/synergy-core.log -c /var/root/Library/Synergy/synergy.conf --address :24800

[ Service ] [2017-10-31T11:14:02] debug: core process started, id=69573

[ Service ] [2017-10-31T11:14:02] debug: handling local profile screen set changed, mode=server

[ Service ] [2017-10-31T11:14:02] debug: starting core server process

[ Service ] [2017-10-31T11:14:02] debug: core process already running, attempting to stop

[ Service ] [2017-10-31T11:14:02] debug: stopping core process

[ Router  ] [2017-10-31T11:14:02] debug: Adding 10.100.50.217:24802

[ Router  ] [2017-10-31T11:14:02] debug: Connecting to 10.100.50.217:24802 (attempt 1/10)

[ Router  ] [2017-10-31T11:14:02] debug: Adding 10.101.197.205:24802

[ Router  ] [2017-10-31T11:14:02] debug: Connecting to 10.101.197.205:24802 (attempt 1/10)

[ Router  ] [2017-10-31T11:14:02] debug: Connection 1 created

[ Router  ] [2017-10-31T11:14:02] debug: Accepted connection from router 10.100.50.217:64987

[ Router  ] [2017-10-31T11:14:02] debug: Connection 2 created

[ Router  ] [2017-10-31T11:14:02] debug: Connection 3 created

[69559:2937744:20171031,111402.802615:ERROR mach_extensions.cc:68] bootstrap_look_up com.apple.ReportCrash: Unknown service name (1102)



[1]+  Segmentation fault: 11  ./synergy-service

san-2mjaffe-m:MacOS root# ps -ef | grep -i syne | grep -v grep

796832397 69569     1   0 11:14AM ??         0:00.01 /Applications/Synergy.app/Contents/MacOS/crashpad_handler --no-rate-limit --database=/Users/mjaffe/Library/Synergy/dumps --metrics-dir=/Users/mjaffe/Library/Synergy/dumps --url=https://synergy.sp.backtrace.io:6098 --annotation=format=minidump --annotation=token=cc4db6ef2d4731b276b0a111979336443dc0372624effb79d8b29b26a200e1c6 --handshake-fd=10

796832397 69584     1   0 11:14AM ??         0:01.14 /Applications/Synergy.app/Contents/MacOS/synergy-config

796832397 69587     1   0 11:14AM ??         0:00.01 /Applications/Synergy.app/Contents/MacOS/crashpad_handler --no-rate-limit --database=/Users/mjaffe/Library/Synergy/dumps --metrics-dir=/Users/mjaffe/Library/Synergy/dumps --url=https://synergy.sp.backtrace.io:6098 --annotation=format=minidump --annotation=token=cc4db6ef2d4731b276b0a111979336443dc0372624effb79d8b29b26a200e1c6 --handshake-fd=15

 

Screen Shot 2017-10-31 at 11.18.45 AM.png

Share this post


Link to post
Share on other sites

My log:

 

2017-10-30T09:37:34] debug: websocket read error: Connection reset by peer
[2017-10-31T10:16:20] debug: service log path: /Users/franciscoburgos/Library/Synergy/synergy-service.log
[2017-10-31T10:16:20] error: failed to start crash handler: Couldn't verify crash dump directory: No such file or directory
[2017-10-31T10:16:20] info: starting service...
[2017-10-31T10:16:20] debug: connecting websocket
[2017-10-31T10:16:20] debug: connectivity test server started
[2017-10-31T10:16:20] debug: creating rpc endpoints
[2017-10-31T10:16:20] debug: rpc endpoints created
[2017-10-31T10:16:20] info: service started successfully
[2017-10-31T10:16:21] debug: websocket connected
[2017-10-31T10:16:21] debug: comparing profiles, id=-1 this=v-1 other=v12
[2017-10-31T10:16:21] debug: profile id changed, -1->8197
[2017-10-31T10:16:21] debug: profile name changed, ->default
[2017-10-31T10:16:21] debug: profile server changed, -1->16305
[2017-10-31T10:16:21] debug: profile screen set changed, added=2 removed=0
[2017-10-31T10:16:21] debug: new screens detected (2), preparing connectivity test
[2017-10-31T10:16:21] debug: starting connectivity test
[2017-10-31T10:16:21] debug: profile changed, storing local copy
[2017-10-31T10:16:21] debug: handling local profile server changed, mode=unknown thisId=16305 serverId=16305 lastServerId=-1
[2017-10-31T10:16:21] debug: starting core server process
[2017-10-31T10:16:22] debug: starting core process with command: /Applications/Synergy.app/Contents/MacOS/synergys -f --no-tray --debug DEBUG --name Franciscos-Mac-Pro.local --enable-drag-drop --profile-dir /Users/franciscoburgos/Library/Synergy --log synergy.log -c /Users/franciscoburgos/Library/Synergy/synergy.conf --address :24800
[2017-10-31T10:16:22] debug: core process started, id=526
[2017-10-31T10:16:22] debug: handling local profile screen set changed, mode=server
[2017-10-31T10:16:22] debug: starting core server process
[2017-10-31T10:16:25] debug: process already running, attempting to stop
[2017-10-31T10:16:25] debug: stopping core process
[2017-10-31T10:16:25] debug: failed report: dest = 16306, ips = 192.168.0.15
[2017-10-31T10:16:25] debug: local profile modified, id=8197
[2017-10-31T10:16:25] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:16:25] debug: profile screen test result changed, screenId=16306 success=``->`` failed=``->`192.168.0.15`
[2017-10-31T10:16:25] debug: handling new report from connectivity tester, screenId=16306 successfulIp= lastServerId=16305
[2017-10-31T10:16:25] debug: finished connectivity test
[2017-10-31T10:16:25] debug: core process exited: code=0 expected=true
[2017-10-31T10:16:25] debug: core process shutdown complete
[2017-10-31T10:16:25] debug: starting core process with command: /Applications/Synergy.app/Contents/MacOS/synergys -f --no-tray --debug DEBUG --name Franciscos-Mac-Pro.local --enable-drag-drop --profile-dir /Users/franciscoburgos/Library/Synergy --log synergy.log -c /Users/franciscoburgos/Library/Synergy/synergy.conf --address :24800
[2017-10-31T10:16:26] debug: core process started, id=537
[2017-10-31T10:17:21] debug: sending last profile snapshot
[2017-10-31T10:17:21] debug: config ui opened, forcing connectivity test
[2017-10-31T10:17:21] debug: new screens detected (2), preparing connectivity test
[2017-10-31T10:17:21] debug: starting connectivity test
[2017-10-31T10:17:21] debug: handling local profile screen set changed, mode=server
[2017-10-31T10:17:21] debug: starting core server process
[2017-10-31T10:17:22] debug: process already running, attempting to stop
[2017-10-31T10:17:22] debug: stopping core process
[2017-10-31T10:17:22] debug: core process exited: code=0 expected=true
[2017-10-31T10:17:22] debug: core process shutdown complete
[2017-10-31T10:17:22] debug: starting core process with command: /Applications/Synergy.app/Contents/MacOS/synergys -f --no-tray --debug DEBUG --name Franciscos-Mac-Pro.local --enable-drag-drop --profile-dir /Users/franciscoburgos/Library/Synergy --log synergy.log -c /Users/franciscoburgos/Library/Synergy/synergy.conf --address :24800
[2017-10-31T10:17:22] debug: core process started, id=618
[2017-10-31T10:17:22] debug: connectivity test passed for 192.168.0.15:24810
[2017-10-31T10:17:23] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:17:23] debug: profile screen status changed, screenId=16305 Connected->Connecting
[2017-10-31T10:17:23] debug: profile screen test result changed, screenId=16306 success=``->`` failed=`192.168.0.15`->``
[2017-10-31T10:17:23] debug: profile changed, storing local copy
[2017-10-31T10:17:23] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:17:23] debug: profile screen status changed, screenId=16305 Connecting->Connected
[2017-10-31T10:17:23] debug: profile changed, storing local copy
[2017-10-31T10:17:23] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:17:23] debug: profile has not changed, no action needed
[2017-10-31T10:17:24] debug: successful report: dest = 16306, ips = 192.168.0.15
[2017-10-31T10:17:24] debug: local profile modified, id=8197
[2017-10-31T10:17:24] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:17:24] debug: profile screen test result changed, screenId=16306 success=``->`192.168.0.15` failed=``->``
[2017-10-31T10:17:24] debug: handling new report from connectivity tester, screenId=16306 successfulIp=192.168.0.15 lastServerId=16305
[2017-10-31T10:17:24] debug: finished connectivity test
[2017-10-31T10:24:18] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:24:18] debug: profile screen test result changed, screenId=16306 success=`192.168.0.15`->`` failed=``->``
[2017-10-31T10:24:18] debug: profile changed, storing local copy
[2017-10-31T10:24:18] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:24:18] debug: profile screen status changed, screenId=16306 Connected->Disconnected
[2017-10-31T10:24:18] debug: profile changed, storing local copy
[2017-10-31T10:24:18] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:24:18] debug: profile screen status changed, screenId=16306 Disconnected->Connecting
[2017-10-31T10:24:18] debug: profile changed, storing local copy
[2017-10-31T10:24:28] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:24:28] debug: profile has not changed, no action needed
[2017-10-31T10:24:38] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:24:38] debug: profile has not changed, no action needed
[2017-10-31T10:24:49] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:24:49] debug: profile has not changed, no action needed
[2017-10-31T10:24:58] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:24:58] debug: profile has not changed, no action needed
 

Share this post


Link to post
Share on other sites

I can't get Beta 5 working, attempted process restarts, reboots.  Mac OS 10.11.4 El Capitan, Ubuntu 16.04 .  Getting "There was a problem connecting to the background service" in both machines.    Attempted starting synergy-service from the command line in both computers.  I have all 3 synergy processes running in Ubuntu, in Mac, I cannot get synergy-service to survive for more than a few seconds.  I notice this in the logs:

[ Core     ] [2017-10-31T12:31:38] debug: [2017-10-31T12:31:38] FATAL: An error occurred: assistive devices does not trust this process, allow it in system settings.

I check Preferences->Security & Privacy->Privacy and see that synergy has "Allow the apps below to control your computer".  I uncheck and re-add, but the fatal error does not change.  Reverting to Beta 4.

Thanks,

Marco

RCOs-Mac-mini:MacOS marcozirino$ /Applications/Synergy.app/Contents/MacOS/synergy-service &
[1] 649
MARCOs-Mac-mini:MacOS marcozirino$ [ Service  ] [2017-10-31T12:31:37] debug: service log path: /Users/marcozirino/Library/Synergy/synergy-service.log
[ Service  ] [2017-10-31T12:31:37] debug: install dir: /Applications/Synergy.app/Contents/MacOS
[ Service  ] [2017-10-31T12:31:37] info: starting service...
[ Service  ] [2017-10-31T12:31:37] debug: connecting websocket
[ Router   ] [2017-10-31T12:31:37] debug: router log path: /Users/marcozirino/Library/Synergy/synergy-router.log
[ Router   ] [2017-10-31T12:31:37] debug: ID = 0, Name = ''
[ Service  ] [2017-10-31T12:31:37] debug: creating rpc endpoints
[ Service  ] [2017-10-31T12:31:37] debug: rpc endpoints created
[ Service  ] [2017-10-31T12:31:38] debug: cloud client connected
[ Service  ] [2017-10-31T12:31:38] debug: websocket connected
[ Service  ] [2017-10-31T12:31:38] debug: comparing profiles, id=-1 this=v-1 other=v8
[ Service  ] [2017-10-31T12:31:38] debug: profile id changed, -1->7680
[ Service  ] [2017-10-31T12:31:38] debug: profile name changed, ->default
[ Service  ] [2017-10-31T12:31:38] debug: profile server changed, -1->15182
[ Service  ] [2017-10-31T12:31:38] debug: profile screen set changed, added=2 removed=0
[ Service  ] [2017-10-31T12:31:38] debug: profile changed, storing local copy
[ Service  ] [2017-10-31T12:31:38] debug: handling local profile server changed, mode=unknown thisId=15182 serverId=15182 lastServerId=-1
[ Service  ] [2017-10-31T12:31:38] debug: starting core server process
[ Service  ] [2017-10-31T12:31:38] debug: starting core process with command: /Applications/Synergy.app/Contents/MacOS/synergy-core --server -f --debug DEBUG --name MARCOs-Mac-mini.local --enable-drag-drop --profile-dir /Users/marcozirino/Library/Synergy --log /Users/marcozirino/Library/Synergy/synergy-core.log -c /Users/marcozirino/Library/Synergy/synergy.conf --address :24800
[ Service  ] [2017-10-31T12:31:38] debug: core process started, id=652
[ Service  ] [2017-10-31T12:31:38] debug: handling local profile screen set changed, mode=server
[ Service  ] [2017-10-31T12:31:38] debug: starting core server process
[ Service  ] [2017-10-31T12:31:38] debug: core process already running, attempting to stop
[ Service  ] [2017-10-31T12:31:38] debug: stopping core process
[ Router   ] [2017-10-31T12:31:38] debug: Adding 10.42.0.2:24802
[ Router   ] [2017-10-31T12:31:38] debug: Connecting to 10.42.0.2:24802 (attempt 1/10)
[ Router   ] [2017-10-31T12:31:38] debug: Adding 192.168.1.26:24802
[ Router   ] [2017-10-31T12:31:38] debug: Connecting to 192.168.1.26:24802 (attempt 1/10)
[ Router   ] [2017-10-31T12:31:38] debug: Adding 10.42.0.1:24802
[ Router   ] [2017-10-31T12:31:38] debug: Connecting to 10.42.0.1:24802 (attempt 1/10)
[ Router   ] [2017-10-31T12:31:38] debug: Adding 172.17.0.1:24802
[ Router   ] [2017-10-31T12:31:38] debug: Connecting to 172.17.0.1:24802 (attempt 1/10)
[ Router   ] [2017-10-31T12:31:38] debug: Adding 172.18.0.1:24802
[ Router   ] [2017-10-31T12:31:38] debug: Connecting to 172.18.0.1:24802 (attempt 1/10)
[ Router   ] [2017-10-31T12:31:38] debug: Adding 172.19.0.1:24802
[ Router   ] [2017-10-31T12:31:38] debug: Connecting to 172.19.0.1:24802 (attempt 1/10)
[ Router   ] [2017-10-31T12:31:38] debug: Adding 172.20.0.1:24802
[ Router   ] [2017-10-31T12:31:38] debug: Connecting to 172.20.0.1:24802 (attempt 1/10)
[ Router   ] [2017-10-31T12:31:38] debug: Adding 172.21.0.1:24802
[ Router   ] [2017-10-31T12:31:38] debug: Connecting to 172.21.0.1:24802 (attempt 1/10)
[ Router   ] [2017-10-31T12:31:38] debug: Adding 192.168.1.3:24802
[ Router   ] [2017-10-31T12:31:38] debug: Connecting to 192.168.1.3:24802 (attempt 1/10)
[ Router   ] [2017-10-31T12:31:38] debug: Accepted connection from router 10.42.0.2:49353
[ Router   ] [2017-10-31T12:31:38] debug: Connection 1 created
[ Router   ] [2017-10-31T12:31:38] debug: Connection 2 created
[ Router   ] [2017-10-31T12:31:38] debug: Connection 3 created
[ Router   ] [2017-10-31T12:31:38] debug: Connection 4 created
[ Router   ] [2017-10-31T12:31:38] debug: Successfully connected to 10.42.0.2:24802
[ Router   ] [2017-10-31T12:31:38] debug: Accepted connection from router 192.168.1.26:49354
[ Router   ] [2017-10-31T12:31:38] debug: Connection 5 created
[ Router   ] [2017-10-31T12:31:38] debug: Successfully connected to 10.42.0.2:24802
[ Router   ] [2017-10-31T12:31:38] debug: Received route advertisement from router 15182
[ Router   ] [2017-10-31T12:31:38] debug:  Received own route advertisement. This indicates a loop. Ignoring
[ Router   ] [2017-10-31T12:31:38] debug: Successfully connected to 10.42.0.1:24802
[ Router   ] [2017-10-31T12:31:38] debug: Received route advertisement from router 15182
[ Router   ] [2017-10-31T12:31:38] debug:  Received own route advertisement. This indicates a loop. Ignoring
[ Router   ] [2017-10-31T12:31:38] debug: Received route advertisement from router 15181
[ Router   ] [2017-10-31T12:31:38] debug: Installing routes received from router 15181
[ Router   ] [2017-10-31T12:31:38] debug:    Route 1: dest 15181, cost 0, path []
[ Router   ] [2017-10-31T12:31:38] debug:     Route 1: installed
[ Router   ] [2017-10-31T12:31:38] debug: Route table contents:
[ Router   ] [2017-10-31T12:31:38] debug:    Route 1: dest 15181, cost 1, path [15181]
[ Router   ] [2017-10-31T12:31:38] debug: Successfully connected to 192.168.1.26:24802
[ Router   ] [2017-10-31T12:31:38] debug: Successfully connected to 192.168.1.26:24802
[ Router   ] [2017-10-31T12:31:38] debug: Received route advertisement from router 15182
[ Router   ] [2017-10-31T12:31:38] debug:  Received own route advertisement. This indicates a loop. Ignoring
[ Router   ] [2017-10-31T12:31:38] debug: Received route advertisement from router 15182
[ Router   ] [2017-10-31T12:31:38] debug:  Received own route advertisement. This indicates a loop. Ignoring
[ Router   ] [2017-10-31T12:31:38] debug: Received route advertisement from router 15182
[ Router   ] [2017-10-31T12:31:38] debug:  Received own route advertisement. This indicates a loop. Ignoring
[ Router   ] [2017-10-31T12:31:38] debug: Received route advertisement from router 15182
[ Router   ] [2017-10-31T12:31:38] debug:  Received own route advertisement. This indicates a loop. Ignoring
[ Service  ] [2017-10-31T12:31:38] debug: core process exited: code=0 expected=true
[ Service  ] [2017-10-31T12:31:38] debug: core process shutdown complete
[ Service  ] [2017-10-31T12:31:38] debug: starting core process with command: /Applications/Synergy.app/Contents/MacOS/synergy-core --server -f --debug DEBUG --name MARCOs-Mac-mini.local --enable-drag-drop --profile-dir /Users/marcozirino/Library/Synergy --log /Users/marcozirino/Library/Synergy/synergy-core.log -c /Users/marcozirino/Library/Synergy/synergy.conf --address :24800
[ Service  ] [2017-10-31T12:31:38] debug: core process started, id=653
[ Core     ] [2017-10-31T12:31:38] debug: [2017-10-31T12:31:38] INFO: drag and drop enabled
[ Core     ] [2017-10-31T12:31:38] debug: [2017-10-31T12:31:38] DEBUG: opening configuration "/Users/marcozirino/Library/Synergy/synergy.conf"
[ Core     ] [2017-10-31T12:31:38] debug: [2017-10-31T12:31:38] DEBUG: configuration read successfully
[ Core     ] [2017-10-31T12:31:38] debug: [2017-10-31T12:31:38] DEBUG: screen shape: center=0,0 size=1920x1200 on 1 display
[ Core     ] [2017-10-31T12:31:38] debug: [2017-10-31T12:31:38] FATAL: An error occurred: assistive devices does not trust this process, allow it in system settings.
[ Core     ] [2017-10-31T12:31:38] debug: 
[ Service  ] [2017-10-31T12:31:38] debug: core process exited: code=1 expected=false
[ Service  ] [2017-10-31T12:31:38] debug: core process shutdown complete
[ Service  ] [2017-10-31T12:31:38] debug: starting core process with command: /Applications/Synergy.app/Contents/MacOS/synergy-core --server -f --debug DEBUG --name MARCOs-Mac-mini.local --enable-drag-drop --profile-dir /Users/marcozirino/Library/Synergy --log /Users/marcozirino/Library/Synergy/synergy-core.log -c /Users/marcozirino/Library/Synergy/synergy.conf --address :24800
[ Service  ] [2017-10-31T12:31:38] debug: core process started, id=654
[ Service  ] [2017-10-31T12:31:38] debug: core process shutdown complete
[ Service  ] [2017-10-31T12:31:38] debug: starting core process with command: /Applications/Synergy.app/Contents/MacOS/synergy-core --server -f --debug DEBUG --name MARCOs-Mac-mini.local --enable-drag-drop --profile-dir /Users/marcozirino/Library/Synergy --log /Users/marcozirino/Library/Synergy/synergy-core.log -c /Users/marcozirino/Library/Synergy/synergy.conf --address :24800
[ Service  ] [2017-10-31T12:31:38] debug: core process started, id=655
[ Service  ] [2017-10-31T12:31:38] debug: core process exited: code=127 expected=false
[ Service  ] [2017-10-31T12:31:38] debug: core process shutdown complete
[ Service  ] [2017-10-31T12:31:38] debug: starting core process with command: /Applications/Synergy.app/Contents/MacOS/synergy-core --server -f --debug DEBUG --name MARCOs-Mac-mini.local --enable-drag-drop --profile-dir /Users/marcozirino/Library/Synergy --log /Users/marcozirino/Library/Synergy/synergy-core.log -c /Users/marcozirino/Library/Synergy/synergy.conf --address :24800
[ Service  ] [2017-10-31T12:31:38] debug: core process started, id=656
[ Service  ] [2017-10-31T12:31:39] debug: core process shutdown complete
[ Service  ] [2017-10-31T12:31:39] debug: starting core process with command: /Applications/Synergy.app/Contents/MacOS/synergy-core --server -f --debug DEBUG --name MARCOs-Mac-mini.local --enable-drag-drop --profile-dir /Users/marcozirino/Library/Synergy --log /Users/marcozirino/Library/Synergy/synergy-core.log -c /Users/marcozirino/Library/Synergy/synergy.conf --address :24800
[ Service  ] [2017-10-31T12:31:39] debug: core process started, id=657
[ Service  ] [2017-10-31T12:31:39]

 

Share this post


Link to post
Share on other sites
2 hours ago, mzirino said:

I check Preferences->Security & Privacy->Privacy and see that synergy has "Allow the apps below to control your computer".  I uncheck and re-add, but the fatal error does not change.  Reverting to Beta 4.

 

Try removing Synergy completely, then rebooting, then reinstalling.

Share this post


Link to post
Share on other sites

Same problem, how does one one completely remove Synergy?

Share this post


Link to post
Share on other sites
13 hours ago, Sproctor said:

Same problem, how does one one completely remove Synergy?

To uninstall, follow the steps in this post:

Share this post


Link to post
Share on other sites
On 10/31/2017 at 2:47 PM, Nick Bolton said:

Try removing Synergy completely, then rebooting, then reinstalling.

Yeah, that fixed it.  Went through complete removal procedures on Ubuntu and Mac OSX, and it connected immediately.

 

Share this post


Link to post
Share on other sites
2 hours ago, mzirino said:

Yeah, that fixed it.  Went through complete removal procedures on Ubuntu and Mac OSX, and it connected immediately.

 

Ah excellent!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now