Dominick Gallegos

Synergy & VPN

13 posts in this topic

I'm a remote employee and am using one laptop (Win8.1.1), desktop (Win8.1.1), and a Surface Pro 3. All the machines are domain registered however most are not connected to our vpn most of the time. My question is, when I [i]do [/i]connect any of the machines to the vpn I lose the ability to use Synergy. So how do I configure Synergy to allow this connection on any device? I should add that the laptop is my server, and the desktop and Surface Pro 3 are each clients. Also, we use Junos Pulse for VPN connections. Thanks, Dominick

Share this post


Link to post
Share on other sites
I also work remotely and started suffering from this issue this week when I started working with a new VPN client named FortiClient. My other VPNs don't seem to affect Synergy, but this one causes the client to not see the server on the same network (192.168.0.x) The highlighted IP on the server changes from that address to (192.168.100.x), which I assume is due to the VPN connections. If anyone has ideas on a workaround, I'm more than happy to help test a solution to this issue. Thanks, Adam

Share this post


Link to post
Share on other sites
This is a problem with your vpn (sometimes), you can try not using the same ip range as the vpn (10.x.x.x for your internal network) so that the vpn connection will be 192.x.x.x but the rest of your connections will be 10.x.x.x We had to do this for a lot of users because of network printers being so common in the household and the vpn stopping them from addressing anything 192 except the vpn. just my two cents

Share this post


Link to post
Share on other sites
Thanks Marty. I'll try switching around my router config and test that out today.

Share this post


Link to post
Share on other sites
No dice..... It still switches it to the 192.168.100.x config on the server.

Share this post


Link to post
Share on other sites
Is this in windows? If so try this... Go to your control panel, network and sharing center, change adapter settings, if you don't see file edit view tools advanced at the top press alt, then go to advanced and advanced settings. Put the connection order so that your nic is above your vpn's nic.

Share this post


Link to post
Share on other sites
Glad I could help. Just curious did you happen to keep separate ip ranges? or are you still on 192. for both lan and vpn? edit: I think in this case it's just a case of the software detecting the IP based on what windows determines is the Default network adapter so it may still work if both are on 192.

Share this post


Link to post
Share on other sites
I ended up keeping my network on a 10.10.0.x config. Didn't have any issues for the rest of the day.

Share this post


Link to post
Share on other sites
It appears that I have celebrated too early. I'm running into the same issue this morning. I double checked the order as mentioned previously and it hasn't changed. The server IP addresses has the VPN connection IP highlighted. There is something a bit different this time around though. The client does say "connected to server", but when I try to drag the mouse over to the client, I get "WARNING: failed to connect to server: server is not responding", then it connects back up to the server immediately. Yet the mouse doesn't transfer over to the client. Edit: and now it's working for some reason. Intermittent issues are the worst to try and solve!

Share this post


Link to post
Share on other sites
I connect via vpn to my work from home and have this same issue, I moved my local wireless interface above the VPN interface on my laptop but I still am unable to connect my home PC to my work laptop when its connect to VPN. Is this probably something on my company VPN that is blocking the connection? update - I found out from my network team that in order for VPN to have access to your local lan split tunneling has to be enable, in my case it is not so synergy will not work while connect to vpn. I also tried a work around that used to work for me, but it now doesn't, maybe you will have better luck with it. Basically you use the IP address of your home router (not the home lan 192.168.x.x) and configure synergy to use port 80,rather than 24800.

Share this post


Link to post
Share on other sites
Windows laptop client. Mac Mini as Server. The Laptop Synergy client is unable to connect after the VPN is turned on. If Synergy is already running and connected before turning the VPN on it stays connected for a while before a timeout error Tried setting "Check clients every" X ms in advanced server settings but didn't help.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now