bbread

Portable deployment unstable; hangs periodically - 1.8.8

1 post in this topic

Hello,

I am using Synergy v1.8.8 on both my server and client. Due to the nature of my work, I am often configuring other computers next to my own, which are then sent elsewhere. I did not wanted to install Synergy on the client computer, so I opted for a portable use only. Ideally, I would have this up and running from a USB stick so I can quickly launch a client, do my things and by the end of the day be done with it.

This has been asked a few times before and information through various posts cover vaguely how to do this (I'll add the relevant links if there is interest), but the main idea is to use synergyc.exe (the client executable). As long as you have the proper DLLs, it should start fine.

My problem is that after a short while of use, the client appears to disconnect (even though verbose output does not show disconnection). On the server side, the mouse will be block by the edge of the screen. On the client, using a physical keyboard, if I send CTRL-C, it will not send the shutdown signal to the client. Rather, it will disconnect from the server and automatically reconnect (see 2nd screenshot - synergyc2.png). This seems to happen after I send some specific keys (like the Windows key, although on the client it will properly bring up the Windows menu once) but this is not systematic (at the time of writing, this behavior happened while I typed on my main computer (server) after no input on the client).

Debug level is visibly at INFO only on the client side - I do not know how to change it from commandline.

synergyc.png

synergyc2.png

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now