Erwin van den Bovenkamp

Ports/IP address open

7 posts in this topic

Hi,

 

I am behind a company firewall and my Synergy 2 Beta does not work... at all..

Now I am getting the feeling that communication trough internet is required by normal use of the program.

Can you specify the IP addresses which my sysop needs to exclude in the firewall?

 

Thank you,

Erwin

(now working with 2 sets M&K again... :-( )

Share this post


Link to post
Share on other sites

I am getting in my debug log the following;

 

[2017-10-26T09:44:04] debug: connecting websocket
TX message (4 octets) ...
TX message: yield [1, {}]
RX preparing to receive message ..
TX message (77 octets) ...
TX message: publish [7, {}, "synergy.service.log", ["[2017-10-26T09:44:04] debug: connecting websocket\n"]]
[wamp_message_processor.cpp:47][process_message] processing message: yield
[wamp_dealer.cpp:424][process_yield_message] session [7090515283965860,default,open], yield [1, {}, null, null]
[wamp_dealer.cpp:465][process_yield_message] session [7090515283965860,default,open], result [6, {}, null, null]
[rawsocket_transport.cpp:39][send_message] sending message: result
[wamp_message_processor.cpp:47][process_message] processing message: publish
[wamp_broker.cpp:111][process_publish_message] session [7090515283965860,default,open], publish [7, {}, synergy.service.log, ["[2017-10-26T09:44:04] debug: connecting websocket\n"], null]
[wamp_broker.cpp:149][process_publish_message] session [2257228500326156,default,open], event [2, 8530991034268898, {}, ["[2017-10-26T09:44:04] debug: connecting websocket\n"], null]
[rawsocket_transport.cpp:39][send_message] sending message: event
[wamp_message_processor.cpp:47][process_message] processing message: call
[wamp_dealer.cpp:166][process_call_message] session [2257228500326156,default,open], call [7, {"timeout":10000}, synergy.profile.request, [], null]
[wamp_dealer.cpp:219][process_call_message] session [2257228500326156,default,open], invocation [2, 2, {}, [], null]
[rawsocket_transport.cpp:39][send_message] sending message: invocation
RX message (6 octets) ...
RX message received.
RX message: invocation [2, 2, {}, []]
Invoking procedure registered under 2
[2017-10-26T09:44:04] error: can't send profile snapshot, not yet received from cloud
TX message (4 octets) ...
TX message: yield [2, {}]
RX preparing to receive message ..
TX message (113 octets) ...
TX message: publish [8, {}, "synergy.service.log", ["[2017-10-26T09:44:04] error: can't send profile snapshot, not yet received from cloud\n"]]
[wamp_message_processor.cpp:47][process_message] processing message: yield
[wamp_dealer.cpp:424][process_yield_message] session [7090515283965860,default,open], yield [2, {}, null, null]
[wamp_dealer.cpp:465][process_yield_message] session [7090515283965860,default,open], result [7, {}, null, null]
[rawsocket_transport.cpp:39][send_message] sending message: result
[wamp_message_processor.cpp:47][process_message] processing message: publish
[wamp_broker.cpp:111][process_publish_message] session [7090515283965860,default,open], publish [8, {}, synergy.service.log, ["[2017-10-26T09:44:04] error: can't send profile snapshot, not yet received from cloud\n"], null]
[wamp_broker.cpp:149][process_publish_message] session [2257228500326156,default,open], event [2, 173663057434166, {}, ["[2017-10-26T09:44:04] error: can't send profile snapshot, not yet received from cloud\n"], null]

[rawsocket_transport.cpp:39][send_message] sending message: event
 

----------------------------------------------------------

It looks like I have no internet connection and it is required to function.

Can anyone assist?

 

Erwin

Share this post


Link to post
Share on other sites

The current version requires an Internet connection to access your profile. The final release will include a manual config option for offline machines.

Synergy is making use of cloud server services and the IP may change and may even be different for different locales. My install is currently 
connecting to 138.68.44.148, but you would be better off constructing rules which don't rely on this and instead use your own IP and the required ports.

 

Share this post


Link to post
Share on other sites

So when I open port 8081 to internet and/or put IP address 138.68.44.148 on the whitelist, it should work?

synergyd also makes an external connection to Symless on port 8081.

Thank you! I will give it a try.

Share this post


Link to post
Share on other sites
On 26/10/2017 at 3:00 PM, IT Troll said:

The final release will include a manual config option for offline machines.

 

Agh, sorry, we had to move this back to 2.1 :(

 

Share this post


Link to post
Share on other sites
On 27/10/2017 at 6:50 AM, Erwin van den Bovenkamp said:

synergyd also makes an external connection to Symless on port 8081.

 

Finally, Synergy 2 beta5 is here! It uses the standard SSL port, 443.

Get the latest version: Synergy-v2.0.0-beta5

Share this post


Link to post
Share on other sites

Any updates on this? It's rather annoying to lose all access to my secondary workstations because Comcast is being its usual unreliable self.

I suppose on the plus side it's generally the first thing I notice when the connection has a problem.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now