Jason D

Ubuntu 17.10 client - no visible mouse

4 posts in this topic

16.04 Ubuntu server; 17.10 Ubuntu client

When focus moves to the client machine, the mouse cursor is not visible. The mouse works, as you can click things, and the keyboard works. Attached logs are from the client side. Also, the screen starts going to sleep even when actively moving the (invisible) mouse around. 

[ Config ] [2017-10-23T09:01:23] INFO: log filename: /home/jason/.config/Symless/Synergy/synergy.log
[ Config ] [2017-10-23T09:01:23] DEBUG: connecting to service
[ Config ] [2017-10-23T09:01:23] DEBUG: connected to service
[ Config ] [2017-10-23T09:01:23] DEBUG: new added screen pos: 257 161
[ Config ] [2017-10-23T09:01:23] DEBUG: Profile ID: 6336 name: default
[ Config ] [2017-10-23T09:01:23] DEBUG: current version is update to date
[ Config ] [2017-10-23T09:01:23] DEBUG: requesting profile snapshot
[ Service ] [2017-10-23T09:01:23] debug: connecting websocket
[ Service ] [2017-10-23T09:01:23] error: can't send profile snapshot, not yet received from cloud
[ Service ] [2017-10-23T09:01:24] debug: websocket connected
[ Service ] [2017-10-23T09:01:24] debug: comparing profiles, id=-1 this=v-1 other=v3
[ Service ] [2017-10-23T09:01:24] debug: profile id changed, -1->6336
[ Service ] [2017-10-23T09:01:24] debug: profile name changed, ->default
[ Service ] [2017-10-23T09:01:24] debug: profile server changed, -1->12456
[ Service ] [2017-10-23T09:01:24] debug: profile screen set changed, added=3 removed=0
[ Service ] [2017-10-23T09:01:24] debug: new screens detected (3), preparing connectivity test
[ Service ] [2017-10-23T09:01:24] debug: starting connectivity test
[ Service ] [2017-10-23T09:01:24] debug: profile changed, storing local copy
[ Service ] [2017-10-23T09:01:24] debug: handling local profile server changed, mode=unknown thisId=18563 serverId=12456 lastServerId=-1
[ Service ] [2017-10-23T09:01:24] debug: starting core client process
[ Service ] [2017-10-23T09:01:24] error: aborting client start, no successful connectivity test results
[ Service ] [2017-10-23T09:01:24] debug: handling local profile screen set changed, mode=client
[ Service ] [2017-10-23T09:01:24] debug: comparing profiles, id=6336 this=v3 other=v3
[ Service ] [2017-10-23T09:01:24] debug: profile screen active changed, screenId=18563 false->true
[ Service ] [2017-10-23T09:01:24] debug: new screens detected (1), preparing connectivity test
[ Service ] [2017-10-23T09:01:24] debug: profile changed, storing local copy
[ Service ] [2017-10-23T09:01:24] debug: connectivity test passed for 10.0.148.254:24810
[ Service ] [2017-10-23T09:01:27] debug: successful report: dest = 12456, ips = 10.0.148.254
[ Service ] [2017-10-23T09:01:27] debug: failed report: dest = 12456, ips = 192.168.122.1
[ Service ] [2017-10-23T09:01:27] debug: local profile modified, id=6336
[ Service ] [2017-10-23T09:01:27] debug: comparing profiles, id=6336 this=v3 other=v3
[ Service ] [2017-10-23T09:01:27] debug: profile screen test result changed, screenId=12456 success=``->`10.0.148.254` failed=``->`192.168.122.1`
[ Service ] [2017-10-23T09:01:27] debug: handling new report from connectivity tester, screenId=12456 successfulIp=10.0.148.254 lastServerId=12456
[ Service ] [2017-10-23T09:01:27] debug: starting core client process
[ Service ] [2017-10-23T09:01:27] debug: starting core process with command: /usr/bin/synergyc -f --no-tray --debug DEBUG --name jason-laptop-2l --enable-drag-drop --profile-dir /home/jason/.config/synergy --log synergy.log 10.0.148.254:24800
[ Service ] [2017-10-23T09:01:27] debug: core process started, id=2549
[ Service ] [2017-10-23T09:01:27] debug: finished connectivity test
[ Core ] [2017-10-23T09:01:27] INFO: ignoring --enable-drag-drop, not supported on linux.
[ Core ] [2017-10-23T09:01:27] DEBUG: XOpenDisplay(":0")
[ Core ] [2017-10-23T09:01:27] DEBUG: xscreensaver window: 0x00000000
[ Core ] [2017-10-23T09:01:27] DEBUG: screen shape: 0,0 2646x1024
[ Core ] [2017-10-23T09:01:27] DEBUG: window is 0x02200004
[ Core ] [2017-10-23T09:01:27] DEBUG: adopting new buffer
[ Core ] [2017-10-23T09:01:27] DEBUG: opened display
[ Core ] [2017-10-23T09:01:27] NOTE: started client
[ Core ] [2017-10-23T09:01:27] NOTE: connecting to '10.0.148.254': 10.0.148.254:24800
[ Core ] [2017-10-23T09:01:27] DEBUG: event queue is ready
[ Core ] [2017-10-23T09:01:27] DEBUG: open clipboard 0
[ Core ] [2017-10-23T09:01:27] DEBUG: empty clipboard 0
[ Core ] [2017-10-23T09:01:27] DEBUG: grabbed clipboard 0
[ Core ] [2017-10-23T09:01:27] DEBUG: close clipboard 0
[ Core ] [2017-10-23T09:01:27] DEBUG: open clipboard 1
[ Core ] [2017-10-23T09:01:27] DEBUG: empty clipboard 1
[ Core ] [2017-10-23T09:01:27] DEBUG: grabbed clipboard 1
[ Core ] [2017-10-23T09:01:27] DEBUG: close clipboard 1
[ Core ] [2017-10-23T09:01:27] NOTE: connected to server
[ Service ] [2017-10-23T09:01:27] debug: comparing profiles, id=6336 this=v3 other=v3
[ Service ] [2017-10-23T09:01:27] debug: profile screen test result changed, screenId=12456 success=`10.0.148.254`->`` failed=`192.168.122.1`->``
[ Service ] [2017-10-23T09:01:27] debug: profile screen status changed, screenId=18563 Connecting->Connected
[ Service ] [2017-10-23T09:01:27] debug: profile changed, storing local copy
[ Service ] [2017-10-23T09:01:27] debug: comparing profiles, id=6336 this=v3 other=v3
[ Service ] [2017-10-23T09:01:27] debug: profile screen status changed, screenId=18563 Connected->Disconnected
[ Service ] [2017-10-23T09:01:27] debug: profile changed, storing local copy
[ Service ] [2017-10-23T09:01:27] debug: comparing profiles, id=6336 this=v3 other=v3
[ Service ] [2017-10-23T09:01:27] debug: profile screen status changed, screenId=18563 Disconnected->Connected
[ Service ] [2017-10-23T09:01:27] debug: profile changed, storing local copy
[ Service ] [2017-10-23T09:01:27] debug: comparing profiles, id=6336 this=v3 other=v3
[ Service ] [2017-10-23T09:01:27] debug: profile screen status changed, screenId=18563 Connected->Connecting
[ Service ] [2017-10-23T09:01:27] debug: profile changed, storing local copy
[ Core ] [2017-10-23T09:01:27] INFO: entering screen
[ Core ] [2017-10-23T09:01:27] DEBUG: start receiving clipboard data
[ Core ] [2017-10-23T09:01:27] DEBUG: receiving clipboard 0 size=39724
[ Core ] [2017-10-23T09:01:27] DEBUG: received clipboard 0 size=39724
[ Core ] [2017-10-23T09:01:27] DEBUG: open clipboard 0
[ Core ] [2017-10-23T09:01:27] DEBUG: empty clipboard 0
[ Core ] [2017-10-23T09:01:27] DEBUG: grabbed clipboard 0
[ Core ] [2017-10-23T09:01:27] DEBUG: add 8222 bytes to clipboard 0 format: 0
[ Core ] [2017-10-23T09:01:27] DEBUG: add 31482 bytes to clipboard 0 format: 1
[ Core ] [2017-10-23T09:01:27] DEBUG: close clipboard 0
[ Core ] [2017-10-23T09:01:27] INFO: clipboard was updated
[ Core ] [2017-10-23T09:01:27] DEBUG: start receiving clipboard data
[ Core ] [2017-10-23T09:01:27] DEBUG: receiving clipboard 1 size=22
[ Core ] [2017-10-23T09:01:27] DEBUG: received clipboard 1 size=22
[ Core ] [2017-10-23T09:01:27] DEBUG: open clipboard 1
[ Core ] [2017-10-23T09:01:27] DEBUG: empty clipboard 1
[ Core ] [2017-10-23T09:01:27] DEBUG: grabbed clipboard 1
[ Core ] [2017-10-23T09:01:27] DEBUG: add 10 bytes to clipboard 1 format: 0
[ Core ] [2017-10-23T09:01:27] DEBUG: close clipboard 1
[ Core ] [2017-10-23T09:01:27] INFO: clipboard was updated
[ Core ] [2017-10-23T09:01:29] INFO: leaving screen
[ Core ] [2017-10-23T09:01:29] INFO: entering screen
[ Core ] [2017-10-23T09:01:42] DEBUG: lost clipboard 1 ownership at 1789349

 

Share this post


Link to post
Share on other sites

I'm confirming the same behaviour with macOS 10.12.6 as server, and Ubuntu 17.10 as client.

Share this post


Link to post
Share on other sites

Got the same beaviour here. I had the issue on both synergy 1.8 and synergy 2 beta4.

You can omit this issue by choosing xorg as window manager instead of the default gnome. This of course is not a good solution, but works until synergy gets fixed

Share this post


Link to post
Share on other sites
16 hours ago, Hallonen said:

Got the same beaviour here. I had the issue on both synergy 1.8 and synergy 2 beta4.

You can omit this issue by choosing xorg as window manager instead of the default gnome. This of course is not a good solution, but works until synergy gets fixed

yeah, wayland isnt going to be supported untill 2.1(mid 2018). try this https://itsfoss.com/switch-xorg-wayland/

select xorg(x11) instead of wayland to make synergy work.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now