marcinbojko

Worst software ever?

27 posts in this topic

I am a Linux fan/user always wanting to work with inter-platform tools. SYnergy 1.x was for me something new - something I can use on daily basic to make my life easier.
As many others I started to participate in early access beta 2.0 version I have to say - it's one of worst experiences I've ever had.

Let's start with with Synergy 1.0 - connecting two machines was not easy, strict per IP configuration (bonjour never helped), problems with different languages and chars, and almost completly lack of any decent documentation. With version 2.0 (don't give a shit about those 5 bucks, I'll let you have it) i was given 'escape room' experience.
First of all - as I understand simplicity over othen means - constant 'iphonisation' of this software is something terrible. If you at least achieve their stability and UX level it would be fine, but you guys started from some never-working abomination - both beginner and power user can't handle.

From the beginning

a) you are not even able to create package for Linux that works. No matter how many changes in systemd files I'll try effect is always the same - non working daemon, have to run this manually, or by startup application section.

b)app doesn't have any settings or documentation to fix something in files.

c) it simply doesn't work - after many, many, many reboots, retries, turning off firewalls, extra network interfaces I was able to achieve 'green-green' situation. It doesn't work. I can enjoy green color as I much but effect stays - doesn't work.

d) if you have any other interfaces (Hyper-V, VirtualBox, Fortissl) app tries to use them to connect and fails.

And - long story short - I don't give a damn about some 'big guys' explaining and being sorry - just start writing a good software. As for now I have no choice than abort this abomination and return to 'not-so-shiny-but-working' Synergy 1.0
 

  • Like 1

Share this post


Link to post
Share on other sites

Well... Somehow I felt the same. My only advice would have been to call that thing an "early alpha" instead of announcing it as a "beta". It is far away from being that. You want to release in November? Which year? :D

Share this post


Link to post
Share on other sites
Just now, mrccnt said:

Well... Somehow I felt the same. My only advice would have been to call that thing an "early alpha" instead of announcing it as a "beta". It is far away from being that. You want to release in November? Which year? :D

I seriously feel like I was scammed. Nor for 5 bucks but for promises of software that work.

Share this post


Link to post
Share on other sites
31 minutes ago, marcinbojko said:

I seriously feel like I was scammed. Nor for 5 bucks but for promises of software that work.

Did you not read the early access email??

It clearly states :

"Warning:
Beta versions are unstable, and are not the final product. Please purchase only if you like to try out bleeding edge software that contains bugs."

 

Share this post


Link to post
Share on other sites
2 minutes ago, stuart macmillan said:

Did you not read the early access email??

It clearly states :

"Warning:
Beta versions are unstable, and are not the final product. Please purchase only if you like to try out bleeding edge software that contains bugs."

 

Did you not understand what: working|not working means?

I was expecting some bugs, problems, and - suprise - better support for us 'early access' suckers. I wasn't expecting software that's broken by design and as a user I have no ability to make it better. With this iphonization thing.
 

Edited by marcinbojko

Share this post


Link to post
Share on other sites
Quote

Beta versions are unstable, and are not the final product

Sure... When it comes to betas, there are always some/many instabilities. But the current version lacks on many basic features. Such a lack of basic features (buggy or not) is an alpha. Its that simple. And hey. It is ok for me. The thing is I wouldn't have tried it out if I had known that it is an alpha...

  • Like 1

Share this post


Link to post
Share on other sites

Just to clarify: Wiki Beta

Quote

Beta phase generally begins when the software is feature complete but likely to contain a number of known or unknown bugs.

IMHO this is a alpha...

  • Like 1

Share this post


Link to post
Share on other sites

Sorry you guys had such a bad experience. Obviously, you invested time and expertise. Nick says whole layers of code has been removed and rewritten to be compatible with Linux distros. Semantics aside, many of us had to drop back to version 1 and are watching for beta 5 to be released.

  • Like 1

Share this post


Link to post
Share on other sites

Yeah I am looking forward to the next release. Synergy is and will be one of my favourite tools when it comes to handling "my army of desktops" (Win 10/7; Ubuntu; Raspi). Maybe I will wait one more week after release and check the forums first... :)

 

BTW: Are there any plans to support Raspberry Pi like v1 did?

Share this post


Link to post
Share on other sites

This is most definitely not a beta, but that argument isn't going anywhere.

The current version sucks, no one has argued that at any point either. Though I do argue that the old (and apparently working) b3 version should be re-released if b4 is so horrible that no one is suggested to fight with it.

Beta 5 may improve things though it's been talked about for a long while now with no ETA, so that doesn't really help things.

 

I think this is another symptom of little to no communication of the part of Symless that isn't quite vague.

 

2 hours ago, mrccnt said:

BTW: Are there any plans to support Raspberry Pi like v1 did?

Raspbian is essentially just linux, so I would expect it to work. Unless you mean in a different capacity?

Share this post


Link to post
Share on other sites

Other than having to restart the Synergy service after a reboot, my beta4 is working pretty damn good. I can't say why everyone doesn't have the same experience, but with people have a plethora of different AV's, firewalls, etc. installed...it could be anything.

For me, beta4 does it's job. I can use two Windows machines with one set of keyboard/mouse. Honestly, other than the service issue, if beta4 was released right now as a final...I'd probably buy it.

Share this post


Link to post
Share on other sites
Just now, marcinbojko said:

Hi Nick.

Thanks, on it!

mb

Awesome, let me know how you get on!

Share this post


Link to post
Share on other sites

Hi Nick.
Some follow up.
1. Service (Linux Mint) starts properly. I've had some issues with certificate handshakes, it was related with my UTM (noted: if page is blocked, synergy informs about 'certificate handshake problem' not about connectivity problem.

2. restart service takes 3-5 minutes.

3. How, do hell, should I know which screen is which? If your workstation name is not ABC or EFG - you have problem. (image 1).

4. All is good. We have a green. Software looks nice ...... but again - doesn't work. If i remember the idea was to use shared mouse and keybord, right? So no, it doesn't work. Can't place my mouse cursor beyond my server's screens. Again - no settings, not really helpfull logs - no diagnose. Iphonization.

5. Logs: https://synergy-logs.symless.com/2017-10-31/8269-2017-10-31T13-47-46.log
 

Selection_999(842).png

Edited by marcinbojko

Share this post


Link to post
Share on other sites

Server. Pressing F12 just killed server. Pressing maniacally. Nothing.
Worked.

Stopped

Worked!

Stopped

Wrong screen order (workstation should be left, is right).

Reversing

Works!

Restart - just to be sure.

Works!

Share this post


Link to post
Share on other sites
8 hours ago, marcinbojko said:

Worked.

Stopped

Worked!

Stopped

Were you clicking or pressing keys on the other computer at this point?

Share this post


Link to post
Share on other sites

Hi Nick. I can't make Synergy 2 beta5 work. Can I have the download to beta4 again? because it's really messing up my work schedule. Thanks. 

Share this post


Link to post
Share on other sites
On 10/17/2017 at 12:47 PM, Ilya said:

Other than having to restart the Synergy service after a reboot, my beta4 is working pretty damn good. I can't say why everyone doesn't have the same experience, but with people have a plethora of different AV's, firewalls, etc. installed...it could be anything.

For me, beta4 does it's job. I can use two Windows machines with one set of keyboard/mouse. Honestly, other than the service issue, if beta4 was released right now as a final...I'd probably buy it.

Same here. I have to kill Synergy in activity monitor maybe once or twice a week, but I've been able to bring my laptop to work, open it and continue using my desktop mouse and keyboard without issue. Excited for Beta 5 and beyond...let's work on those gestures for macOS, @Nick Bolton;)

Share this post


Link to post
Share on other sites
11 hours ago, Nick Bolton said:

Were you clicking or pressing keys on the other computer at this point?

Clicking like a crazy person.

Share this post


Link to post
Share on other sites
11 hours ago, Archer said:

let's work on those gestures for macOS

It's a popular request, but we've got to fix Wayland for the Linux users first.

Share this post


Link to post
Share on other sites
11 hours ago, FBG said:

I can't make Synergy 2 beta5 work

What problem are you having? Beta4 isn't supported anymore, sorry.

Share this post


Link to post
Share on other sites

Hi Nick, I'm on Mac OS 10.11.6. Synergy 2 beta4 was working fine. it told me to update to beta5, and now it doesn't work at all.. (my PC works fine it seems). "There was a problem connecting to the background service". I restarted my mac pro, still nothing. I opened the Activity monitor app but there is no "Synergy-service" process... just a "synergy"  one. What do I do? this is so frustrating...my workflow was sort of set up around Synergy.

I looked at the log. but I don't know what any of it means: I'm pasting it at the the bottom, under the picture. Not sure what to do at this point if Beta4 is not available and beta5 does not work.

59fa870a2b2a0_ScreenShot2017-11-01at7_45_25PM.png.156df439902de3fb10e9e00b21500ffc.png

 

2017-10-30T09:37:34] debug: websocket read error: Connection reset by peer
[2017-10-31T10:16:20] debug: service log path: /Users/franciscoburgos/Library/Synergy/synergy-service.log
[2017-10-31T10:16:20] error: failed to start crash handler: Couldn't verify crash dump directory: No such file or directory
[2017-10-31T10:16:20] info: starting service...
[2017-10-31T10:16:20] debug: connecting websocket
[2017-10-31T10:16:20] debug: connectivity test server started
[2017-10-31T10:16:20] debug: creating rpc endpoints
[2017-10-31T10:16:20] debug: rpc endpoints created
[2017-10-31T10:16:20] info: service started successfully
[2017-10-31T10:16:21] debug: websocket connected
[2017-10-31T10:16:21] debug: comparing profiles, id=-1 this=v-1 other=v12
[2017-10-31T10:16:21] debug: profile id changed, -1->8197
[2017-10-31T10:16:21] debug: profile name changed, ->default
[2017-10-31T10:16:21] debug: profile server changed, -1->16305
[2017-10-31T10:16:21] debug: profile screen set changed, added=2 removed=0
[2017-10-31T10:16:21] debug: new screens detected (2), preparing connectivity test
[2017-10-31T10:16:21] debug: starting connectivity test
[2017-10-31T10:16:21] debug: profile changed, storing local copy
[2017-10-31T10:16:21] debug: handling local profile server changed, mode=unknown thisId=16305 serverId=16305 lastServerId=-1
[2017-10-31T10:16:21] debug: starting core server process
[2017-10-31T10:16:22] debug: starting core process with command: /Applications/Synergy.app/Contents/MacOS/synergys -f --no-tray --debug DEBUG --name Franciscos-Mac-Pro.local --enable-drag-drop --profile-dir /Users/franciscoburgos/Library/Synergy --log synergy.log -c /Users/franciscoburgos/Library/Synergy/synergy.conf --address :24800
[2017-10-31T10:16:22] debug: core process started, id=526
[2017-10-31T10:16:22] debug: handling local profile screen set changed, mode=server
[2017-10-31T10:16:22] debug: starting core server process
[2017-10-31T10:16:25] debug: process already running, attempting to stop
[2017-10-31T10:16:25] debug: stopping core process
[2017-10-31T10:16:25] debug: failed report: dest = 16306, ips = 192.168.0.15
[2017-10-31T10:16:25] debug: local profile modified, id=8197
[2017-10-31T10:16:25] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:16:25] debug: profile screen test result changed, screenId=16306 success=``->`` failed=``->`192.168.0.15`
[2017-10-31T10:16:25] debug: handling new report from connectivity tester, screenId=16306 successfulIp= lastServerId=16305
[2017-10-31T10:16:25] debug: finished connectivity test
[2017-10-31T10:16:25] debug: core process exited: code=0 expected=true
[2017-10-31T10:16:25] debug: core process shutdown complete
[2017-10-31T10:16:25] debug: starting core process with command: /Applications/Synergy.app/Contents/MacOS/synergys -f --no-tray --debug DEBUG --name Franciscos-Mac-Pro.local --enable-drag-drop --profile-dir /Users/franciscoburgos/Library/Synergy --log synergy.log -c /Users/franciscoburgos/Library/Synergy/synergy.conf --address :24800
[2017-10-31T10:16:26] debug: core process started, id=537
[2017-10-31T10:17:21] debug: sending last profile snapshot
[2017-10-31T10:17:21] debug: config ui opened, forcing connectivity test
[2017-10-31T10:17:21] debug: new screens detected (2), preparing connectivity test
[2017-10-31T10:17:21] debug: starting connectivity test
[2017-10-31T10:17:21] debug: handling local profile screen set changed, mode=server
[2017-10-31T10:17:21] debug: starting core server process
[2017-10-31T10:17:22] debug: process already running, attempting to stop
[2017-10-31T10:17:22] debug: stopping core process
[2017-10-31T10:17:22] debug: core process exited: code=0 expected=true
[2017-10-31T10:17:22] debug: core process shutdown complete
[2017-10-31T10:17:22] debug: starting core process with command: /Applications/Synergy.app/Contents/MacOS/synergys -f --no-tray --debug DEBUG --name Franciscos-Mac-Pro.local --enable-drag-drop --profile-dir /Users/franciscoburgos/Library/Synergy --log synergy.log -c /Users/franciscoburgos/Library/Synergy/synergy.conf --address :24800
[2017-10-31T10:17:22] debug: core process started, id=618
[2017-10-31T10:17:22] debug: connectivity test passed for 192.168.0.15:24810
[2017-10-31T10:17:23] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:17:23] debug: profile screen status changed, screenId=16305 Connected->Connecting
[2017-10-31T10:17:23] debug: profile screen test result changed, screenId=16306 success=``->`` failed=`192.168.0.15`->``
[2017-10-31T10:17:23] debug: profile changed, storing local copy
[2017-10-31T10:17:23] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:17:23] debug: profile screen status changed, screenId=16305 Connecting->Connected
[2017-10-31T10:17:23] debug: profile changed, storing local copy
[2017-10-31T10:17:23] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:17:23] debug: profile has not changed, no action needed
[2017-10-31T10:17:24] debug: successful report: dest = 16306, ips = 192.168.0.15
[2017-10-31T10:17:24] debug: local profile modified, id=8197
[2017-10-31T10:17:24] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:17:24] debug: profile screen test result changed, screenId=16306 success=``->`192.168.0.15` failed=``->``
[2017-10-31T10:17:24] debug: handling new report from connectivity tester, screenId=16306 successfulIp=192.168.0.15 lastServerId=16305
[2017-10-31T10:17:24] debug: finished connectivity test
[2017-10-31T10:24:18] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:24:18] debug: profile screen test result changed, screenId=16306 success=`192.168.0.15`->`` failed=``->``
[2017-10-31T10:24:18] debug: profile changed, storing local copy
[2017-10-31T10:24:18] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:24:18] debug: profile screen status changed, screenId=16306 Connected->Disconnected
[2017-10-31T10:24:18] debug: profile changed, storing local copy
[2017-10-31T10:24:18] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:24:18] debug: profile screen status changed, screenId=16306 Disconnected->Connecting
[2017-10-31T10:24:18] debug: profile changed, storing local copy
[2017-10-31T10:24:28] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:24:28] debug: profile has not changed, no action needed
[2017-10-31T10:24:38] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:24:38] debug: profile has not changed, no action needed
[2017-10-31T10:24:49] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:24:49] debug: profile has not changed, no action needed
[2017-10-31T10:24:58] debug: comparing profiles, id=8197 this=v12 other=v12
[2017-10-31T10:24:58] debug: profile has not changed, no action needed
 

Share this post


Link to post
Share on other sites

This is because the background service is crashing, we're fixing this now. Thanks for your patience.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now