Sod Almighty

It won't even install

28 posts in this topic

Have you tried installing as an administrator?

I see you are using Win 7, what other OS are you using with Synergy?

Share this post


Link to post
Share on other sites

There is no option to install as an administrator. The installer is an .msi file, and doesn't offer the same run options an .exe file would offer.

I have managed to install Synergy 2 in MacOS - and I must say it seems very minimal. No options, no nothing. I just get a window with the name of my computer in a little box in the middle. Where are all the settings?

What am I missing?

Share this post


Link to post
Share on other sites

I had this same problem Sod. Nobody has acknowledged the issue yet. See my original thread here (I'm also running Windows 7 SP 1 by the way):

There is a way to force the msi package to install as administrator, you can follow the guide provided here:

https://www.howtogeek.com/178826/how-to-force-an-msi-package-to-install-using-administrator-mode/

This did not help at all. It tried everything, restarts, clean installs, the forced administrator install. Nothing fixed the issue.I went back to Synergy 1.8.8. I can't use Synergy 2.0 until this is fixed which I hope is before release.

Share this post


Link to post
Share on other sites
21 hours ago, Sod Almighty said:

Three days and no response from Symless. Not impressed.

the CEO is having a hard time, for direct symless suport try contacting them at [email protected]

is this a "special"(from your company etc) computer? or just a personal computer

Share this post


Link to post
Share on other sites

Running Windows 7 64-bit Pro

I tried this as well
https://www.howtogeek.com/178826/how-to-force-an-msi-package-to-install-using-administrator-mode/

Then use this to convert it to a .exe http://www.imelfin.com/convert-msi-to-exe.html and set it to run as admin it also failed.

I disabled the firewall and turn off the UCA as well still failed,.there seems to be a issue with the services not asking for privilege 

Share this post


Link to post
Share on other sites

I found the issue the msvcr140.dll missing and need to install Visual C++ Redistributable for Visual Studio 2015 then Microsoft Visual C++ 2015 Redistributable Update 3 and restart.

Run the .mis installer and it should complete.

At this point make sure the Synergy 2 APP is running in Administrator under the Compatibility tab on the Windows 7 system.

On the Prime system shut down Synergy 2 APP disable the Windows Firewall completely go in to the services.msc and restart the Synergy 2 service then start the Synergy 2 APP.

Re-enable the Windows Firewall and you should be good to go.

The Windows 7 Synergy 2 APP screen will look like crap but it is running.

On the Prime system the Windows 7 system may keep looking like it is loading in the Synergy 2 APP screen but so far I have no issue going from screen to screen.

Hope this helps those of you with Windows 7 64-bit systems.

 

Visual C++ Redistributable for Visual Studio 2015 https://www.microsoft.com/en-us/download/details.aspx?id=48145

Microsoft Visual C++ 2015 Redistributable Update 3 https://www.microsoft.com/en-us/download/details.aspx?id=53587

Edited by Wolfx
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Dread Pirate Wolf said:

I found the issue the msvcr140.dll missing and need to install Visual C++ Redistributable for Visual Studio 2015 then Microsoft Visual C++ 2015 Redistributable Update 3 and restart.

Run the .mis installer and it should complete.

At this point make sure the Synergy 2 APP is running in Administrator under the Compatibility tab on the Windows 7 system.

On the Prime system shut down Synergy 2 APP disable the Windows Firewall completely go in to the services.msc and restart the Synergy 2 service then start the Synergy 2 APP.

Re-enable the Windows Firewall and you should be good to go.

The Windows 7 Synergy 2 APP screen will look like crap but it is running.

On the Prime system the Windows 7 system may keep looking like it is loading in the Synergy 2 APP screen but so far I have no issue going from screen to screen.

Hope this helps those of you with Windows 7 64-bit systems.

 

Visual C++ Redistributable for Visual Studio 2015 https://www.microsoft.com/en-us/download/details.aspx?id=48145

Microsoft Visual C++ 2015 Redistributable Update 3 https://www.microsoft.com/en-us/download/details.aspx?id=53587

Beautiful. Absolutely beautiful. 

On 10/15/2017 at 0:37 PM, Sod Almighty said:

There is no option to install as an administrator. The installer is an .msi file, and doesn't offer the same run options an .exe file would offer.

I have managed to install Synergy 2 in MacOS - and I must say it seems very minimal. No options, no nothing. I just get a window with the name of my computer in a little box in the middle. Where are all the settings?

This all looks like a step backward, not an improvement. What am I missing?

There's a reason this is a beta. With all pre-release software, you have a chance to encounter some "not yet ready" software. That's the risk you take. [email protected] if you're unsatisfied.

Synergy 2 beta4 is not a proper representation of the ideals of what Synergy 2 was designed to be; it is an incomplete piece of software. Synergy 2 beta5 vastly differentiates the network topology used from beta4 in order to ensure a smoother experience. The Synergy 2 final release will have some form of advanced admin GUI or something along those lines for those that want to tinker with the settings, but your mindset will have to shift from Synergy 1, as they are now trying to appeal to the bigger audience group of people who need to use Synergy but don't have the time or the technical knowledge required to fiddle around with static IP configuration, firewall/IDS/IPS interference, port configuration, SSL configuration, auto-teaming, etc. Synergy 2 uses cloud computing to auto-negotiate a connection that will be started locally. It is now automatic configuration for Synergy, but again, there will be an administration console. This is beta software, take it or return it.

Edited by Kelvin Tran

Share this post


Link to post
Share on other sites
1 hour ago, Dread Pirate Wolf said:

I found the issue the msvcr140.dll missing and need to install Visual C++ Redistributable for Visual Studio 2015 then Microsoft Visual C++ 2015 Redistributable Update 3 and restart.

Run the .mis installer and it should complete.

At this point make sure the Synergy 2 APP is running in Administrator under the Compatibility tab on the Windows 7 system.

On the Prime system shut down Synergy 2 APP disable the Windows Firewall completely go in to the services.msc and restart the Synergy 2 service then start the Synergy 2 APP.

Re-enable the Windows Firewall and you should be good to go.

The Windows 7 Synergy 2 APP screen will look like crap but it is running.

On the Prime system the Windows 7 system may keep looking like it is loading in the Synergy 2 APP screen but so far I have no issue going from screen to screen.

Hope this helps those of you with Windows 7 64-bit systems.

 

Visual C++ Redistributable for Visual Studio 2015 https://www.microsoft.com/en-us/download/details.aspx?id=48145

Microsoft Visual C++ 2015 Redistributable Update 3 https://www.microsoft.com/en-us/download/details.aspx?id=53587

Thank you Dread Pirate Wolf for the useful information. I will try this and report back if I can get it to work.

17 minutes ago, Kelvin Tran said:

Beautiful. Absolutely beautiful. 

There's a reason this is a beta. With all pre-release software, you have a chance to encounter some "not yet ready" software. That's the risk you take. [email protected] if you're unsatisfied.

Synergy 2 beta4 is not a proper representation of the ideals of what Synergy 2 was designed to be; it is an incomplete piece of software. Synergy 2 beta5 vastly differentiates the network topology used from beta4 in order to ensure a smoother experience. The Synergy 2 final release will have some form of advanced admin GUI or something along those lines for those that want to tinker with the settings, but your mindset will have to shift from Synergy 1, as they are now trying to appeal to the bigger audience group of people who need to use Synergy but don't have the time or the technical knowledge required to fiddle around with static IP configuration, firewall/IDS/IPS interference, port configuration, SSL configuration, auto-teaming, etc. Synergy 2 uses cloud computing to auto-negotiate a connection that will be started locally. It is now automatic configuration for Synergy, but again, there will be an administration console. This is beta software, take it or return it.

I agree that we should expect there to be some issues with the software, and I do, but being unable to simply install the software is even more frustrating than dealing with irritating or inconvenient bugs and a lack of features. A simple reply in the forum by the developers to say that they are looking into the issue would go a very long way in making customers like Sod Almighty and I feel better. I don't think it's unreasonable of anyone to expect some form of communication with severe issues such as this. 

Share this post


Link to post
Share on other sites
50 minutes ago, StaggerLee84 said:

Thank you Dread Pirate Wolf for the useful information. I will try this and report back if I can get it to work.

I agree that we should expect there to be some issues with the software, and I do, but being unable to simply install the software is even more frustrating than dealing with irritating or inconvenient bugs and a lack of features. A simple reply in the forum by the developers to say that they are looking into the issue would go a very long way in making customers like Sod Almighty and I feel better. I don't think it's unreasonable of anyone to expect some form of communication with severe issues such as this. 

No, I completely understand your frustration with the lack of being able to get it to install. That's inexcusable from even an alpha, let alone a beta. However, that may be due to the lack of integrated code to detect Visual C++ redistributable software on the system as they have recompiled the binary. This is in no way based off of Synergy 1. The two are completely separate codebases. @Nick Bolton (CEO of the company) is normally VERY active on the forums, but as he has mentioned in a conversation with I and the rest of the moderators, he is dealing with an emergency, so it is only fair that we provide him with the time to recover from the incident.

Edited by Kelvin Tran

Share this post


Link to post
Share on other sites
22 minutes ago, Kelvin Tran said:

No, I completely understand your frustration with the lack of being able to get it to install. That's inexcusable from even an alpha, let alone a beta. However, that may be due to the lack of integrated code to detect Visual C++ redistributable software on the system as they have recompiled the binary. This is in no way based off of Synergy 1. The two are completely separate codebases. @Nick Bolton (CEO of the company) is normally VERY active on the forums, but as he has mentioned in a conversation with I and the rest of the moderators, he is dealing with an emergency, so it is only fair that we provide him with the time to recover from the incident.

Thanks for clearing that up, I am happy to have patience in the event of family emergencies. I wish him and his family well and I hope that everything is alright.

Share this post


Link to post
Share on other sites

I argee, they should have a support page. I just have to remeber the email address, and that fails sometimes.

The synergy2 installer will try to install a service that starts at boot, your IT administrator has probably blocked this because it can be very dangerous.

Ask the IT department if they can help you install it.

Share this post


Link to post
Share on other sites
15 hours ago, jaap aarts said:

I argee, they should have a support page. I just have to remeber the email address, and that fails sometimes.

The synergy2 installer will try to install a service that starts at boot, your IT administrator has probably blocked this because it can be very dangerous.

Ask the IT department if they can help you install it.

I don't think that this is the problem. I also have full administrative access to the PC causing problems (not to mention the fact that it installs perfectly on the adjacent PC). Dread Pirate Wolf outlined a possible solution above that involved the Visual Studio 2015 redistributable packages. I believe that this should work for most people. Incidentally, I have not been able to get it to work using this solution, but it seems to be related to a Windows update issue on the PC in question.

Share this post


Link to post
Share on other sites

Do you need to have Service Pack 1 installed for Synergy 2 to work? I've not tried it on Windows 7 RTM.

Share this post


Link to post
Share on other sites
On ‎10‎/‎15‎/‎2017 at 0:37 PM, Sod Almighty said:

There is no option to install as an administrator. The installer is an .msi file, and doesn't offer the same run options an .exe file would offer.

I have managed to install Synergy 2 in MacOS - and I must say it seems very minimal. No options, no nothing. I just get a window with the name of my computer in a little box in the middle. Where are all the settings?

This all looks like a step backward, not an improvement. What am I missing?

I have this same issue in Windows 10.  I get the Synergy 2.0 screen with my Desktop in a little box.  I clicked on it and the little box background turned green and nothing else happens, no matter what else I try to click.

Share this post


Link to post
Share on other sites
11 hours ago, ShodiWarmic said:

Do you need to have Service Pack 1 installed for Synergy 2 to work? I've not tried it on Windows 7 RTM.

If you are not running Windows 7 SP 1 you need to be for security issue. As for running Synergy 2 on Windows 7 see my post further up on how to install it.

Share this post


Link to post
Share on other sites

Guys if you have not beta tested anything before let my make a few notes.

1st Beta software is not the finished product and will be missing menus and access tools that are in the finished product.

2nd It is not going to work like the finished product

3rd The beta is put out to find issue that the developer can address and fix.

4th If you do not have the time nor the understanding on how to work around issue I would say stay with Synergy 1 till Synergy 2 is completed.

I hope I don't come off sounding like a smart-aurs but I do a lot of beta testing to improve products for others that don't have time or don't want to beta test.

Share this post


Link to post
Share on other sites
On 10/22/2017 at 6:02 PM, Sod Almighty said:

am the IT department.

hmmm,

do you have a way of reinstalling windows automaticly? (network boot into something, etc)

if its just that computer try reinstalling windows to the same point the working computers are.

also make sure you are allowed to start a service, or try creating a new administartor and see if that account is able to install it.

did you use any setup script besides default windows? they may have turned off the ability to starts a service for anyone.

Share this post


Link to post
Share on other sites

I have attempted to install beta 5 and this problem does not appear to have been solved.

Share this post


Link to post
Share on other sites
35 minutes ago, StaggerLee84 said:

I have attempted to install beta 5 and this problem does not appear to have been solved.

There's a bug on Windows where services can get into a corrupt state. Have you tried uninstalling and rebooting?

Share this post


Link to post
Share on other sites
15 minutes ago, Nick Bolton said:

There's a bug on Windows where services can get into a corrupt state. Have you tried uninstalling and rebooting?

Many, many times. I am sure that this isn't the issue. I think the issue has to do with the Visual C++ 2015 redistributables during installation. I have been unable to work around this in any way. I have tried many reboots, reinstallations, administrative permission forcing etc.

Share this post


Link to post
Share on other sites
5 minutes ago, StaggerLee84 said:

I think the issue has to do with the Visual C++ 2015 redistributables during installation.

Ah, I see the post about redistributables now. Ok, I'll raise a bug and prioritize the issue. Any idea how many people it's affecting?

Share this post


Link to post
Share on other sites
6 minutes ago, Nick Bolton said:

Ah, I see the post about redistributables now. Ok, I'll raise a bug and prioritize the issue. Any idea how many people it's affecting?

So far, the only people who have complained about it are Sod Almighty and I. Can't say for sure otherwise. Based on the responses to this thread, I don't think that it's a super-prevalent issue.

Edit: And thanks for prioritizing the bug :)

Edited by StaggerLee84

Share this post


Link to post
Share on other sites
3 minutes ago, StaggerLee84 said:

Edit: And thanks for prioritizing the bug :)

Anything that stops users from installing is very high priority. I'll try and get this fixed for 2.0.1.

Share this post


Link to post
Share on other sites

I just tried to install Beta 5.  It did the same thing Beta 4, installed, but only gives me that initial screen which show the little desktop icons. I did manage to send the log.

My Ver 1.8 was uninstalled, however during installation there was a screen telling me to close movies & TV, People, photos, and settings. None of them were open to my knowledge, but I closed everything I could find in the task manager and on the second attempt, the install finished, but as yet, I can go no further than initial screen.  It shows two of my desktops icons, one of which shows an active green ego line, like it is trying to lad something but it just continues. Not sure where to go from here.

Synergy Install issue Capture.PNG

desktop Beta 5 Capture.PNG

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now