Sign in to follow this  
Michael Schwerin

1.7.3 lag/denial of service caused by old versions

0 posts in this topic

I noticed a lot of people complaining I upgraded two machines on my network to 1.7.3: Ubuntu 14.04 64bit server, Windows 8.1 64bit client. I then booted an older machine which still had 1.4.17 on it and apparently the 1.7.3 server can't gracefully handle the older version trying to connect. The error log was also not very useful as it didn't include a hostname or IP address of the offending machine or indicate the version of the client trying to connect. The log keeps repeating the following: NOTE: accepted client connection ERROR: passive ssl error limit exceeded: 100001 ERROR: failed to accept secure socket with this thrown in every once in a while ERROR: ssl error occurred (system call failure) or ERROR: eof violates ssl protocol After this many errors or if a certain error rate is exceeded perhaps it could just choose to ignore that host rather than drag down all the other connections with extreme lag (1 second or more per cursor update in my case, and sometimes took seconds to get cursor back to the server machine).

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this