mlumb

Synergy 2 on Raspberry Pi 2 or 3

8 posts in this topic

Has anyone had any luck installing Synergy 2 Beta on a Raspberry Pi?  I am running Raspian Stretch. I primarily use Synergy between my Windows/Mac/Pi.  The non-beta I can just apt-get but it doesn't seem to like the architecture of either the .deb or .rpm installer. Tried converting with no luck.  Thanks in advance for the help. 

Michael

Share this post


Link to post
Share on other sites

mlumb,

I know nothing about using a Pi. I'm going to hide and watch to see if you get other users to reply. I'll be interested to learn.

Share this post


Link to post
Share on other sites

I just tried compiling from the synergy-core in git on my pi 3 with ubuntu mate; which does not appear to work. 

We will need the source archive for 2.0.5 to compile (like for 1.x), or for the synergy-core to be updated to a compatible version, i think

 

Share this post


Link to post
Share on other sites

sorry, i'm new and i just read that the synergy2 is closed source so no source archive will be available i guess, and synergy-core may then not be compatible with synergy 2. 

can we request a .deb package compiled for the armhf architecture so it can be used with the raspberry pi? 

The primary use of synergy for me is to interact with a couple of raspberry pi's and the amd64 architecture is the only one available for ubuntu or debian. 

Share this post


Link to post
Share on other sites

I will return to 1.8 i guess and help with beta testing when my use case is supported

Share this post


Link to post
Share on other sites

Sorry guys, no Raspberry Pi support yet.

  • Sad 1

Share this post


Link to post
Share on other sites

ok, thanks sir, back to 1.8.8 - i will wait and see if you release a package or code we can compile for the pi sometime soon

Share this post


Link to post
Share on other sites
12 hours ago, revere521 said:

ok, thanks sir, back to 1.8.8 - i will wait and see if you release a package or code we can compile for the pi sometime soon

We do plan to support it, but maybe not until 2.2.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now