outerringz

Synergy 2.0 beta 4 on KDE Neon

14 posts in this topic

I have been running 1.8 without issue to move between a Windows 10 PC and a KDE Neon Linux PC. I purchased 2.0 and tried the initial beta, but kept getting stuck at the "Sign in with Symless" screen upon launching the client. I removed v2 and went back to 1.8 to give the beta more time. I just tried beta 4 and I'm experiencing the same symptom of not being able to progress passed the "Sign in with Symless" screen. I tried the beta 4 troubleshooting steps linked below to no effect.

https://symless.com/synergy-2-beta4-troubleshooting

Thanks,

Mike

Share this post


Link to post
Share on other sites

I'm running Linux Mint (as the main server) and Win 10 (as 'slave')

The only way I got it to work was on each machine  - kill the Synergy services.

Open a terminal in Linux and copy in these 4 commands one at a time :-

mkdir -p ~/.config/synergy/

ln -s ~/.config/Symless/Synergy/synergy.conf ~/.config/synergy/synergy.conf

touch /var/log/synergy-service.log    [ NB for this line I needed to sudo ]

/usr/bin/synergyd

Restart Synergy2 on both computers

Then on the Linux machine whilst on the Synergy screen press ` ( not this is the grave not the tilde - and opens the log) and then F12 and everything suddenly started to work.

However, the next day when I switched machines on I had to do the whole thing all over again.

Share this post


Link to post
Share on other sites

I had this same issue yesterday when I installed it.  I had tried setting up as a start up script "/usr/bin/synergyd &" to run in a terminal.  It still won't launch at start up and I just have to rerun the "/usr/bin/synergyd &" in an open terminal when I login.

I'm taking it on faith that since this is just a Beta release, that these issues will be addressed prior to the release.  For now, it works, and I do feel that it works better than the current release. 

Share this post


Link to post
Share on other sites

I managed to get around that by creating a .desktop file to open /usr/bin/synergyd and storing that file in /etc/xdg/autostart/  because these are run even before you login 

This was my .desktop file

[Desktop Entry]

Name=synergy-start.desktop

Comment=Starts the SYNERGY program

Exec=/usr/bin/synergyd 

Terminal=false

Type=Application

X-GNOME-Autostart-enabled=true

Share this post


Link to post
Share on other sites

Thanks for the tips guys, I'll probably give it another beta version or two since I heavily rely on Synergy being available and operational. I just wanted to check the beta to see if it was stable enough to get by.

Share this post


Link to post
Share on other sites

Good work Linux beta testers. 

Many users have 'bought in' to the beta program and stepped back to the stable version 1 waiting for the full version 2 or to test the next beta, beta 5. They still, of course still have a financial consideration for the final version of Synergy 2. It should be on the market about the end of the year.

Share this post


Link to post
Share on other sites

What version are you guys talking about? There's no "synergyd" file in version 2. 

Share this post


Link to post
Share on other sites
3 hours ago, Stuart Smith said:

What version are you guys talking about? There's no "synergyd" file in version 2. 

There was in Synergy 2 beta 4 but it seems to have disappeared in Synergy 2 beta 5

Share this post


Link to post
Share on other sites
1 hour ago, UncleOilybag said:

There was in Synergy 2 beta 4 but it seems to have disappeared in Synergy 2 beta 5

Ah, I see. Thanks for clarity. I tried beta5 but no-go at all here.

Share this post


Link to post
Share on other sites
21 hours ago, Stuart Smith said:

Ah, I see. Thanks for clarity. I tried beta5 but no-go at all here.

What error are you seeing?

Share this post


Link to post
Share on other sites

Okay, I installed Beta5 yesterday and fiddled with it most of the day (cause I could).  Here's the issue that I'm running into:

I'm running OpenSuse LEAP 42.2, and when I install it I get the regular, "Can't find libssl.so.10" dependency.  I've done the symbolic links to libssl.so.1.0.0 -> libssl.so.10.0 and it'll load.  With 1.8.8 I am able to just NOT use SSL for the traffic between the two, so it's really not that big of a deal.  However, Beta5, I don't really see the option to disable the SSL.  The agents launch, run, I think they even somewhat communicate to each other, but never really connect. 

 

Would it be in my best interest to download and install the libssl.so.10 compatibility RPM for Fedora, or continue down the symbolic link route?  I'd really like to give the next version a go, because the two machines that I'm using sometimes one is connected via VPN to work and the 1.8.8 version doesn't connect. 

 

I'd upload my logs, but have since removed everything from both and re-installed/re-activated 1.8.8.

Share this post


Link to post
Share on other sites

Ah, openSUSE support is coming soon.

Share this post


Link to post
Share on other sites
On 11/1/2017 at 1:18 PM, Nick Bolton said:

What error are you seeing?

I posted on another thread. I can't get past the "Sign On with Symless" notification on my server - KDEneon (Ubuntu with KDE/Plasma 5)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now