Michael Egan

Alt Tab Not Working

6 posts in this topic

Server = Desktop machine running Windows Server 2008R2 Client = Microsoft Surface Pro3 running Windows 8.1 Synergy= 1.7.3 Alt tab does not work on client machine using server keyboard. Tab key works fine, alt key works fine, but combination does not work. Alt-tab does work if I use the client keyboard, so it is not a Windows 8.1 issue. This did not start until I recently upgraded to 1.7.3 which coincided with a domain change. Is there a setting I am missing?

Share this post


Link to post
Share on other sites
I'm having the same problem with my Windows 8.1 client laptop, running Synergy 1.7.4. alt-tab works fine from the laptop keyboard, but not through Synergy. There was a bug opened on this a while back, but is showing closed on Github: https://github.com/synergy/synergy/issues/3268 The bug report referenced above seems to indicate enabling "Elevate mode" in settings might have an effect. In my case, though, it does not. A referenced issue in a different Github project at the bottom of that bug report (https://github.com/openstenoproject/plover/issues/237) implies a change is needed to the executable's manifest to set UIAccess=true. Synergy team, any chance of having this fixed in the near future? Thanks! -Chris

Share this post


Link to post
Share on other sites
I upgraded to Synergy 1.7.4 earlier this week and the alt-tab seems to be working fine again. Not sure if that was the fix or just coincidental.

Share this post


Link to post
Share on other sites
Hmm... I'm already running 1.7.4, but still see the problem. Do you have UAC enabled or disabled?

Share this post


Link to post
Share on other sites
My company's stupid group policy keeps changing my UAC to Always Notify, so it is definitely on.

Share this post


Link to post
Share on other sites
Ok, thanks. UAC is disabled on my laptop, so I'll try enabling it when I'm next in my office to see if it makes a difference.

Share this post


Link to post
Share on other sites
That fixed the problem. Setting UAC to one level above disabled is allowing alt-tab to work again. Thanks again for the info, Michael!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now