skaterx2

Cannot get to settings screen

12 posts in this topic

I'm not on a Mac here, but I can see you started the service and the Synergy2 UI.

By "Cannot get to the settings screen" do you mean that you're unable to see the Synergy2 UI, or that you're looking for some sort of configuration option there?

(Because, other than tilde (~) to open the log, and F12 to force server, there aren't any)

Share this post


Link to post
Share on other sites

In the previous version I had control over which machine was the server and which is the client.  Is this no longer available?  All I see is the following screen, which is not helpful at all:

 

synergy2screen.jpg

Share this post


Link to post
Share on other sites

I am facing the same issue and my client is failing to connect saying "server refused client with our name"

 

Server Logs:

[ Core ] [2017-10-06T17:38:56] NOTE: accepted client connection

[ Core ] [2017-10-06T17:38:56] DEBUG: received client "linuxbox" info shape=0,0 1920x1080 at 1435,263

[ Core ] [2017-10-06T17:38:56] WARNING: unrecognised client name "linuxbox", check server config

[ Core ] [2017-10-06T17:38:56] NOTE: disconnecting client "linuxbox"

[ Core ] [2017-10-06T17:38:56] DEBUG: active sides: 0

[ Core ] [2017-10-06T17:38:56] NOTE: client "linuxbox" has disconnected

Edited by trippout

Share this post


Link to post
Share on other sites

From the Synergy2 window, pressing 'F12' will force that machine to become the server. The only other command at present is tilde '~' which opens the log.

As there's only one computer showing up, the immediate question is whether the other computer is able to connect to the cloud.

Share this post


Link to post
Share on other sites

Pressing F12 resulted in a simple "Connection refused" message from my client, almost as if it stopped accepting client connections.

Share this post


Link to post
Share on other sites

ok, so now I have two computers showing up in the blue window.  I have one designated as the server (by pressing F12) How do I get the mouse to the client?

Share this post


Link to post
Share on other sites

Also, Does version 2 require an external connection to Symless in order for it to work?  If so, that's a show stopper for me. I don't want my keystrokes and mouse movements to be recorded by Symless.

Share this post


Link to post
Share on other sites

I was never able to get the auto config to work, but creating the conf file manually and starting synergys from the command line (using the config I created) has gotten mine connected.

Share this post


Link to post
Share on other sites
12 minutes ago, skaterx2 said:

Also, Does version 2 require an external connection to Symless in order for it to work?  If so, that's a show stopper for me. I don't want my keystrokes and mouse movements to be recorded by Symless.

To be clear: Symless does require a connection to the cloud, but what's sent up is only the locations (IP addresses), machine names, and orientation (relative location of the computers that you arrange in the window) of your environment. Generally, these IPs will not even be routable from outside your private network, so it's pretty "safe" from a security standpoint.

None of your keystrokes, movements, or data (cut-and-paste, etc.) are ever sent to Symless or the cloud. The team is focused on building the automatic configuration at present, since this will serve the largest number of users. They have said there will be a version of Synergy2 that will allow configuration without a connection to the cloud, but this likely represents a small subset of the overall user base, so it's a lesser priority than getting the automatic config totally bulletproof.

  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, trippout said:

I was never able to get the auto config to work, but creating the conf file manually and starting synergys from the command line (using the config I created) has gotten mine connected.

Are you using Synergy2 beta4, @trippout? I'd be curious what you changed manually in your conf file to get things working.

Share this post


Link to post
Share on other sites

Yeah I have Beta4, I downloaded the latest today.  I could never get it to work properly with the service or the auto config so I just edited the default c:\Users\username\AppData\Local\Symless\Synergy\Synergy.conf file manually to update my screen section and add links/aliases section and started from the command line:  synergys.exe --config c:\Users\username\AppData\Local\Symless\Synergy\Synergy.conf

Edited by trippout

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now