MartinRentschler

Can't find discovery (?) server

3 posts in this topic

After finally figuring out, where the troubleshooting / info on Synergy 2.0 alpha is, I'm here to make my first bug report. Yay! (Please put a link to the forum in the app.)

Previously I was using Synergy 1 Basic on my Windows 10 x64 and Windows 7 x64 machine. Generally speaking everything worked, albeit at times I would have to unplug my keyboard to have synergy release my input it was putting to god know where. But that's not the point.

 

The new install of Synergy2.0.0-beta4 (I tried restarting, completely uninstalling, disabling firewall, all that) can't seem to connect, to what I presume is the discovery server. See excerpt from log:

Quote

[..]
[ Service ] [2017-10-06T10:40:51] debug: tcp client connect error: Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte
[ Service ] [2017-10-06T10:40:51] debug: websocket connect failed
[ Service ] [2017-10-06T10:40:51] debug: retrying websocket connection in 3s
[ Service ] [2017-10-06T10:40:54] debug: retrying websocket connection now
[ Service ] [2017-10-06T10:40:54] debug: connecting websocket
[ Service ] [2017-10-06T10:40:55] debug: tcp client connect error: Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte
[ Service ] [2017-10-06T10:40:55] debug: websocket connect failed
[ Service ] [2017-10-06T10:40:55] debug: retrying websocket connection in 3s
[ Config  ] [2017-10-06T10:41:15] INFO: log filename: C:/Users/whoever/AppData/Local/Symless/Synergy/synergy.log
[ Config  ] [2017-10-06T10:41:15] DEBUG: connecting to service
[ Config  ] [2017-10-06T10:41:16] DEBUG: connected to service
[ Config  ] [2017-10-06T10:41:16] DEBUG: new added screen pos: 257 161
[ Config  ] [2017-10-06T10:41:17] DEBUG: Profile ID: 3357 name: default
[ Config  ] [2017-10-06T10:41:17] DEBUG: current version is update to date
[ Config  ] [2017-10-06T10:41:17] DEBUG: requesting profile snapshot
[ Service ] [2017-10-06T10:41:17] debug: connecting websocket
[ Service ] [2017-10-06T10:41:17] error: can't send profile snapshot, not yet received from cloud

[ Config  ] [2017-10-06T10:41:17] DEBUG: forcing current computer to be server
[ Service ] [2017-10-06T10:41:18] debug: tcp client connect error: Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte
[ Service ] [2017-10-06T10:41:18] debug: websocket connect failed
[ Service ] [2017-10-06T10:41:18] debug: retrying websocket connection in 3s
[ Service ] [2017-10-06T10:41:21] debug: retrying websocket connection now
[ Service ] [2017-10-06T10:41:21] debug: connecting websocket
[ Service ] [2017-10-06T10:41:22] debug: tcp client connect error: Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte
[ Service ] [2017-10-06T10:41:22] debug: websocket connect failed
[ Service ] [2017-10-06T10:41:22] debug: retrying websocket connection in 3s
[ Service ] [2017-10-06T10:41:25] debug: retrying websocket connection now
[ Service ] [2017-10-06T10:41:25] debug: connecting websocket

 

I'm on a corporate network, so there might be some port-blocking going on, but I would have assumed discovery to use https/443.

Edited by MartinRentschler

Share this post


Link to post
Share on other sites

Win 10 and Win 7...you should have a happy install. When you say you uninstalled, did you simply go through the windows uninstall routine? If so, there are usually left behind files that confuse the new install. Under a 'user' folder there is ultimately a synergy.cfg file from version 1. In my workflow, I use Revo Uninstaller that looks for leftovers and erases them. Other programs do so... or just searching your system for Synergy folders. The troubleshooting guide put up by moderator Kelvin Tran explains deeper:

Keep us posted on your experience.

 

Share this post


Link to post
Share on other sites

Where is the 'user' folder? I can't find any Synergy related files after uninstalling it. There's nothing left in %APPDATA%, Programs, my user profile, etc.

 

I do think it's the requirement for an outward connection on whatever port Syngergy 2 is trying to use that get's blocked by the corporate firewall I'm behind and that I can't influence. I'll be back once discovery w/o an external internet connection becomes possible.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now