smurfless1

macOS: Synergy 2 beta 4 will not show a window

8 posts in this topic

Killed the processes as shown in the troubleshooting guide, the processes restart, but no UI appears on either of the two systems. Sierra current release (waiting on High Sierra work updates before upgrade). 

Share this post


Link to post
Share on other sites

Hello, 

Same issue as @smurfless1 here: killing the processes as indicated in the troubleshoot guide won't work as them keep re-spawning. What worked for me was to firstly unload and disable com.symless.synergy.v2.ServiceHelper.plist, this way I was able to get the Synergy window again. However the F12 key does nothing (no configuration window appears, no visual feedback of any kind, no nothing).

Server: Sierra / Client: High Sierra

Share this post


Link to post
Share on other sites

Even if all is working correctly, the F12 is just a hot-key to force that instance of Synergy to assume the role of Server. Nothing pops up, no config page shows. It just swaps Server status from one machine to another.

If I understand correctly, in the final version even this will not be necessary. Synergy will auto-discern your Server from your Keyboard/Mouse activity.

A couple of points. The initial configuration after installation of Synergy is coded from the Synergy program connecting to the Cloud server. It reads the particulars of each computer names, ports...etc. and configures. This is not immediate. It shouldn't take more than a couple of minutes, but it might take nearly that long. be patient before you judge. Also, at this point with beta4 sometimes multiple restarts finally accomplish a solid connection. All this is from beta4 being a poor release. It seems to work OK for most Windows to Windows setups but MACs have a bit more trouble and Linux boxes are a great disappointment (understatement) in version beta4. 

Many of us have had to step back to version 1 to have Synergy work on our systems while we anxiously scan the horizon for signs of beta5.  The rumor mill says 5 weeks, 3 weeks and next week. 

For now, I suggest you follow the troubleshooting guide sticky  posted at the top of this beta access forum section. keep your beta 4, try restarting, waiting a couple of minutes...and restarting... before you give up.

Let us know your progress.

  • Like 1

Share this post


Link to post
Share on other sites

I had waited well over 10 minutes when I first noticed it hadn't launched, so that wasn't it. 

Share this post


Link to post
Share on other sites

Oh hey, that's neat! If you poke around in the bundle file, you can go back to using your original config files from like 2007 and everything works fine. I'm at least unblocked, even if the magic configuration system isn't working for me. 

Share this post


Link to post
Share on other sites

Thanks for stepping in with this nice explanation @KringleKrebs.

Quote

Even if all is working correctly, the F12 is just a hot-key to force that instance of Synergy to assume the role of Server. Nothing pops up, no config page shows. It just swaps Server status from one machine to another.

Cool, I got it wrong then, thanks for the correction.

Quote

A couple of points. The initial configuration after installation of Synergy is coded from the Synergy program connecting to the Cloud server. It reads the particulars of each computer names, ports...etc. and configures. This is not immediate. It shouldn't take more than a couple of minutes, but it might take nearly that long. be patient before you judge. Also, at this point with beta4 sometimes multiple restarts finally accomplish a solid connection. All this is from beta4 being a poor release. It seems to work OK for most Windows to Windows setups but MACs have a bit more trouble and Linux boxes are a great disappointment (understatement) in version beta4. 

Understood. I yet have to try Synergy 2 beta4 on my GNU+Linux boxes, it's good to know in advance that there exists a bunch of issues with it. 

Quote

For now, I suggest you follow the troubleshooting guide sticky  posted at the top of this beta access forum section. keep your beta 4, try restarting, waiting a couple of minutes...and restarting... before you give up.

Everything seems to be working as expected so far, and yes, it's totally understandable to stumble upon rough edges every so often :) 

So far I'm particularly impressed with the work done regarding resources consumption as from what I'm seeing Synergy 2 consumes way less CPU cycles than the previous version.

Share this post


Link to post
Share on other sites

Great! Keep us up to date on your progress. Especially if you hit on a successful sequence. 

Share this post


Link to post
Share on other sites

+1 same problem here on Sierra. It actually worked right after install for me between an Ubuntu server and a MacOS Sierra around September 26, but has stopped working now.

I followed @Martin C.'s suggestion and unloaded the synergy process:

launchctl unload /Library/LaunchAgents/com.symless.synergy.v2.synergyd.plist

And I have the window back. It's still not connecting to my Ubuntu server though. I also tried switching the client and server (MacOS server), but no dice, and nothing helpful in the logs.

Ubuntu server:

[ Config  ] [2017-10-04T14:44:04] INFO: log filename: /home/mtaschuk/.config/Symless/Synergy/synergy.log
[ Config  ] [2017-10-04T14:44:04] DEBUG: connecting to service
[ Config  ] [2017-10-04T14:44:04] DEBUG: new added screen pos: 257 161
[ Config  ] [2017-10-04T14:44:04] DEBUG: Profile ID: 2118 name: default
[ Config  ] [2017-10-04T14:44:05] DEBUG: current version is update to date
[ Config  ] [2017-10-04T14:44:05] DEBUG: requesting profile snapshot
[ Config  ] [2017-10-04T14:44:14] DEBUG: forcing current computer to be server
[ Config  ] [2017-10-04T14:44:16] DEBUG: forcing current computer to be server
[ Config  ] [2017-10-04T15:03:12] DEBUG: forcing current computer to be server
[ Config  ] [2017-10-04T15:06:40] DEBUG: forcing current computer to be server

MacOS client:

[ Config  ] [2017-10-04T15:01:52] ERROR: failed to start crash handler: Couldn't verify crash dump directory: No such file or directory
[ Config  ] [2017-10-04T15:01:52] INFO: log filename: /Users/mtaschuk/Library/Preferences/Symless/Synergy/synergy.log
[ Config  ] [2017-10-04T15:01:52] DEBUG: connecting to service
[ Config  ] [2017-10-04T15:01:53] DEBUG: new added screen pos: 257 161
[ Config  ] [2017-10-04T15:01:55] DEBUG: Profile ID: 2118 name: default
[ Config  ] [2017-10-04T15:01:55] DEBUG: requesting profile snapshot
[ Config  ] [2017-10-04T15:01:55] DEBUG: current version is update to date
[ Config  ] [2017-10-04T15:05:20] DEBUG: forcing current computer to be server

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now