discord

using old ssl libraries in version 1.8

3 posts in this topic

I'm trying to use synergy pro with a linux server and a mac client. On my debian sid host I was getting errors re libcrypto.so.1.0.0 and libssl.so.1.0.0 missing. It appears these are out of date (heartbleed?) and therefore I created a symlink to the missing libraries like sudo ln -s libcrypto.so.1.0.2 libcrypto.so.1.0.0 . Then when I ran synergy on my server I get

/usr/bin/synergys: /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /usr/bin/synergys)
/usr/bin/synergys: /usr/lib/x86_64-linux-gnu/libssl.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /usr/bin/synergys)
[2017-10-03T11:50:10] ERROR: process exited with error code: 1
[2017-10-03T11:50:10] INFO: detected process not running, auto restarting

I read elsewhere this is fixed in 1.9. Can you version bump the debian package so it's not broken? I'd prefer not to send my keystrokes around network.

 

I found a 1.9 rc3 release but it also seemed to rely on the old open ssl 1.0.0 and failed with the same issues. Also it seemed to have some additional dependencies...
 

Unpacking synergy (1.9.0~rc3) over (1.9.0~rc3) ...

dpkg: synergy: dependency problems, but configuring anyway as you requested:

synergy depends on libssl1.0.0 (>= 1.0.0); however:

Package libssl1.0.0 is not installed.

synergy depends on qml-module-qtquick-controls (>= 5.0.2); however:

Package qml-module-qtquick-controls is not installed.

synergy depends on qml-module-qtquick-layouts (>= 5.0.2); however:

Package qml-module-qtquick-layouts is not installed.

synergy depends on qml-module-qtquick-dialogs (>= 5.0.2); however:

Package qml-module-qtquick-dialogs is not installed.

synergy depends on qml-module-qtquick2 (>= 5.0.2); however:

Package qml-module-qtquick2 is not installed.

 
 
I also filed a ticket since I bought a license which I've never had a good chance to use.cleardot.gif

 

Share this post


Link to post
Share on other sites

Also in the 1.9 release notes it appears Windows got a version bump for the openssl library, but not linux :(

Share this post


Link to post
Share on other sites

Looks like the current ssl is 1.1.0, which is also what the windows version is using.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now