Daniel Yeung

Hotkey is not working on other screen

2 posts in this topic

Greeting. My setup as follows: Version: 1.7.3 pro Windows 8.1 - Server Mac OSX 10.10.3 - Client I would like to set a hot key (e.g. "x") and when I press it in OSX screen, it can perform an action on my Win8 screen. In the hotkeys page, I add keyStroke x to the left and a keystroke action (e.g. Shift+Home) on the right with "only on these screens" to my win8 screen. When I press the keystroke in my win8 screen, it works. When I press the keystroke in my OSX, my win8 screen didn't perform the action. I was able to make this work with same config when my server is arch linux and my client is win8. I can press the keystroke in whatever screen I like and still perform the action in my win8 screen which is wonderful. But this does not work in win8 server + osx client. I also tried to reverse the role of win8 and osx (i.e. win8 client and osx server) but still no luck. Is this a bug? Thanks

Share this post


Link to post
Share on other sites
Hello, I fiddled with this on my stuff and got some really interesting results. Whenever I leave my Linux client I lose focus, and my keybinds stop working. I am assuming this is because the applications open on this client are no longer "in focus" and therefore are not receiving any keyboard input. To bring them back into focus would require either clicking on or moving the mouse over them. Bit of a pain because per your dilemma, we would like to use the hotkey without first switching screens. Without focus on a window in any OS I won't be able to send it keyboard events. Different Operating Systems have different ways of controlling focus. You mentioned Arch Linux, which Desktop Environment are you using there?

Share this post


Link to post
Share on other sites
I am running the latest version of gnome3 from the arch linux package repository. It doesn't look like the focus is lost in win8 for this case because you will be noticed that if the focus is being lost, the text cursor is no longer flashing if you are focusing on a text box. My expected perform action in win8 should be a global hotkey (i.e. no matter what you are focusing on, if you press that button / receive the keystroke, the action should be happened). I also tried to enable "Don't take foreground window on Windows servers" in the configuration window but still not working.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now