Padraig

Linux libqt5core5a dependency problem

8 posts in this topic

The beta installer said that there's a dependency of libqt5core5a >= 5.5.0

My server (running Lubuntu 14.04) only can install libqt5core5a version 5.2.1

Synergy 1 has no issues running on this version (I didn't even have libqt5core5a installed)

Is it possible to lower the requirement of libqt5core5a for the next beta release?

Share this post


Link to post
Share on other sites

you can try manually lowering the dependency and then testing it.

Share this post


Link to post
Share on other sites

I lowered it and 3 other deps were too high for Lubuntu so I lowered them too.

Now I'm stuck on a package that's not available ( qml-module-qtquick-controls )

Is Synergy2 only designed for latest version of Linux flavours and not the more stable 14.04 versions? I ask because I cannot update my 14.04 for a a long while yet.

Share this post


Link to post
Share on other sites
On 22/09/2017 at 4:39 PM, Padraig said:

Is Synergy2 only designed for latest version of Linux flavours and not the more stable 14.04 versions?

Only for the beta.

Share this post


Link to post
Share on other sites
On 9/23/2017 at 8:26 PM, Nick Bolton said:

Only for the beta.

Ok, that's fine. I'll have to leave it for a while so until 14.04 is being tested/supported.

Thanks.

Share this post


Link to post
Share on other sites
On 9/22/2017 at 5:39 PM, Padraig said:

I lowered it and 3 other deps were too high for Lubuntu so I lowered them too.

Now I'm stuck on a package that's not available ( qml-module-qtquick-controls )

Is Synergy2 only designed for latest version of Linux flavours and not the more stable 14.04 versions? I ask because I cannot update my 14.04 for a a long while yet.

try removing the dependencies you cant install, you probably already have the necessary dependencies.

or you can try and take a look at this for installing the dependencies via backports.

  • Like 1

Share this post


Link to post
Share on other sites
On 9/25/2017 at 4:20 PM, jaap aarts said:

try removing the dependencies you cant install, you probably already have the necessary dependencies.

or you can try and take a look at this for installing the dependencies via backports.

Hi, even after removing the missing ones (mostly qml-module-*), it installed but would not run.

I won't bother doing the backports, I need the machine to be stable.

I will try it again when there's an official beta for Lubuntu 14.04. For now, I'll revert to the old version.

Thanks.

Share this post


Link to post
Share on other sites

okay, if you need your machine to be stable use the old version.

fixing a broken system can be annoying and time consuming, dont do it when you need it up and running.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now