patch

Win7. synergy2.exe has stopped working

15 posts in this topic

As in the title, installed synergy2 beta on a Windows 7 desktop and first run fails with the above error. Uninstall/reinstall produces the same issue.

There's nothing special about the device, domain joined Win7 patched up to date running as a non-admin user (although run as admin exhibits the same issue). 

Here's the event from application event log, I can find no other trace as to what might be going on.

Log Name:      Application
Source:        Application Error
Date:          21/09/2017 17:56:24
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      AgentPC
Description:
Faulting application name: synergy2.exe, version: 0.0.0.0, time stamp: 0x59b9380d
Faulting module name: ig4icd64.dll, version: 8.14.10.1930, time stamp: 0x4aba7134
Exception code: 0xc0000005
Fault offset: 0x00000000002a3cb5
Faulting process id: 0xd54
Faulting application start time: 0x01d332fa89c0d77f
Faulting application path: C:\Program Files\Synergy\synergy2.exe
Faulting module path: C:\Windows\system32\ig4icd64.dll
Report Id: cc94c723-9eed-11e7-9732-002170048699
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2017-09-21T16:56:24.000000000Z" />
    <EventRecordID>61155</EventRecordID>
    <Channel>Application</Channel>
    <Computer>AgentPC</Computer>
    <Security />
  </System>
  <EventData>
    <Data>synergy2.exe</Data>
    <Data>0.0.0.0</Data>
    <Data>59b9380d</Data>
    <Data>ig4icd64.dll</Data>
    <Data>8.14.10.1930</Data>
    <Data>4aba7134</Data>
    <Data>c0000005</Data>
    <Data>00000000002a3cb5</Data>
    <Data>d54</Data>
    <Data>01d332fa89c0d77f</Data>
    <Data>C:\Program Files\Synergy\synergy2.exe</Data>
    <Data>C:\Windows\system32\ig4icd64.dll</Data>
    <Data>cc94c723-9eed-11e7-9732-002170048699</Data>
  </EventData>
</Event>

Share this post


Link to post
Share on other sites
On 9/21/2017 at 11:12 AM, patch said:

ig4icd64.dll

That is an Intel graphics driver dll file as far as I am aware. I wonder if your graphics driver is out of date here, that is odd that that would have anything to do with it overall.

Share this post


Link to post
Share on other sites

Hmm, interesting idea. We use Qt, so maybe there's a problem with that library?

Share this post


Link to post
Share on other sites

I know that anything that uses OpenGL to render in any way can cause issues in that DLL if the graphical drivers are out of date, or overgeneralized like using Microsoft's versions not the manufacturer's. Happens in Minecraft and many games for example.

Share this post


Link to post
Share on other sites

Onoitsu2 was right, the graphics driver was horribly out of date, I've pulled down the latest and just updated but no change. I've checked other drivers and update a couple that were equally aged. Still getting the same issue, just a complete freeze and crash on start up of synergy.

I've emailed as requested Nick.

Share this post


Link to post
Share on other sites

Darn, was worth a shot there Patch. I saw what screamed at me graphics driver, and thought the UI's rendering itself could have been the cause. No matter, we'll leave this to the actual Devs of the software :) I am sure with that information they can isolate it.

Share this post


Link to post
Share on other sites

It was a good call, there's clearly something up with how it's interacting with that driver.

Share this post


Link to post
Share on other sites

I have the exact same issue, both on a Win7 and Win10 machines. Neither of them are even starting. The logs from my EventViewer is basically the same as posted earlier. I have already sent the logs to the dev way before I found this thread.

Share this post


Link to post
Share on other sites

Same DLL? 

Whats the make/model of your systems? 

Mine was an old Dell Optiplex 755. It's been fine everywhere else I have used it. 

Share this post


Link to post
Share on other sites

Hi,

After looking closely, this is not the same DLL that is causing the crash.

My machines are:

Win7: Lenovo ThinkCentre M83  Intel i5-4570 @3.20Ghz + 4Go RAM

Win10: Lenovo ThinCentre M3282: intel i5 @3.20Ghz + 4Go RAM

Win7_logs:

- <System>
  <Provider Name="Application Error" /> 
  <EventID Qualifiers="0">1000</EventID> 
  <Level>2</Level> 
  <Task>100</Task> 
  <Keywords>0x80000000000000</Keywords> 
  <TimeCreated SystemTime="2017-09-26T14:42:25.000000000Z" /> 
  <EventRecordID>34477</EventRecordID> 
  <Channel>Application</Channel> 
  <Computer>WDHDVDOMLAB.ville.XXXXXXXX.qc.ca</Computer> 
  <Security /> 
  </System>
- <EventData>
  <Data>synergy2.exe</Data> 
  <Data>0.0.0.0</Data> 
  <Data>59b9380d</Data> 
  <Data>ucrtbase.DLL</Data> 
  <Data>10.0.10586.788</Data> 
  <Data>5879ab76</Data> 
  <Data>40000015</Data> 
  <Data>000000000006990f</Data> 
  <Data>100c</Data> 
  <Data>01d336d5aa9c4de1</Data> 
  <Data>C:\Program Files\Synergy\synergy2.exe</Data> 
  <Data>C:\Windows\system32\ucrtbase.DLL</Data> 
  <Data>e928e821-a2c8-11e7-8e4c-0023249e61b1</Data> 
  </EventData>
  </Event>

Win10 logs:

- <System>
  <Provider Name="Application Error" /> 
  <EventID Qualifiers="0">1000</EventID> 
  <Level>2</Level> 
  <Task>100</Task> 
  <Keywords>0x80000000000000</Keywords> 
  <TimeCreated SystemTime="2017-09-26T14:41:14.601269900Z" /> 
  <EventRecordID>3225</EventRecordID> 
  <Channel>Application</Channel> 
  <Computer>AUTOBVT-LHFHU72.ville.XXXXXXXX.qc.ca</Computer> 
  <Security /> 
  </System>
- <EventData>
  <Data>synergy2.exe</Data> 
  <Data>0.0.0.0</Data> 
  <Data>59b9380d</Data> 
  <Data>ucrtbase.dll</Data> 
  <Data>10.0.15063.413</Data> 
  <Data>5ba8b66e</Data> 
  <Data>c0000409</Data> 
  <Data>00000000000734be</Data> 
  <Data>21b4</Data> 
  <Data>01d336d57fc8bcd9</Data> 
  <Data>C:\Program Files\Synergy\synergy2.exe</Data> 
  <Data>C:\Windows\System32\ucrtbase.dll</Data> 
  <Data>e04ea449-92a0-4110-a4cd-00814dcb75b3</Data> 
  <Data /> 
  <Data /> 
  </EventData>
  </Event>
  -----------------------------------------
- <System>
  <Provider Name="synergy-service-controller" /> 
  <EventID Qualifiers="0">0</EventID> 
  <Level>2</Level> 
  <Task>0</Task> 
  <Keywords>0x80000000000000</Keywords> 
  <TimeCreated SystemTime="2017-09-26T14:48:17.452046500Z" /> 
  <EventRecordID>3233</EventRecordID> 
  <Channel>Application</Channel> 
  <Computer>AUTOBVT-LHFHU72.ville.XXXXXXXX.qc.ca</Computer> 
  <Security /> 
  </System>
- <EventData>
  <Data>synergy-service-controller</Data> 
  <Data>Failed to shutdown synergyd.exe</Data> 
  </EventData>
  </Event>

Share this post


Link to post
Share on other sites

Not familiar with that dell, seems it's part of the Microsoft C stack. 

Beyond me to suggest a fix. I did get a message saying beta 5 is out on the 9th so I'm holding it until then.

Share this post


Link to post
Share on other sites
40 minutes ago, patch said:

Not familiar with that dell, seems it's part of the Microsoft C stack. 

Beyond me to suggest a fix. I did get a message saying beta 5 is out on the 9th so I'm holding it until then.

I did too, hopefully I will be able to use this application at the next update.

Share this post


Link to post
Share on other sites
3 minutes ago, Merolas said:

I did too, hopefully I will be able to use this application at the next update.

Probably not, they'll probably use the same UI. and if not Idd think they would have said something here.

Share this post


Link to post
Share on other sites

Same problem.  Win7 Synergy 2 b4 don't work. Works fine on Linux (Kubuntu) and OSX ( 10.13 ).

 <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Application Error" /> 
  <EventID Qualifiers="0">1000</EventID> 
  <Level>2</Level> 
  <Task>100</Task> 
  <Keywords>0x80000000000000</Keywords> 
  <TimeCreated SystemTime="2017-10-11T12:49:05.000000000Z" /> 
  <EventRecordID>316191</EventRecordID> 
  <Channel>Application</Channel> 
  <Computer>H2014RU19420A.azgroup.itad.corpnet</Computer> 
  <Security /> 
  </System>
- <EventData>
  <Data>synergy2.exe</Data> 
  <Data>0.0.0.0</Data> 
  <Data>59b9380d</Data> 
  <Data>ucrtbase.DLL</Data> 
  <Data>10.0.10240.16390</Data> 
  <Data>55a5b718</Data> 
  <Data>40000015</Data> 
  <Data>0000000000065a5f</Data> 
  <Data>30c8</Data> 
  <Data>01d3428f457e55a4</Data> 
  <Data>C:\Program Files\Synergy\synergy2.exe</Data> 
  <Data>C:\Windows\system32\ucrtbase.DLL</Data> 
  <Data>90532f5b-ae82-11e7-b56d-6c3be52f07b1</Data> 
  </EventData>
  </Event>

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now