stuart macmillan

Windows Login

9 posts in this topic

Hi,

I cant use synergy 2 to log into windows on a client machine. 

From what I can see the config file is saved in the Windows user appdata folder. If this is the case then I assume the user has to be logged in before synergy will work. Is this correct?

If so then how can I log in to a client pc with no keyboard and mouse?

Am I missing something?

Stuart

Share this post


Link to post
Share on other sites

Can you RDP into the client machine to log into it and then set it up ?

Share this post


Link to post
Share on other sites

It's installed and working. I just can't log into the machine after a restart without a keyboard and mouse.

Share this post


Link to post
Share on other sites

interesting, I wonder if it could be made a service to start at boot vs after login.

Share this post


Link to post
Share on other sites
30 minutes ago, CapnJoe said:

interesting, I wonder if it could be made a service to start at boot vs after login.

I like that thought, that is how ScreenConnect (now Connectwise Control) works, as a system service. I never minded v1 being an after login service because I use ScreenConnect (yes older version) paired with v1 Synergy. But if it could permit control at the login screen it would be awesome for my work Mac too.

Share this post


Link to post
Share on other sites

It is running as a service and did in v1 as well. It wasn't a problem before.

it just looks like the config file is stored in the users data so the service won't know where to find it until the user logs in.

But as I said before I might be missing something.

Stuart

Share this post


Link to post
Share on other sites

I have also found that when I sign out of windows I need to use an attached keyboard and mouse to sign in again.

After that get a single "screen" on synergy until I restart the service, reopen the app and F12 on the server. It all works as normal after that.

Here are the logs I get after the sign in:

[ Config  ] [2017-09-22T08:01:03] ERROR: failed to start crash handler: Couldn't verify crash dump directory: The system cannot find the file specified
[ Config  ] [2017-09-22T08:01:03] INFO: log filename: C:/Users/Server/AppData/Local/Symless/Synergy/synergy.log
[ Config  ] [2017-09-22T08:01:03] DEBUG: connecting to service
[ Config  ] [2017-09-22T08:01:03] DEBUG: new added screen pos: 257 161
[ Config  ] [2017-09-22T08:01:05] DEBUG: Profile ID: 973 name: default
[ Config  ] [2017-09-22T08:01:05] DEBUG: current version is update to date
[ Config  ] [2017-09-22T08:01:05] DEBUG: requesting profile snapshot

It never gets to the normal lines until I restart the service:

[ Service ] [2017-09-22T08:08:52] debug: sending last profile snapshot
[ Service ] [2017-09-22T08:08:52] debug: config ui opened, forcing connectivity test

Stuart

 

 

Share this post


Link to post
Share on other sites
4 hours ago, stuart macmillan said:

This is now working in Beta5 :D

Woohoo!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now