Mathias Sørensen

Start before GDM

3 posts in this topic

Hi Synergy community,

I have a client running on Ubuntu 17.04, uninstalled lightdm and installed GDM because every 2. time i move from Windows 10 to the ubuntu machine the cursor is hidden.

I have gone thouge this guide https://help.ubuntu.com/community/SynergyHowto#On_the_Client-1 to start before GDM login screen so at no time i need keyboard and mouse to login.

Any one know what i need to do to get this working?

 

 

Share this post


Link to post
Share on other sites

EDIT:

I went back to lightdm my solution to the mouse only showing every 2. time is:

gsettings set org.gnome.settings-daemon.plugins.cursor active false

then i did thisin /etc/lightdm/lightdm.conf

[SeatDefaults]
greeter-setup-script=/usr/bin/synergyc --name MYHOSTNAMEFORTHEPC --enable-crypto SERVERIP:24800

then chmod +x /etc/lightdm/lightdm.conf

now my server says 

Quote

[2017-09-20T13:36:07] INFO: OpenSSL 1.0.2 22 Jan 2015

[2017-09-20T13:36:07] INFO: accepted secure socket

[2017-09-20T13:36:07] INFO: AES256-GCM-SHA384 TLSv1.2 Kx=RSA Au=RSA Enc=AESGCM(256) Mac=AEAD

[2017-09-20T13:36:07] NOTE: accepted client connection

[2017-09-20T13:36:22] NOTE: new client disconnected

DiskPC is setup to the left og my main screen

Share this post


Link to post
Share on other sites

 Problem has been identified, --enable-crypto is causing all the trouble.

Edited by Mathias Sørensen

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now