FireFrenzy

Symless Beta 4 non functional on Win10 Pro 64bit

16 posts in this topic

[ Service ] [2017-09-14T18:49:26] debug: core process shutdown complete

[ Service ] [2017-09-14T18:49:26] debug: starting core process with command: C:\Program Files\Synergy\synergys.exe -f --no-tray --debug DEBUG --name Yggdrasil --enable-drag-drop --profile-dir C:\Users\FireFrenzy\AppData\Local\Symless\Synergy --log synergy.log -c C:\Users\FireFrenzy\AppData\Local\Symless\Synergy\synergy.conf --address :24800

[ Service ] [2017-09-14T18:49:26] debug: core process started, id=1600

[ Core ] [2017-09-14T18:49:26] INFO: drag and drop enabled

[ Core ] [2017-09-14T18:49:26] DEBUG: opening configuration "C:\Users\FireFrenzy\AppData\Local\Symless\Synergy\synergy.conf"

[ Core ] [2017-09-14T18:49:26] DEBUG: configuration read successfully

[ Core ] [2017-09-14T18:49:26] DEBUG: screen shape: -1920,0 5760x1080 (multi-monitor)

[ Core ] [2017-09-14T18:49:26] ERROR: failed to get desktop path, no drop target available, error=2

[ Core ] [2017-09-14T18:49:26] DEBUG: window is 0x0006113e

[ Core ] [2017-09-14T18:49:26] DEBUG: adopting new buffer

[ Core ] [2017-09-14T18:49:26] DEBUG: opened display

[ Core ] [2017-09-14T18:49:26] DEBUG: active sides: 10

[ Core ] [2017-09-14T18:49:26] DEBUG: active sides: 10

[ Core ] [2017-09-14T18:49:26] DEBUG: desk Default window is 0x00091044

[ Core ] [2017-09-14T18:49:26] DEBUG: switched to desk "Default"

[ Core ] [2017-09-14T18:49:26] DEBUG: desktop is now accessible

[ Core ] [2017-09-14T18:49:26] DEBUG: registered hotkey ScrollLock (id=ef14 mask=0000) as id=1

[ Core ] [2017-09-14T18:49:26] NOTE: started server, waiting for clients

[ Core ] [2017-09-14T18:49:26] DEBUG: event queue is ready

[ Core ] [2017-09-14T18:49:26] DEBUG: add pending events to buffer

[ Core ] [2017-09-14T18:49:26] DEBUG: screen "Yggdrasil" shape changed

[ Service ] [2017-09-14T18:49:27] debug: comparing profiles, id=241 this=v3 other=v3

[ Service ] [2017-09-14T18:49:27] debug: profile screen status changed, screenId=463 Connected->Connecting

[ Service ] [2017-09-14T18:49:27] debug: profile changed, storing local copy

[ Service ] [2017-09-14T18:49:27] debug: comparing profiles, id=241 this=v3 other=v3

[ Service ] [2017-09-14T18:49:27] debug: profile screen status changed, screenId=463 Connecting->Connected

[ Service ] [2017-09-14T18:49:27] debug: profile changed, storing local copy

[ Service ] [2017-09-14T18:49:31] debug: comparing profiles, id=241 this=v3 other=v4

[ Service ] [2017-09-14T18:49:31] debug: profile screen position changed, screenId=467 258,219->343,219

[ Service ] [2017-09-14T18:49:31] debug: profile changed, storing local copy

[ Service ] [2017-09-14T18:49:31] debug: handling local profile screen position changed, mode=server

[ Service ] [2017-09-14T18:49:31] debug: starting core server process

[ Service ] [2017-09-14T18:49:31] debug: process already running, attempting to stop

[ Service ] [2017-09-14T18:49:31] debug: stopping core process

[ Service ] [2017-09-14T18:49:31] debug: core process exited: code=1 expected=true

[ Service ] [2017-09-14T18:49:31] debug: core process shutdown complete

[ Service ] [2017-09-14T18:49:31] debug: starting core process with command: C:\Program Files\Synergy\synergys.exe -f --no-tray --debug DEBUG --name Yggdrasil --enable-drag-drop --profile-dir C:\Users\FireFrenzy\AppData\Local\Symless\Synergy --log synergy.log -c C:\Users\FireFrenzy\AppData\Local\Symless\Synergy\synergy.conf --address :24800

[ Service ] [2017-09-14T18:49:31] debug: core process started, id=15264

[ Core ] [2017-09-14T18:49:31] INFO: drag and drop enabled

[ Core ] [2017-09-14T18:49:31] DEBUG: opening configuration "C:\Users\FireFrenzy\AppData\Local\Symless\Synergy\synergy.conf"

[ Core ] [2017-09-14T18:49:31] DEBUG: configuration read successfully

[ Core ] [2017-09-14T18:49:31] DEBUG: screen shape: -1920,0 5760x1080 (multi-monitor)

[ Core ] [2017-09-14T18:49:31] ERROR: failed to get desktop path, no drop target available, error=2

[ Core ] [2017-09-14T18:49:31] DEBUG: window is 0x000b0040

[ Core ] [2017-09-14T18:49:31] DEBUG: adopting new buffer

[ Core ] [2017-09-14T18:49:31] DEBUG: opened display

[ Core ] [2017-09-14T18:49:31] DEBUG: active sides: 0

[ Core ] [2017-09-14T18:49:31] DEBUG: active sides: 0

[ Core ] [2017-09-14T18:49:31] DEBUG: desk Default window is 0x000a1044

[ Core ] [2017-09-14T18:49:31] DEBUG: switched to desk "Default"

[ Core ] [2017-09-14T18:49:31] DEBUG: desktop is now accessible

[ Core ] [2017-09-14T18:49:31] DEBUG: registered hotkey ScrollLock (id=ef14 mask=0000) as id=1

[ Core ] [2017-09-14T18:49:31] NOTE: started server, waiting for clients

[ Core ] [2017-09-14T18:49:31] DEBUG: event queue is ready

[ Core ] [2017-09-14T18:49:31] DEBUG: add pending events to buffer

[ Core ] [2017-09-14T18:49:31] DEBUG: screen "Yggdrasil" shape changed

[ Service ] [2017-09-14T18:49:31] debug: comparing profiles, id=241 this=v4 other=v4

[ Service ] [2017-09-14T18:49:31] debug: profile screen status changed, screenId=463 Connected->Connecting

[ Service ] [2017-09-14T18:49:31] debug: profile changed, storing local copy

[ Service ] [2017-09-14T18:49:32] debug: comparing profiles, id=241 this=v4 other=v4

[ Service ] [2017-09-14T18:49:32] debug: profile screen status changed, screenId=463 Connecting->Connected

[ Service ] [2017-09-14T18:49:32] debug: profile changed, storing local copy

[ Service ] [2017-09-14T18:49:34] debug: comparing profiles, id=241 this=v4 other=v5

[ Service ] [2017-09-14T18:49:34] debug: profile screen position changed, screenId=467 343,219->257,219

[ Service ] [2017-09-14T18:49:34] debug: profile changed, storing local copy

[ Service ] [2017-09-14T18:49:34] debug: handling local profile screen position changed, mode=server

[ Service ] [2017-09-14T18:49:34] debug: starting core server process

[ Service ] [2017-09-14T18:49:34] debug: process already running, attempting to stop

[ Service ] [2017-09-14T18:49:34] debug: stopping core process

[ Service ] [2017-09-14T18:49:35] debug: core process exited: code=1 expected=true

[ Service ] [2017-09-14T18:49:35] debug: core process shutdown complete

[ Service ] [2017-09-14T18:49:35] debug: starting core process with command: C:\Program Files\Synergy\synergys.exe -f --no-tray --debug DEBUG --name Yggdrasil --enable-drag-drop --profile-dir C:\Users\FireFrenzy\AppData\Local\Symless\Synergy --log synergy.log -c C:\Users\FireFrenzy\AppData\Local\Symless\Synergy\synergy.conf --address :24800

[ Service ] [2017-09-14T18:49:35] debug: core process started, id=7568

[ Core ] [2017-09-14T18:49:35] INFO: drag and drop enabled

[ Core ] [2017-09-14T18:49:35] DEBUG: opening configuration "C:\Users\FireFrenzy\AppData\Local\Symless\Synergy\synergy.conf"

[ Core ] [2017-09-14T18:49:35] DEBUG: configuration read successfully

[ Core ] [2017-09-14T18:49:35] DEBUG: screen shape: -1920,0 5760x1080 (multi-monitor)

[ Core ] [2017-09-14T18:49:35] ERROR: failed to get desktop path, no drop target available, error=2

[ Core ] [2017-09-14T18:49:35] DEBUG: window is 0x0008113e

[ Core ] [2017-09-14T18:49:35] DEBUG: adopting new buffer

[ Core ] [2017-09-14T18:49:35] DEBUG: opened display

[ Core ] [2017-09-14T18:49:35] DEBUG: active sides: 10

[ Core ] [2017-09-14T18:49:35] DEBUG: active sides: 10

[ Core ] [2017-09-14T18:49:35] DEBUG: desk Default window is 0x000c0040

[ Core ] [2017-09-14T18:49:35] DEBUG: switched to desk "Default"

[ Core ] [2017-09-14T18:49:35] DEBUG: desktop is now accessible

[ Core ] [2017-09-14T18:49:35] DEBUG: registered hotkey ScrollLock (id=ef14 mask=0000) as id=1

[ Core ] [2017-09-14T18:49:35] NOTE: started server, waiting for clients

[ Core ] [2017-09-14T18:49:35] DEBUG: event queue is ready

[ Core ] [2017-09-14T18:49:35] DEBUG: add pending events to buffer

[ Core ] [2017-09-14T18:49:35] DEBUG: screen "Yggdrasil" shape changed

[ Service ] [2017-09-14T18:49:35] debug: comparing profiles, id=241 this=v5 other=v5

[ Service ] [2017-09-14T18:49:35] debug: profile screen status changed, screenId=463 Connected->Connecting

[ Service ] [2017-09-14T18:49:35] debug: profile changed, storing local copy

[ Service ] [2017-09-14T18:49:35] debug: comparing profiles, id=241 this=v5 other=v5

[ Service ] [2017-09-14T18:49:35] debug: profile screen status changed, screenId=463 Connecting->Connected

[ Service ] [2017-09-14T18:49:35] debug: profile changed, storing local copy

[ Service ] [2017-09-14T18:49:42] debug: tcp client connect error: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond

[ Service ] [2017-09-14T18:49:42] debug: connectivity test failed for 192.168.2.5:24810

[ Config ] [2017-09-14T18:51:11] INFO: Sending log file...

[ Config ] [2017-09-14T18:51:13] INFO: Upload path: https://synergy-logs.symless.com/2017-09-14/250-2017-09-14T18-51-11.log

 

 

Share this post


Link to post
Share on other sites

And now for the other half:

 

[ Config ] [2017-09-14T18:51:03] INFO: log filename: C:/Users/FireFrenzy/AppData/Local/Symless/Synergy/synergy.log

[ Config ] [2017-09-14T18:51:03] DEBUG: connecting to service

[ Config ] [2017-09-14T18:51:03] DEBUG: connected to service

[ Config ] [2017-09-14T18:51:05] DEBUG: new added screen pos: 257 161

[ Config ] [2017-09-14T18:51:07] DEBUG: Profile ID: 241 name: default

[ Config ] [2017-09-14T18:51:07] DEBUG: current version is update to date

[ Config ] [2017-09-14T18:51:07] DEBUG: requesting profile snapshot

[ Service ] [2017-09-14T18:51:07] debug: sending last profile snapshot

[ Service ] [2017-09-14T18:51:07] debug: config ui opened, forcing connectivity test

[ Service ] [2017-09-14T18:51:07] debug: new screens detected (2), preparing connectivity test

[ Service ] [2017-09-14T18:51:07] debug: starting connectivity test

[ Service ] [2017-09-14T18:51:07] debug: handling local profile screen set changed, mode=client

[ Service ] [2017-09-14T18:51:10] debug: failed report: dest = 463, ips = 192.168.2.4

[ Service ] [2017-09-14T18:51:10] debug: local profile modified, id=241

[ Service ] [2017-09-14T18:51:10] debug: comparing profiles, id=241 this=v5 other=v5

[ Service ] [2017-09-14T18:51:10] debug: profile screen test result changed, screenId=463 success=``->`` failed=``->`192.168.2.4`

[ Service ] [2017-09-14T18:51:10] debug: handling new report from connectivity tester, screenId=463 successfulIp= lastServerId=463

[ Service ] [2017-09-14T18:51:10] debug: finished connectivity test

[ Service ] [2017-09-14T18:51:28] debug: tcp client connect error: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond

[ Service ] [2017-09-14T18:51:28] debug: connectivity test failed for 192.168.2.4:24810

[ Config ] [2017-09-14T18:52:43] INFO: Sending log file...

[ Config ] [2017-09-14T18:52:45] INFO: Upload path: https://synergy-logs.symless.com/2017-09-14/250-2017-09-14T18-52-44.lo

Share this post


Link to post
Share on other sites

Incase it helps,

Top PC is top post, Laptop is on the bottom...

IMG_20170914_185403[1].jpg

Share this post


Link to post
Share on other sites

I had the same issue. It's windows firewall. Make sure you add all the exe's in synergy folder to windows firewall exception.

Share this post


Link to post
Share on other sites

Guess i'll undo the rollback to 1.8.8 then:) Since i bought beta i figure i might as well actually beta test :)

 

Share this post


Link to post
Share on other sites

Since i apparently do not have Editing privileges, it seems the AVG on my laptop is throwing a hissy fit about SynergyC,exe, i have told it trust it but that doesnt appear to actually DO ANYTHING...

I've Manually added an exception in AVG for all the main EXEs (synergy2, synergyc and synergyd) and that seems to have solved the problem... That said the new beta now functions but it seems to still lack "minimize to tray" functionality...

As far as i am concerned this means all the fiddling i just did is worthless since without that functionality the program is just NOT a viable product to me... I HATE having shit on my start bar that doesn't need to be there... And i'm saying that as a dude with 3x27" monitors giving me -no joke i measured this- 1meter and 78.5 centimeters of task bar, its more if include the bezels...

Share this post


Link to post
Share on other sites

win 10 pro x64 and synergy seem to work fine - with other win10 machines and with win 7.  The biggest problem I have is that the ability to snap to the side of the screen seems to be gone on the server.

Share this post


Link to post
Share on other sites
16 hours ago, FireFrenzy said:

[ Service ] [2017-09-14T18:51:10] debug: profile screen test result changed, screenId=463 success=``->`` failed=``->`192.168.2.4`

 

The connect test is failing. Try restarting the services on both computers.

Share this post


Link to post
Share on other sites

It was the firewall, it's solved...


AVG has also whitelisted the exe on their end

Share this post


Link to post
Share on other sites

I am having this issue, too. My firewall is showing the correct entries and I can see that it's connecting and updating as I move things around... I just can't move the mouse between computers. I have an odd setup. My laptop is a client that has an over/under setup, and the left screen is my primary computer acting as Server.

As simple as this interface is... I really would like an option to show live logs, like the old one. I'd at least see why the transition isn't happening.

IMG_20170915_085621.jpg

Share this post


Link to post
Share on other sites

Something similar is happening on my end.  I have 3 computers set up to test this.  They are

The first 2 are windows 10 pro x64 boxes:

Far left = cnccr1l

middle (and server) = cnccr0j

right (and windows 7 pro x64) = cnccr0i

 

No matter how I set it up the win 7 box is not accessible, as you can see in the attachment is does not even recognize the existence of the other 2 machines, while the others see it as alive.

 

synergy working on windows 10.PNG

synergy not working on windows 7.PNG

Share this post


Link to post
Share on other sites

That did it and solved the hotcorners/stacked problem.  Now to go to my left screen I have to use the upper left hand corner like I have it set up, while going to the right I can just go over using the middle of the screen, like that one is setup.  Everything is green now.

 

I had to restart the service on all three machines and then restart Synergy and finally press f12 on the main machine - but it worked.

Share this post


Link to post
Share on other sites
8 minutes ago, tzucker said:

I had to restart the service on all three machines and then restart Synergy and finally press f12 on the main machine - but it worked.

Yeah, that's quite typical for beta4. It'll be fixed in beta5 though.

Share this post


Link to post
Share on other sites

I'm all green now after several restarts and hitting F12 on each computer. But... my mouse still won't transit between computers? Also, is there a command list, like bound keys and debug screens, that I should be looking at?

(It seems like it's being blocked at the port? 24810. But I have the Windows firewall opened for all things associated with Synergy file names. However, I'm going to try opening the port after this.)

I can't attach my log file, but I'll inject the last 20 or so lines:

[ Service ] [2017-09-15T12:21:24] debug: comparing profiles, id=210 this=v16 other=v16
[ Service ] [2017-09-15T12:21:24] debug: profile screen active changed, screenId=410 false->true
[ Service ] [2017-09-15T12:21:24] debug: new screens detected (1), preparing connectivity test
[ Service ] [2017-09-15T12:21:24] debug: starting connectivity test
[ Service ] [2017-09-15T12:21:24] debug: profile changed, storing local copy
[ Service ] [2017-09-15T12:21:24] debug: comparing profiles, id=210 this=v16 other=v16
[ Service ] [2017-09-15T12:21:24] debug: profile screen active changed, screenId=409 false->true
[ Service ] [2017-09-15T12:21:24] debug: new screens detected (1), preparing connectivity test
[ Service ] [2017-09-15T12:21:24] debug: profile changed, storing local copy
[ Service ] [2017-09-15T12:21:24] debug: comparing profiles, id=210 this=v16 other=v16
[ Service ] [2017-09-15T12:21:24] debug: profile screen status changed, screenId=409 Connected->Connecting
[ Service ] [2017-09-15T12:21:24] debug: profile changed, storing local copy
[ Service ] [2017-09-15T12:21:24] debug: comparing profiles, id=210 this=v16 other=v16
[ Service ] [2017-09-15T12:21:24] debug: profile has not changed, no action needed
[ Service ] [2017-09-15T12:21:24] debug: comparing profiles, id=210 this=v16 other=v16
[ Service ] [2017-09-15T12:21:24] debug: profile screen status changed, screenId=409 Connecting->Connected
[ Service ] [2017-09-15T12:21:24] debug: profile changed, storing local copy
[ Service ] [2017-09-15T12:21:27] debug: failed report: dest = 410, ips = 192.168.0.153
[ Service ] [2017-09-15T12:21:27] debug: local profile modified, id=210
[ Service ] [2017-09-15T12:21:27] debug: comparing profiles, id=210 this=v16 other=v16
[ Service ] [2017-09-15T12:21:27] debug: profile screen test result changed, screenId=410 success=``->`` failed=``->`192.168.0.153`
[ Service ] [2017-09-15T12:21:27] debug: handling new report from connectivity tester, screenId=410 successfulIp= lastServerId=409
[ Service ] [2017-09-15T12:21:27] debug: finished connectivity test
[ Service ] [2017-09-15T12:21:45] debug: tcp client connect error: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond
[ Service ] [2017-09-15T12:21:45] debug: connectivity test failed for 192.168.0.153:24810

Synergy_2.png

Edited by Erik Collett

Share this post


Link to post
Share on other sites

Could you use the Send Logs feature? I need to see the whole log.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now