QuantumRiff

Error 400 in beta 4 on Linux

21 posts in this topic

I upgraded both computers (Ubuntu 17.04 and Fedora 26) to beta 4. both log in fine, however, they do not see each other, and the monitor icon's stay black.


When I attempt to move a monitor around the screen, this error appears in logs:

[ Config  ] [2017-09-13T08:21:50] ERROR: Reply status code: 400
[ Config  ] [2017-09-13T08:21:50] ERROR: Reply error message: Invalid JSON request: bad numeric conversion: negative overflow

 

Share this post


Link to post
Share on other sites

Ah, right now on Linux you need to start the service manually: /usr/bin/synergyd

Share this post


Link to post
Share on other sites

This is a good reason for a release note :)

Its working now.  Does this register as a service with systemd? or do I need to create my own?

Share this post


Link to post
Share on other sites

Yeah, we dropped the ball for Linux in beta4, sorry. It's supposed to create a systemd but there's a bug. Could you try creating one?

Share this post


Link to post
Share on other sites

I spoke too soon about it working. Its getting errors. it appears its trying to connect to its peer on port 24800, but the new service for beta4 does not appear to be using that port, it seems to be using 24810 and 24888

 

Share this post


Link to post
Share on other sites

Damn, looks like it's not generating a config on Linux. That's really bad.

[ Core    ] [2017-09-13T18:20:56] DEBUG: opening configuration "/home/jaap/.config/synergy/synergy.conf"
[ Core    ] [2017-09-13T18:20:56] DEBUG: cannot open configuration "/home/jaap/.config/synergy/synergy.conf"
[ Core    ] synergys: no configuration available

 

Share this post


Link to post
Share on other sites
Just now, QuantumRiff said:

it seems to be using 24810 and 24888

Yeah, it does a connectivity test on a different port (for now). We're going to unify that in beta5.

Share this post


Link to post
Share on other sites
2 minutes ago, Nick Bolton said:

Damn, looks like it's not generating a config on Linux. That's really bad.

[ Core    ] [2017-09-13T18:20:56] DEBUG: opening configuration "/home/jaap/.config/synergy/synergy.conf"
[ Core    ] [2017-09-13T18:20:56] DEBUG: cannot open configuration "/home/jaap/.config/synergy/synergy.conf"
[ Core    ] synergys: no configuration available

 

I do see a file Synergy.conf inside ~/.config/Synergy(synergy1.0?):

[General]
activationHasRun=true
autoConfig=true
autoConfigPrompted=true
autoHide=false
etc(not going to cluther the forum with config files)
Edited by jaap aarts

Share this post


Link to post
Share on other sites

I have one, but i'm guessing its an old one from the last beta3?

(renamed screens for privacy)
 

cat ~/.config/Symless/Synergy/synergy.conf
section: screens
    desktop:
        halfDuplexCapsLock = false
        halfDuplexNumLock = false
        halfDuplexScrollLock = false
        xtestIsXineramaUnaware = false
        switchCorners = none
        switchCornerSize = 0
    laptop:
        halfDuplexCapsLock = false
        halfDuplexNumLock = false
        halfDuplexScrollLock = false
        xtestIsXineramaUnaware = false
        switchCorners = none
        switchCornerSize = 0
end

section: links
    desktop:
        right = blight
    laptop:
        left = desktop
end

section: options
        relativeMouseMoves = false
        screenSaverSync = true
        win32KeepForeground = false
        switchCorners = none
        switchCornerSize = 0
end

 

Share this post


Link to post
Share on other sites

Damn, it's looking in:

/home/jaap/.config/synergy/synergy.conf

But, it should be opening: 

~/.config/Symless/Synergy/synergy.conf

Could you create a symlink?

Share this post


Link to post
Share on other sites

I systemlinked /home/jaap/.config/synergy/synergy.conf to /home/jaap/.config/Symless/Synergy/synergy.conf

ln /home/jaap/.config/Symless/Synergy/synergy.conf /home/jaap/.config/synergy/synergy.con

still same problem

Share this post


Link to post
Share on other sites
6 minutes ago, jaap aarts said:

I systemlinked /home/jaap/.config/synergy/synergy.conf to /home/jaap/.config/Symless/Synergy/synergy.conf

ln /home/jaap/.config/Symless/Synergy/synergy.conf /home/jaap/.config/synergy/synergy.con

still same problem

Try .conf?

Share this post


Link to post
Share on other sites
mkdir -p ~/.config/synergy/
ln -s ~/.config/Symless/Synergy/synergy.conf ~/.config/synergy/synergy.conf
/usr/bin/synergyd
#then open app in gnome


they are both  connected now.

However, I have the same issue I had in beta 3, but I'll start a new thread for that.

  • Like 1

Share this post


Link to post
Share on other sites
Just now, Nick Bolton said:

Try .conf?

sry, the f wasnt copied correctly, I checked and it was there

Share this post


Link to post
Share on other sites
1 minute ago, QuantumRiff said:
mkdir -p ~/.config/synergy/
ln -s ~/.config/Symless/Synergy/synergy.conf ~/.config/synergy/synergy.conf
/usr/bin/synergyd
#then open app in gnome


they are both  connected now.

However, I have the same issue I had in beta 3, but I'll start a new thread for that.

ln: failed to create symbolic link '/home/jaap/.config/synergy/synergy.conf': File exists
[2017-09-13T18:49:38] debug: service log path: /var/log/synergy-service.log
[2017-09-13T18:49:38] info: starting service...
[2017-09-13T18:49:38] debug: connecting websocket
[2017-09-13T18:49:38] debug: tcp server bind error: Address already in use
[2017-09-13T18:49:38] debug: failed to start connectivity test server
[2017-09-13T18:49:38] debug: connectivity test server started
[rawsocket_server_impl.cpp:94][start] starting rawsocket server
terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::system::system_error> >'
  what():  bind: Address already in use
fish: “/usr/bin/synergyd” terminated by signal SIGABRT (Abort)

systemctl status synergy also says the process sysaborted

Share this post


Link to post
Share on other sites
1 minute ago, QuantumRiff said:
mkdir -p ~/.config/synergy/
ln -s ~/.config/Symless/Synergy/synergy.conf ~/.config/synergy/synergy.conf
/usr/bin/synergyd
#then open app in gnome


they are both  connected now.

Excellent! Thanks for sharing.

  • Like 1

Share this post


Link to post
Share on other sites
Just now, jaap aarts said:

terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::system::system_error> >'
  what():  bind: Address already in use

This happens when the synergys binaryu is running when you try to start the synergyd service. Try killing synergys first.

Share this post


Link to post
Share on other sites
10 minutes ago, Nick Bolton said:

This happens when the synergys binaryu is running when you try to start the synergyd service. Try killing synergys first.

the service still wont start, but the /usr/bin/synergyd does work now.

both screens grey with loading bar on both displays.

https://synergy-logs.symless.com/2017-09-13/85-2017-09-13T19-02-55.log

https://synergy-logs.symless.com/2017-09-13/85-2017-09-13T19-04-03.log

Share this post


Link to post
Share on other sites

On two Ubuntu 16.04 installs here, the following allowed my beta4 to work well (so far):

Quote
mkdir -p ~/.config/synergy/
ln -s ~/.config/Symless/Synergy/synergy.conf ~/.config/synergy/synergy.conf
/usr/bin/synergyd
#then open app in gnome

Thanks!

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.