CaraDeHil

Keyboard Language changing when switching between screens

8 posts in this topic

I have two laptops.  One has Windows 10 on it and has English (United States), Spanish (Colombia), and Japanese keyboards enabled.  The other (MacBook Air with OSX Sierra) has the English, Spanish, and Japanese keyboards also installed.  What happens is when I mouse from the Windows computer and back it changes the keyboard language on the Windows computer and cycles through them about ever 5th time passing over to the other screen.  I can keep changing the keyboard language on my screen whenever it happens, but it is definitely a bug that needs to be fixed for production. I think it is only affecting the keyboard language on the windows computer because I am using it as the host keyboard.  Let me know if you need any more information.

Share this post


Link to post
Share on other sites

UPDATE: It seems to only be happening when command prompt is open and has focus on the host computer.  When cmd has focus it cycles through without fail every time that you move from the Windows to the Mac.

Share this post


Link to post
Share on other sites

Does this work for you in Synergy 1?

Share this post


Link to post
Share on other sites

Actually I don't have Synergy 1 to be able to test it out, so I can't confirm or deny that.

Share this post


Link to post
Share on other sites
15 hours ago, CaraDeHil said:

Actually I don't have Synergy 1 to be able to test it out, so I can't confirm or deny that.

Now you do!

Share this post


Link to post
Share on other sites

Okay.  With Synergy 1 it isn't cycling through the languages.  What happens with S1 is that right after you change language from L1 to L2, when you move your mouse to the client it switches back to L1, then upon entering the server again it changes the language back to L2.  The language stays on L2 from then on even when on the client and when on the server.  I'll keep testing it out to see if there is any change in behavior. 

Edited by CaraDeHil

Share this post


Link to post
Share on other sites

So the behavior is different between Synergy 1 and Synergy 2?

Share this post


Link to post
Share on other sites

Hi!

I have the same problem. I'm using Synergy 1.8.8-stable and have two Windows machines, both running windows 10. Also, the keyboard language is only changing on the computer running the server.

I have disabled the option "Let me set a different input method for each app window" and removed the hotkeys for changing input languages in the windows language settings.

I can also confirm that the change of language only happens when the console window is in focus on the machine running the synergy server.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now