DiogoK

Linux Mint client cant connect to Windows server, works the other way around

4 posts in this topic

I've been having some troubles getting my Linux machine to connect to my Windows machine. I've contacted their support team via e-mail, but they haven't been able to help me, so I decided to try my luck on the forums and see if anyone has had a similar problem and has a workaround.

Here's some info I've sent to their support team:

- Machines are running Windows 10 and Linux Mint 18.

- Synergy works fine if I make the Linux machine the server and the Windows machine the client, but not the other way around, which is what I need.

- Firewalls in both machines are disabled.

- Both machines are in the same network (Windows is on a wired connection and Linux on wireless).

- I've tried both versions 1.8.8 and 1.9rc3.

Screenshots of the screens:

Windows server log: https://pastebin.com/cgM4UyL6

Linux client log: https://pastebin.com/8HxhUDV8

Share this post


Link to post
Share on other sites

Hey Nick,

I have already contacted your support team via that e-mail and, as mentioned in the post, you weren't able to help me. In fact I was offered a refund as well as being able to keep my account active, but I just opted to come to the forums and see if anyone had a workaround instead of giving up.

To be frank, I'm quite disappointed with your Support. Do you offer a refund as soon as disabling firewalls doesn't fix the problem? 

Share this post


Link to post
Share on other sites

I had a similar problem, but I found a solution that worked for my case, so I'll relay it to you. 

This solution also works with firewalls up on both computers, but I was using a Mac and a Win 10 PC, so I'm not sure if this applies to Win 10 and Linux. You may have noticed that the server side lists multiple IP's, and the bolded one is the one that the client typically tries connects to. This is the wrong IP. I solved the problem for myself by manually setting a Server IP for the client to connect to. The IP I used was the one assigned in the DHCP system within your router. I also assigned static IPs to both so I won't have to screw around with it in the future.

And to the support team at Synergy: maybe add "client is trying to connect to wrong IP" to the list of possible fixes for support problems.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now