jonkjon

Mouse (and keyboard) Randomly Disappearing

3 posts in this topic

I have Synergy configured as a server on a Windows 10 desktop machine which has two monitors. I also have two Linux machines with Synergy clients running on them. I use a KVM switch to change between displays and Synergy to handle the mouse and keyboard so that I can take advantage of the drag and drop features. I keep one monitor (the left most one) on the Windows desktop all the time. The KVM only switches the right most monitor.
Recently, I have been having issues where the mouse disappears from my Windows machine. The keyboard doesn't seem to function either except when pressing ctrl+alt+delete which brings the mouse and keyboard back to life. I have disabled Synergy and the problem does not occur. I have Synergy configured to use a manual configuration as follows:
 
section: screens
 vengeance:
 ubuntu:
 jon-mint:
 end
section: links
 jon-mint:
  right=vengeance
 ubuntu:
  left=vengeance
 vengeance:
  right=ubuntu
  left=jon-mint
end
section: options
 screenSaverSync =  false
 keystroke(f12) = lockCursorToScreen(toggle)
 mousebutton(6) = keystroke(WWWBack)
 mousebutton(7) = keystroke(WWWForward)
 mousebutton(4) = mousebutton(6)
 mousebutton(5) = mousebutton(7)
 switchCorners = bottom-left
 switchCornerSize = 500
 switchDelay = 1000
end
 
--Jon

Share this post


Link to post
Share on other sites

I changed the setting for "elevate" to always on the Win 10 server. So far, this problem has not recurred. 

Share this post


Link to post
Share on other sites

So the above "fix" did not work. I have narrowed the issue down to something on one of my Linux boxes running 1.8.8. If I log out and leave the Ubuntu machine on the login screen, the problem with the cursor disappearing on the Win 10 server stops. The Ubuntu screen is somehow grabbing the cursor and keyboard and it does not return to Windows. Not sure why the Ubuntu screen is randomly grabbing the focus but that is the problem.

Since the Ubuntu box is a 32 bit machine, I can't find a 32 bit version of 1.9 to try. Is there one?

 

--Jon

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now