James House

SSL Connectivity Problems on 1.7.3

7 posts in this topic

Just upgraded both of my machines to 1.7.3. Server is CentOS Linux release 7.1.1503 (Core) Installed with yum localinstall synergy-v1.7.3-stable-*-x86_64.rpm Client is OS X Yosemite 10.10.3 When running the setup wizard on the server, I get "Error: Could not get Linux package type." When starting the server, I get the following information: [code]NOTE: starting server NOTE: command: /usr/bin/synergys -f --no-tray --debug DEBUG --name JMH-CENTOS7.domain.local --enable-crypto --log /var/log/synergy.log -c /tmp/qt_temp.H12362 --address :24800 NOTE: config file: /tmp/qt_temp.j12362 NOTE: log level: DEBUG NOTE: log file: /var/log/synergy.log DEBUG: opening configuration "/tmp/qt_temp.H12362" DEBUG: configuration read successfully DEBUG: plugins dir: /home/jhouse/.synergy/plugins DEBUG: XOpenDisplay(":0") DEBUG: xscreensaver window: 0x00000000 DEBUG: screen shape: 0,0 3882x2160 (xinerama) DEBUG: window is 0x05600004 DEBUG: adopting new buffer DEBUG: opened display NOTE: crypto disabled because of ns plugin not available DEBUG: registered hotkey ScrollLock (id=ef14 mask=0000) as id=1 NOTE: started server, waiting for clients DEBUG: event queue is ready DEBUG: add pending events to buffer DEBUG: screen "JMH-CENTOS7.domain.local" shape changed NOTE: stopping synergy desktop process NOTE: starting server NOTE: command: /usr/bin/synergys -f --no-tray --debug DEBUG --name JMH-CENTOS7.domain.local --enable-crypto --log /var/log/synergy.log -c /tmp/qt_temp.d12362 --address :24800 NOTE: config file: /tmp/qt_temp.I12362 NOTE: log level: DEBUG NOTE: log file: /var/log/synergy.log DEBUG: opening configuration "/tmp/qt_temp.d12362" DEBUG: configuration read successfully DEBUG: plugins dir: /home/jhouse/.synergy/plugins DEBUG: XOpenDisplay(":0") DEBUG: xscreensaver window: 0x00000000 DEBUG: screen shape: 0,0 3882x2160 (xinerama) DEBUG: window is 0x05600004 DEBUG: adopting new buffer DEBUG: opened display NOTE: crypto disabled because of ns plugin not available DEBUG: registered hotkey ScrollLock (id=ef14 mask=0000) as id=1 NOTE: started server, waiting for clients DEBUG: event queue is ready DEBUG: add pending events to buffer DEBUG: screen "JMH-CENTOS7.domain.local" shape changed NOTE: accepted client connection NOTE: new client is unresponsive[/code] When starting the client, I get this: [code]NOTE: starting client NOTE: command: /Applications/Synergy.app/Contents/MacOS/synergyc -f --no-tray --debug DEBUG --name jmh-mbp.domain.local --enable-drag-drop --enable-crypto --log /var/log/synergy.log JMH-CENTOS7.domain.local:24800 NOTE: config file: /var/folders/c0/5qty2zx11zl052s8drh9xtcw0000gn/T/Synergy.K24843 NOTE: log level: DEBUG NOTE: log file: /var/log/synergy.log INFO: drag and drop enabled DEBUG: plugins dir: /Users/jhouse/Library/Synergy/Plugins DEBUG: loading plugin: libns.dylib DEBUG: loaded plugin: libns.dylib DEBUG: screen shape: center=0,0 size=1440x900 on 1 display DEBUG: starting watchSystemPowerThread DEBUG: adopting new buffer DEBUG: opened display NOTE: started client DEBUG: started watchSystemPowerThread DEBUG: waiting for event loop NOTE: connecting to 'JMH-CENTOS7.domain.local': 192.168.111.99:24800 DEBUG: waiting for carbon loop DEBUG: event queue is ready DEBUG: signalling carbon loop ready DEBUG: add pending events to buffer DEBUG: starting carbon loop DEBUG: carbon loop ready DEBUG: add pending events to buffer ERROR: ssl error occurred (generic failure) ERROR: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol ERROR: failed to connect secure socket 2015-05-28 10:23:37.425 synergyc[24927:2285715] starting cocoa loop NOTE: disconnected from server[/code]

Share this post


Link to post
Share on other sites
I am experiencing similar issues/errors. Client is OS X 10.9.5, Server is Fedora 22 (fresh upgrade today). All packages up to date on F22 server, update both client and server to 1.7.3 (was working fine on 1.7.2), and got the same "Error: Could not get Linux package type", followed by SSL errors that prevent Synergy from connecting. Client: INFO: connected to secure socket INFO: server ssl certificate info: /CN=Synergy ERROR: ssl error occurred (generic failure) ERROR: error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number NOTE: disconnected from server Server: ERROR: secure socket error: SSL_ERROR_SSL ERROR: error:1409442E:SSL routines:SSL3_READ_BYTES:tlsv1 alert protocol version NOTE: new client disconnected Disabling SSL on both client and server allows the connection to work.

Share this post


Link to post
Share on other sites
Same problem: Server OpenSUSE 13.2 (rpm) Client: Mac OS X Yosemite 10.10.3

Share this post


Link to post
Share on other sites
I am experiencing similar issues with an iMAC running OS X Yosemite as the server and a Win 7 (64b) as the client since I upgraded to 1.7.3. I get the following on the server which continues to repeat: ERROR: passive ssl error limit exceeded: 100001 ERROR: failed to accept secure socket INFO: client connection may not be secure NOTE: accepted client connection ERROR: ssl error occurred (system call failure) ERROR: eof violates s INFO: client connection may not be secure sl protocol ERROR: failed to accept secure socket On the client it just repeats: connecting to '192.168.1.50': 192.168.1.50:24800 disconnecting from server I first tried to install as a registered version on the PC, however, that failed so I was able to install without registering.

Share this post


Link to post
Share on other sites
I should add that when I disable "Use SSL encryption" Synergy works just fine.

Share this post


Link to post
Share on other sites
I'm having this problem as well. Server: [code] NOTE: accepted client connection ERROR: ssl error occurred (system call failure) ERROR: failed to accept secure socket NOTE: accepted client connection ERROR: ssl error occurred (system call failure) ERROR: eof violates ssl protocol ERROR: failed to accept secure socket [/code] Client: [code] NOTE: config file: /tmp/qt_temp.fl1994 NOTE: log level: INFO NOTE: started client NOTE: connecting to '<CENSORED>': <CENSORED>:24800 ERROR: passive ssl error limit exceeded: 100001 ERROR: failed to connect secure socket NOTE: disconnected from server NOTE: stopped client [/code]

Share this post


Link to post
Share on other sites
I have sort of the same issue. Whenever i start the "server" of my 2 machines (laptop i take home), m7y client has the following in it's logging: [quote]NOTE: started client NOTE: connecting to 'vincent1': <masked>:24801 NOTE: server fingerprint: <tickle> NOTE: connected to server ERROR: corrupted clipboard data, expected size=56 actual size=0 ERROR: ssl error occurred (system call failure) ERROR: eof violates ssl protocol NOTE: disconnected from server NOTE: stopped client NOTE: stopping synergy desktop process [/quote] If i stop and start the synergy server the same happens, so it's not something boot+connection related, but startup of server related.

Share this post


Link to post
Share on other sites
To add to my earlier problem i also experience regular client crashes (both noticed by KDE as well as internal just stopping the connection). Whatever the cause it is not going as smooth as i have experienced in the last few years. Waiting on next version while running 1.7.1 so i don't need to keep mouse and keyboard of the client around

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now