David D.

Mouse Recentered on Exiting Computer

12 posts in this topic

When moving from Computer A to Computer B, the mouse is displayed back in the center of the screen with the Task Bar of Computer A.  In Synergy 1.X, it disappeared or stayed where it exited.  This leads to very confusing interaction if I need to locate the mouse.

Edited by David D.

Share this post


Link to post
Share on other sites

I have seen this too when exiting from a Windows 10 computer. Only with some apps though; happens for me if File Explorer or the Synergy client are the active window at the time.

Share this post


Link to post
Share on other sites

I'm on Windows 7 and it happens regardless of what screen has focus.

Share this post


Link to post
Share on other sites

Yeah, this is quite an annoying bug. We'll be working on a solution in beta5, please hang on for a fix.

Share this post


Link to post
Share on other sites

Where can I download Beta 5?  I have RC1 installed and I still have this issue.  Running Windows 10 Home 64 on two computers.    When going from one computer to the other the mouse jumps to the center of the screen and stays there.  Does this to each machine.

This was happening on Synergy 1.  The only reason I went to Synergy 2 was an indication this was fixed... guess it hasn't been yet.

Share this post


Link to post
Share on other sites

No this is not fixed in beta5 or RC1 (RC1 is the latest). Last I heard was that this wouldn't be fixed until 2.0.1; i.e. after commercial release.

Share this post


Link to post
Share on other sites
54 minutes ago, Smitty said:

When going from one computer to the other the mouse jumps to the center of the screen and stays there. 

We plan to fix this issue soon.

Share this post


Link to post
Share on other sites

I experience this issue and something that might be related -- on macOS, when I'm moving the mouse around on another machine (Ubuntu 16.04 in this case), I'll often see hover effects in Safari on the host. So, wiggling the mouse on a different machine seems to cause the inactive macOS machine to report some mouse-over activity; especially in Safari, where links will look highlighted; but it's only around the center of the screen. Clicks don't improperly register, it only seems to be hover-related..

Share this post


Link to post
Share on other sites
11 hours ago, jtls said:

wiggling the mouse on a different machine seems to cause the inactive macOS machine to report some mouse-over activity

Did this happen in Synergy 1?

Share this post


Link to post
Share on other sites
48 minutes ago, Nick Bolton said:

Did this happen in Synergy 1?

Yep

Share this post


Link to post
Share on other sites
20 minutes ago, jtls said:

Yep

Thanks. I think we'll be addressing this in 2.2, which is due mid/late next year.

Share this post


Link to post
Share on other sites

This is still happening with 2.0.9 stable on Mac OS Sierra as the server and Mac OS High Sierra as the client.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now