Sign in to follow this  
Ron Hixson

Ver 1.73 SSL issues - PC to Mac

6 posts in this topic

I'm running a Win 7 server & a Mac 10.10.4 beta client. After updating to V 1.73, I could not connect to the client without disabling SSL encryption on the server. I have a hard wired ethernet connection between the comps, so I'm not concerned about WiFi transmissions, but I would like to re-establish the SSL connection. On the Mac side, there doesn't appear to be a way to set a password or certificate. I have done a clean re-install on the server and client. Any help is appreciated.

Share this post


Link to post
Share on other sites
I had the same issue with Linux Mint Cinnamon server and Win 7 enterprise client. I followed the tip by EDToft here: https://github.com/synergy/synergy/issues/4618, and that worked for me. Turned off the SSL on both client and server, then turned it back on, accepted a "do you trust the..." message, and voila.. reconnect worked.

Share this post


Link to post
Share on other sites
I am using a Mac with OS 10.6.8 and Win 7. Same thing happened here. SSL was active... I turned it off in the settings... Viola!! Thanks for the advice!!

Share this post


Link to post
Share on other sites
Where do you turn off SSL? I am trying to share a keyboard between Ubuntu 14.04, MacOSX Yosemite and Win8. Thanks

Share this post


Link to post
Share on other sites
Scratch last question. I found it under Edit > Settings on Ubuntu, under Synergy > Preferences on the Mac and Edit > Settings on Win 8 (just in case anyone else doesn't know where to look)

Share this post


Link to post
Share on other sites
Another thought on this. After upgraded Synergy you always need to Re-run the Registration Wizard in File -> Run Wizard. This re-downloads the files used for SSL. These files are [b]not[/b] installed with the installer exe or dmg. Running the Wizard after upgrade solves a lot of annoying errors. :D

Share this post


Link to post
Share on other sites
I've spent several hours scouring these forums to find a simply step by step guide without success. I have an iMac that I want to use as a client, and a Windows 8.1 I'd like to setup as the server. Can anyone point me to directions? All I see in the forums are particular questions about particular situations, no actual guide or instructions.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this