JasonSep

Client does not receive keystrokes

4 posts in this topic

Hi,

I'm using OSX 10.12.1 as the Server and CentOS 7.3.1611 Gnome Desktop as a client.

Both versions are the same - 1.8.8-stable-25a8cb2

At times, my client does not receive keystrokes however the mouse pointer is working fine. The keystrokes show up on the server.

I use iterm2 on OSX and Terminator on Centos.

It seems intermittent, however, now it seems permanent and restarting the server or the client doesn't help.

Thanks

Jason

 

(you can see the "ffff" in the tailf output of the logs showing the keystrokes remaining on the server)

[2017-08-03T14:53:42] INFO: switch from "macbook.local" to "desk2" at 0,583
[2017-08-03T14:53:42] INFO: leaving screen
[2017-08-03T14:53:42] DEBUG: hiding cursor
[2017-08-03T14:53:42] WARNING: cursor may not be visible
[2017-08-03T14:53:42] DEBUG: opening clipboard
[2017-08-03T14:53:42] DEBUG: closing clipboard
[2017-08-03T14:53:42] INFO: screen "macbook.local" updated clipboard 0
[2017-08-03T14:53:42] DEBUG: opening clipboard
[2017-08-03T14:53:42] DEBUG: closing clipboard
[2017-08-03T14:53:42] INFO: screen "macbook.local" updated clipboard 1
[2017-08-03T14:53:42] DEBUG: sending clipboard 0 to "desk2"
[2017-08-03T14:53:42] DEBUG: sent clipboard size=27
[2017-08-03T14:53:42] DEBUG: sending clipboard 1 to "desk2"
[2017-08-03T14:53:42] DEBUG: sent clipboard size=27
ffff[2017-08-03T14:53:50] INFO: switch from "desk2" to "macbook.local" at 1853,554

Edited by JasonSep

Share this post


Link to post
Share on other sites

at the time when keystrokes aren't sent, I can right click and paste the server's clipboard contents to the client ok 

Share this post


Link to post
Share on other sites

debug1: (note the highlight keys staying on the server in the tailf output below)

[2017-08-03T15:00:13] DEBUG1: event: Key event kind: 12, keycode=54
[2017-08-03T15:00:13] DEBUG1: mask=0100 outMask=0000
[2017-08-03T15:00:13] DEBUG1: new mask: 0x0000
[2017-08-03T15:00:13] DEBUG1: onKeyUp id=61419 mask=0x0000 button=0x0038
[2017-08-03T15:00:14] DEBUG1: try to leave "macbook.local" on right
[2017-08-03T15:00:14] DEBUG1: mask=0000 outMask=0000
[2017-08-03T15:00:14] INFO: switch from "macbook.local" to "desk2" at 0,933
[2017-08-03T15:00:14] INFO: leaving screen
[2017-08-03T15:00:14] DEBUG: hiding cursor
[2017-08-03T15:00:14] WARNING: cursor may not be visible
[2017-08-03T15:00:14] DEBUG1: mask=0000 outMask=0000
[2017-08-03T15:00:14] DEBUG1: modifiers on update: 0x0000
[2017-08-03T15:00:14] DEBUG: opening clipboard
[2017-08-03T15:00:14] DEBUG: closing clipboard
[2017-08-03T15:00:14] INFO: screen "macbook.local" updated clipboard 0
[2017-08-03T15:00:14] DEBUG: opening clipboard
[2017-08-03T15:00:14] DEBUG: closing clipboard
[2017-08-03T15:00:14] INFO: screen "macbook.local" updated clipboard 1
[2017-08-03T15:00:14] DEBUG1: mask=0000 outMask=0000
[2017-08-03T15:00:14] DEBUG1: send enter to "desk2", 0,933 3 0000
[2017-08-03T15:00:14] DEBUG: sending clipboard 0 to "desk2"
[2017-08-03T15:00:14] DEBUG: sent clipboard size=2446
[2017-08-03T15:00:14] DEBUG: sending clipboard 1 to "desk2"
[2017-08-03T15:00:14] DEBUG: sent clipboard size=2446
[2017-08-03T15:00:14] DEBUG1: sending clipboard chunk
[2017-08-03T15:00:14] DEBUG1: sending clipboard chunk
[2017-08-03T15:00:14] DEBUG1: sending clipboard chunk
[2017-08-03T15:00:14] DEBUG1: sending clipboard chunk
[2017-08-03T15:00:14] DEBUG1: sending clipboard chunk
[2017-08-03T15:00:14] DEBUG1: sending clipboard chunk
23234234234234[2017-08-03T15:00:16] DEBUG1: event: button press button=1
[2017-08-03T15:00:16] DEBUG1: onMouseDown id=1
[2017-08-03T15:00:16] DEBUG1: send mouse down to "desk2" id=1
[2017-08-03T15:00:16] DEBUG1: event: button release button=1
[2017-08-03T15:00:16] DEBUG1: onMouseUp id=1
[2017-08-03T15:00:16] DEBUG1: send mouse up to "desk2" id=1
234234[2017-08-03T15:00:17] DEBUG1: event: button press button=1
[2017-08-03T15:00:17] DEBUG1: onMouseDown id=1
[2017-08-03T15:00:17] DEBUG1: send mouse down to "desk2" id=1
[2017-08-03T15:00:18] DEBUG1: event: button release button=1
[2017-08-03T15:00:18] DEBUG1: onMouseUp id=1
[2017-08-03T15:00:18] DEBUG1: send mouse up to "desk2" id=1
[2017-08-03T15:00:19] DEBUG1: try to leave "desk2" on left

Share this post


Link to post
Share on other sites

Hi @JasonSep. Can you close all of the programs running on each of your machines and reboot them? When it boots back, run Synergy(only) on both. When both machines are connected through Synergy, check if client responds to all mouse clicks and keyboard presses. Once verified, Try running the usual programs you use on your server machine one by one. After opening each program, try if client still responds to keyboard and mouse actions coming from the server.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now