BrianD

Stale DNS confuses Synergy connection

3 posts in this topic

Currently using Beta 3.

First of all -- requiring the initial launch of Synergy 2 to pop out to a web browser page for authentication is confusing. And the first couple of times I tried it -- I didn't get the authorization page from the server (on both a Windows 7 client and a MacOS X Sierra 10.12.6 client). When I finally did -- I I still had to relaunch the Synergy apps on both machines multiple times to get past the "Sign in to Symless" screen.

Next problem was the each of the two clients recognized that the other was on the network but failed to connect to each other. Getting to the logs to see details by pressing '~' was utterly not obvious. There should be UI for debugging front and center. When I saw the logs, the problem was obvious -- my corporate network frequently has stale DNS records for clients with DHCP assigned IPs (don't ask). I had to release and renew DHCP IPs multiple times before DNS finally got updated and Synergy was happy. It would be helpful if Synergy didn't rely on reverse DNS to successfully connect. The two clients clearly saw each other on the network (because they displayed each other on their app config screens) -- but refused to connect until the reverse DNS worked.

My other complaints others seem to have filed already: can't close the app without losing connection, so have to minimize and no drag and drop yet.

Edited by BrianD

Share this post


Link to post
Share on other sites

And no keyboard mapping either yet.

Ok guys -- this is *alpha* software, not beta. Beta software is supposed to be feature complete but there may be bugs. I have to go back to 1.8.8.

  • Like 1

Share this post


Link to post
Share on other sites

Hey, Synergy 2 doesn't use DNS to connect your machines. It was probably an issue with our recent cloud config scalability issues.

Quote

can't close the app without losing connection, so have to minimize and no drag and drop yet.

This will be in beta4, which will be out in 3 weeks. It was due in beta3 but it wasn't ready for testing yet.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now