teddygleeson

"starting cocoa loop" server hung

20 posts in this topic

Server is hung on 

2017-08-02 15:02:56.812 synergys[1087:13327] starting cocoa loop

Client computer not connecting. "Time out".

This was working and suddenly stopped. Had a good run of a few months with it now its not.

I am using a mac (Server) El cap 10.11.06, my only client is a windows 10 computer. 

both are running 1.8.8 and I have restarted the computer a few times. 

 

Any ideas greatly appreciated. 

 

Share this post


Link to post
Share on other sites

Hi @teddygleeson. Please provide more details about your machines (OS, 32/64 bit, Synergy version installed, connected to the network via Ethernet or Wi-Fi, specify which one is the server). Also, post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine.

Share this post


Link to post
Share on other sites

I am using a mac (Server) El cap 10.11.06, my only client is a windows 10 computer both are running 1.8.8 and I have restarted the computer a few times. 

This was running smoothly up to a couple of days ago. 

Connected over WiFi. 

 

 

 

 

Client.png

Server Mac.png

Server Config.png

Share this post


Link to post
Share on other sites

If you can't fix this I am getting a refund . 

Please write back entire workflow grinded to a halt.

Let me know something anything ASAP.  

 

Share this post


Link to post
Share on other sites

I'm having the same issue, and by the looks of the recent threads this is a bug. I'm on Mac OS X Sierra (server), and client is a Windows 7 64 bit OS (Client). I'm getting the dreaded "failed to connect to the server" on the client, and on the server it's stuck in the cocoa loop. I've uninstalled/reinstalled on both machines, and have restarted.

Someone forgot to unit test their code before checking it in, or their QA team missed a major issue somehow. 

Share this post


Link to post
Share on other sites

Also, I'm using Synergy over Wifi if that helps. It seems the issue lies with the Mac version of the software, it does not work as server and only works as client in manual mode. This thread should be plenty to get the issue diagnosed. 

Edited by jmwarren

Share this post


Link to post
Share on other sites

I am using a similar set up. Mac 10.11.6(Server) To windows 10 (Client). I am also over Wifi and have reinstalled restarted as well.

I think it's a bug with one of the updates. My reason being that this worked seamlessly for me for a couple of months. Then all of a sudden This Cocao Loop Thing. It must be an update. 

I wonder is it possible to download an older version? I am off to try and find an older version. 

Share this post


Link to post
Share on other sites

Please try v1.9.0rc3 from the tagged thread below.

Let me know how it goes.

 

Share this post


Link to post
Share on other sites

I am having the same issue on 1.9.rc3  Just bought it and this is a really rough start.  Will ask for a refund if not fixed soon.

Share this post


Link to post
Share on other sites
On 8/8/2017 at 2:50 PM, Paul Suarez said:

Please try v1.9.0rc3 from the tagged thread below.

Let me know how it goes.

 

Thanks Paul, this release candidate has solved the issue. I still see in the log Warning: Quartz event etc.... and Cocoa server etc...., but it's working now. 

Share this post


Link to post
Share on other sites

No Joy tried 1.9-rc3 , still can't connect, See post above everything is the same. Server Hangs on "starting cocoa loop" and client says it cannot connect. 

:(

Any other suggestions. 

Share this post


Link to post
Share on other sites

Hey guys OP here, updated my Mac OSX and it appears to have fixed everything. 

Thanks to everyone that helped. 

All is well now will continue to use this great product. 

 

Thanks a million. 

Share this post


Link to post
Share on other sites

I have pretty much the samme issue.

I am connecting from Windows 10 as a host, to MacOS Sierra as client.

 

Windows side looks good, reported "Watchdog Status: ok" And synergy is running.

on the mac side it says "Starting Cocoa loop", and "Synergy is starting"

When i switch to Auto Config, it then proceeds to spell out "Cannot connect socket: Host is down.

And that message just loops.

 

My windows machine is showing 4 different IP addresses. And i tried them all. As well as disable and enable SSL encryption on both.

I also tried to run with the 1.9 release candidate. Didn't work.

I even uninstalled any antivirus i had on both machines. And double checked firewall permissions. Nothing changed.

Both my systems are up to date.

 

From what i can see it is the Mac Version that isn't working. I still says that "Synergy is starting" and never gets it done. Even while trying to connect.

Sometimes when i stop, it says "Process exited with Error code: 9

 

What is weird is that Synergy did connect, and worked the first time i tried it (This was 1.8.8). But immediately after it gave up service. and refuses to work now.

 

Any ideas? If more info or anything is needed. I am willing to help out.

Edited by Ignis

Share this post


Link to post
Share on other sites

While the release candidate fixed the ability to use both Mac and windows, I've noticed the ability to drag files between the two doesn't work at all.

Hopefully, these bugs get worked out on the next stable release.

Share this post


Link to post
Share on other sites

I was having the same issue a few days ago so I stopped using Synergy and went back to VNC/RDP (sucks); today after reading this post - came here to report the issue - everything is working again!?? Weird!

My system stack is as follows: Synergy 1.9rc3 / Server: macOS Sierra 10.12.6 fully updated / Client 1: macOS Sierra 10.12.6 fully updated / Client 2: Windows 10 Pro fully updated

Share this post


Link to post
Share on other sites
On 9/7/2017 at 7:26 PM, jmwarren said:

I'm giving up on this for the time being, is there a way to be notified of the next release?

Keep an eye on your email.

On 9/5/2017 at 3:38 PM, jmwarren said:

Thanks Nick,

Any idea when the next stable release will be?

Not until November, but you could try the beta: https://symless.com/synergy/early-access

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now