dmpal

Not starting after install on Win 7 Pro

10 posts in this topic

Installed Synergy 2 Beta 3 on desktop running Win 7 Pro 64bit. When I tried to start it the following message came up: "The procedure entry point ucrtbase.terminate could not be located in the dynamic library api-ms-win-crt-runtime-l1-1-0.dll". Installed fine on Win 10 laptop.

Share this post


Link to post
Share on other sites

Hi @dmpal. Can you share a screenshot or error logs for that?

Share this post


Link to post
Share on other sites

Please try rebooting your computer and redownloading the installer. It could be corrupt, or there may be something running on your computer that's causing the error.

Share this post


Link to post
Share on other sites

I have been running v1.8.8 on the computer and had no problems. I uninstalled v1.8.8 and then rebooted the computer. I downloaded v2.0.0-beta3 and installed it. Came up with the same errors as above. I rebooted the computer and the same happened.

Share this post


Link to post
Share on other sites

Ah, I wonder if your runtimes are out of date. Could you please go to add/remove programs and uninstall everything that starts with "Microsoft Visual C++", then reinstall Synergy.

@Jerry Hou The Synergy 2 installer installs the correct runtime, right?

Share this post


Link to post
Share on other sites

We use the same version of runtime as v1.8.8 which is probably too old for v2. I will double check it.

Share this post


Link to post
Share on other sites

This is likely because you don't have all the Windows 7 updates installed, in particular this one: https://support.microsoft.com/en-us/help/2999226/update-for-universal-c-runtime-in-windows

Microsoft discourage application developers from shipping these DLLs with their application, since they're now a part of Windows itself, instead they recommend that people using Windows 8.1 and below simply make sure they have the latest service pack and updates installed.

Share this post


Link to post
Share on other sites

Thanks @Andrew Nelless. I found some missing updates which fixed the problem. Haven't found why they were missing. Software now running but the cloud being down means that I can't try it.

Share this post


Link to post
Share on other sites
7 minutes ago, dmpal said:

Software now running but the cloud being down means that I can't try it.

Really sorry about that. I'm pretty close to picking up the phone and attempting to wake @Andrew Nelless and @Dan Sorahan, but that'll impact tomorrow's development... so it's probably unwise.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now