Patrik Olsson

Keyboard is not shared to clients

21 posts in this topic

Suddenly with no changes down on computers or Synergy app, keyboard is not shared to clients. Mouse and screens are shared. Have tried to restart Synergy on all computers. Have upgraded Synergy from 1.8.7 to 1.8.8 on all computers. Have rebooted all computers. Still doesnt work.

Worked on Friday the 28th of July. Left computers on. Came back to office Sunday 30th of July and it just doesnt work. Even after doing the things mentioned above.
Running MAC OSX 10.10.x on all computers.

Please help, this seriously affects my productivity.

Thanks
Patrik

Edited by Patrik Olsson

Share this post


Link to post
Share on other sites

Please provide more details about your machines (OS, 32/64 bit, Synergy version installed, connected to the network via Ethernet or Wi-Fi, specify which one is the server). Also, post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine.

Share this post


Link to post
Share on other sites

Flat ethernet network, all machines cabled to a switch connected on same VLAN  (Switch is a deep buffer Arista 7048T). All boxes have their WLAN disabled.

Client machine df-s MacBook Pro, MAC OSX 10.10.5 (Screen shot 1 and 2 below)

Client machine Patriks-Mac-mini, MAC OSX 10.10.5 (Screen shot 3 and 4 below)

Server Patriks-MacBook-Air, MAX OSX 10.10.5 (Screen shot 5 and 6 below)

All boxes running in 64 bit mode. Alla running Synergy 1.8.8 (as stated in original post).

 

 

Screen Shot 2017-07-31 at 19.11.31.png

Screen Shot 2017-07-31 at 19.14.52.png

Screen Shot 2017-07-31 at 19.15.48.png

Screen Shot 2017-07-31 at 19.15.58.png

Screen Shot 2017-07-31 at 19.18.31.png

Screen Shot 2017-07-31 at 19.18.04.png

Screen Shot 2017-07-31 at 19.29.32.png

Share this post


Link to post
Share on other sites

To be clear, the other IPs you see on clients and server are not WiFI or Ethernet, it is VMWare VMNetworks.

Share this post


Link to post
Share on other sites

Can you try v1.9.0rc3 from the tagged thread below?

 

Share this post


Link to post
Share on other sites

Thanks. I will download and try this. Will be back with results.

Share this post


Link to post
Share on other sites

Didnt fix the problem.

Now nothign works.

 

Server has this rolling big time in the log (and believe me, I have allowed access for the app in System preferences, otherwise the Synergy.app dont open at all):

[2017-08-01T18:02:29] INFO: starting server

[2017-08-01T18:02:29] INFO: config file: /var/folders/2h/wzc0bcxs30lglfxpcw4q7mr40000gn/T/Synergy.V10779

[2017-08-01T18:02:29] INFO: log level: INFO

[2017-08-01T18:02:29] INFO: drag and drop enabled

[2017-08-01T18:02:29] FATAL: An error occurred: assistive devices does no

t trust this process, allow it in system settings.

[2017-08-01T18:02:29] ERROR: process exited with error code: 1

[2017-08-01T18:02:29] INFO: detected process not running, auto restarting

[2017-08-01T18:02:30] INFO: starting server

[2017-08-01T18:02:30] INFO: config file: /var/folders/2h/wzc0bcxs30lglfxpcw4q7mr40000gn/T/Synergy.G10779

[2017-08-01T18:02:30] INFO: log level: INFO

[2017-08-01T18:02:30] INFO: drag and drop enabled

[2017-08-01T18:02:31] FATAL: An error occurred: assistive devices does not trust this

process, allow it in system settings.

[2017-08-01T18:02:31] ERROR: process exited with error code: 1

[2017-08-01T18:02:31] INFO: detected process not running, auto restarting

[2017-08-01T18:02:32] INFO: starting server

[2017-08-01T18:02:32] INFO: config file: /var/folders/2h/wzc0bcxs30lglfxpcw4q7mr40000gn/T/Synergy.ba0779

[2017-08-01T18:02:32] INFO: log level: INFO

[2017-08-01T18:02:32] INFO: drag and drop enabled

[2017-08-01T18:02:32] FATAL: An error occurred: assistive devices doe

s not trust this process, allow it in system settings.

[2017-08-01T18:02:32] ERROR: process exited with error code: 1

[2017-08-01T18:02:32] INFO: detected process not running, auto restarting

[2017-08-01T18:02:33] INFO: starting server

[2017-08-01T18:02:33] INFO: config file: /var/folders/2h/wzc0bcxs30lglfxpcw4q7mr40000gn/T/Synergy.da0779

[2017-08-01T18:02:33] INFO: log level: INFO

[2017-08-01T18:02:33] INFO: drag and drop enabled

[2017-08-01T18:02:33] FATAL: An error occurred: assistive devices does not trust this process, allow

it in system settings.

[2017-08-01T18:02:33] ERROR: process exited with error code: 1

[2017-08-01T18:02:33] INFO: detected process not running, auto restarting

[2017-08-01T18:02:34] INFO: starting server

[2017-08-01T18:02:34] INFO: config file: /var/folders/2h/wzc0bcxs30lglfxpcw4q7mr40000gn/T/Synergy.fa0779

[2017-08-01T18:02:34] INFO: log level: INFO

[2017-08-01T18:02:34] INFO: drag and drop enabled

[2017-08-01T18:02:34] FATAL: An error occurred: assisti

ve devices does not trust this process, allow it in system settings.

[2017-08-01T18:02:34] ERROR: process exited with error code: 1

[2017-08-01T18:02:34] INFO: detected process not running, auto restarting

[2017-08-01T18:02:35] INFO: starting server

[2017-08-01T18:02:35] INFO: config file: /var/folders/2h/wzc0bcxs30lglfxpcw4q7mr40000gn/T/Synergy.ha0779

[2017-08-01T18:02:35] INFO: log level: INFO

[2017-08-01T18:02:35] INFO: drag and drop enabled

[2017-08-01T18:02:35] FATAL: An error occurred: assistive

devices does not trust this process, allow it in system settings.

[2017-08-01T18:02:35] ERROR: process exited with error code: 1

[2017-08-01T18:02:35] INFO: detected process not running, auto restarting

[2017-08-01T18:02:36] INFO: starting server

[2017-08-01T18:02:36] INFO: config file: /var/folders/2h/wzc0bcxs30lglfxpcw4q7mr40000gn/T/Synergy.ja0779

[2017-08-01T18:02:36] INFO: log level: INFO

[2017-08-01T18:02:36] INFO: drag and drop enabled

[2017-08-01T18:02:36] FATAL: An error occurred: assistive devic

es does not trust this process, allow it in system settings.

[2017-08-01T18:02:36] ERROR: process exited with error code: 1

[2017-08-01T18:02:36] INFO: detected process not running, auto restarting

[2017-08-01T18:02:37] INFO: starting server

[2017-08-01T18:02:37] INFO: config file: /var/folders/2h/wzc0bcxs30lglfxpcw4q7mr40000gn/T/Synergy.la0779

[2017-08-01T18:02:37] INFO: log level: INFO

[2017-08-01T18:02:37] INFO: drag and drop enabled

[2017-08-01T18:02:37] FATAL: An error occurred: assistive devices

does not trust this process, allow it in system settings.

[2017-08-01T18:02:37] ERROR: process exited with error code: 1

[2017-08-01T18:02:37] INFO: detected process not running, auto restarting

[2017-08-01T18:02:38] INFO: starting server

[2017-08-01T18:02:38] INFO: config file: /var/folders/2h/wzc0bcxs30lglfxpcw4q7mr40000gn/T/Synergy.na0779

[2017-08-01T18:02:38] INFO: log level: INFO

[2017-08-01T18:02:39] INFO: drag and drop enabled

[2017-08-01T18:02:39] FATAL: An error oc

curred: assistive devices does not trust this process, allow it in system settings.

[2017-08-01T18:02:39] ERROR: process exited with error code: 1

[2017-08-01T18:02:39] INFO: detected process not running, auto restarting

[2017-08-01T18:02:40] INFO: starting server

[2017-08-01T18:02:40] INFO: config file: /var/folders/2h/wzc0bcxs30lglfxpcw4q7mr40000gn/T/Synergy.pa0779

[2017-08-01T18:02:40] INFO: log level: INFO

[2017-08-01T18:02:40] INFO: drag and drop enabled

[2017-08-01T18:02:40] FATAL: An error occur

red: assistive devices does not trust this process, allow it in system settings.

[2017-08-01T18:02:40] ERROR: process exited with error code: 1

[2017-08-01T18:02:40] INFO: detected process not running, auto restarting

[2017-08-01T18:02:41] INFO: starting server

[2017-08-01T18:02:41] INFO: config file: /var/folders/2h/wzc0bcxs30lglfxpcw4q7mr40000gn/T/Synergy.ra0779

[2017-08-01T18:02:41] INFO: log level: INFO

[2017-08-01T18:02:41] INFO: drag and drop enabled

[2017-08-01T18:02:41] FATAL: An error occurred: assistive devices does not trust this process, allow it in system settings.

[2017-08-01T18:02:41] ERROR: process exited with error code: 1

[2017-08-01T18:02:41] INFO: detected process not running, auto restarting

[2017-08-01T18:02:42] INFO: starting server

[2017-08-01T18:02:42] INFO: config file: /var/folders/2h/wzc0bcxs30lglfxpcw4q7mr40000gn/T/Synergy.ta0779

[2017-08-01T18:02:42] INFO: log level: INFO

[2017-08-01T18:02:42] INFO: drag and drop enabled

[2017-08-01T18:02:42] FATAL: An error occurred: assistive devices does not trust this proces

s, allow it in system settings.

[2017-08-01T18:02:42] ERROR: process exited with error code: 1

[2017-08-01T18:02:42] INFO: detected process not running, auto restarting

[2017-08-01T18:02:43] INFO: starting server

[2017-08-01T18:02:43] INFO: config file: /var/folders/2h/wzc0bcxs30lglfxpcw4q7mr40000gn/T/Synergy.va0779

[2017-08-01T18:02:43] INFO: log level: INFO

[2017-08-01T18:02:43] INFO: drag and drop enabled

[2017-08-01T18:02:43] FATAL: An error occurred: assistive devic

es does not trust this process, allow it in system settings.

[2017-08-01T18:02:43] ERROR: process exited with error code: 1

[2017-08-01T18:02:43] INFO: detected process not running, auto restarting

[2017-08-01T18:02:44] INFO: starting server

[2017-08-01T18:02:44] INFO: config file: /var/folders/2h/wzc0bcxs30lglfxpcw4q7mr40000gn/T/Synergy.xa0779

[2017-08-01T18:02:44] INFO: log level: INFO

[2017-08-01T18:02:44] INFO: drag and drop enabled

[2017-08-01T18:02:44] FATAL: An error occurred: assistive devices does not trust this process, allow it in system settings.

[2017-08-01T18:02:44] ERROR: process exited with error code: 1

[2017-08-01T18:02:44] INFO: detected process not running, auto restarting

[2017-08-01T18:02:45] INFO: starting server

[2017-08-01T18:02:45] INFO: config file: /var/folders/2h/wzc0bcxs30lglfxpcw4q7mr40000gn/T/Synergy.za0779

[2017-08-01T18:02:45] INFO: log level: INFO

[2017-08-01T18:02:45] INFO: drag and drop enabled

[2017-08-01T18:02:45] FATAL: An error occurred: assistive devices does not trust this process, allow it in system settings.

[2017-08-01T18:02:46] ERROR: process exited with error code: 1

[2017-08-01T18:02:46] INFO: detected process not running, auto restarting

[2017-08-01T18:02:47] INFO: starting server

[2017-08-01T18:02:47] INFO: config file: /var/folders/2h/wzc0bcxs30lglfxpcw4q7mr40000gn/T/Synergy.bb0779

[2017-08-01T18:02:47] INFO: log level: INFO

[2017-08-01T18:02:47] INFO: drag and drop enabled

[2017-08-01T18:02:47] FATAL: An error occurred: assistive devices does not trust this proces

s, allow it in system settings.

[2017-08-01T18:02:47] ERROR: process exited with error code: 1

[2017-08-01T18:02:47] INFO: detected process not running, auto restarting

[2017-08-01T18:02:48] INFO: starting server

[2017-08-01T18:02:48] INFO: config file: /var/folders/2h/wzc0bcxs30lglfxpcw4q7mr40000gn/T/Synergy.db0779

[2017-08-01T18:02:48] INFO: log level: INFO

[2017-08-01T18:02:48] INFO: drag and drop enabled

[2017-08-01T18:02:48] FATAL: An error occurred: assistive devices does not trust this

process, allow it in system settings.

[2017-08-01T18:02:48] ERROR: process exited with error code: 1

[2017-08-01T18:02:48] INFO: detected process not running, auto restarting

 

 

HELP!

Share this post


Link to post
Share on other sites

To be clear, getting the log above even if I have done according to screenshot below.

 

Screen Shot 2017-08-01 at 22.48.23.png

Share this post


Link to post
Share on other sites

More info:

Patriks-MacBook-Air:arista df$ /Applications/Synergy.app/Contents/MacOS/synergys -c ~df/synergy.confg -d DEBUG2 --log mylog.txt --daemon

[2017-08-02T09:38:35] DEBUG1: logging to file (mylog.txt) enabled

[2017-08-02T09:38:35] DEBUG: opening configuration "/Users/df/synergy.confg"

[2017-08-02T09:38:35] DEBUG: configuration read successfully

Patriks-MacBook-Air:arista df$ cat mylog.txt 

[2017-08-02T09:38:35] DEBUG1: logging to file (mylog.txt) enabled

[2017-08-02T09:38:35] DEBUG: opening configuration "/Users/df/synergy.confg"

[2017-08-02T09:38:35] DEBUG: configuration read successfully

[2017-08-02T09:38:35] DEBUG1: logging to file (mylog.txt) enabled

[2017-08-02T09:38:35] DEBUG: opening configuration "/Users/df/synergy.confg"

[2017-08-02T09:38:35] DEBUG: configuration read successfully

[2017-08-02T09:38:35] FATAL: An error occurred: assistive devices does not trust this process, allow it in system settings.

 

Patriks-MacBook-Air:arista df$ 

 

Share this post


Link to post
Share on other sites

another fun fact, that even if I keep the config in screen shot 1, if I quit the synergy app and restart it, it doesnt seem to know that it has been approved and give the error according to screen shot 2.

Any feedback of progress or lack there of would be appreciated!

Screen Shot 2017-08-01 at 22.48.23.png

Screen Shot 2017-08-02 at 12.46.55.png

Share this post


Link to post
Share on other sites

Trie to downgrade to 1.8.8 again. issue remains. Went down to 1.8.7 where I nvr saw the issue. Problem remains. 

Help.

 

Share this post


Link to post
Share on other sites

Been two days since last feedback from you guys (Symless). Pls port any feedback or even post lack of feedback.

 

 

Share this post


Link to post
Share on other sites

Hi @Patrik Olsson! This is most likely to be a compatibility issue with that KeePassX. Please refer to Server breaks KeePass auto-type feature #4400 in our GitHub issue tracker.

Share this post


Link to post
Share on other sites

Ok. I didnt even know I had KeepassX until I saw it in the list... will read #4400 and report!

 

Share this post


Link to post
Share on other sites

Uninstalled KeePassX (not using it), made sure via "ps auxw" as root in a shell in my macbook air (synergy server) that no processes remains from KeePassX.

Checked my Synergy clients, they didnt have KeePassX.

Restarted Synergy on all computers.

No success. Keyboard is still not shared.

I want to remind you that it "suddenly" stopped working. It has worked weill. And KeepasX was installed over two years ago.

Anyhow, still doesnt work with keepassx uninstalled.

 

Can I force a dump on my server and clients for your developers? Or anything else that will give you debug data to work with?

Share this post


Link to post
Share on other sites

Same issue  , was working and just after the update of mac os  to 10.12.6 . it does not work . 

Mouse is ok , but keyboard not

 

Edited by EchoMike

Share this post


Link to post
Share on other sites

What is a proper uninstall? I mean, I could delete the app and re copy to App folder. But thats pretty much same procedure as upgrade, i.e. overwriting old SYnergy app.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now