Sign in to follow this  
Duncan Lilly

1.7.3 - Client\server compatibility?

1 post in this topic

I have a client running 1.5.1 (the most recent version approved by my employer) and a server on my personal PC - which was happily working with 1.6.3 (both client and server are Win 64bit) I upgraded to 1.7.1 and had the SSL crashes and log explosion so went back to 1.6.3. I've just tried 1.7.3 and none of the crashes happen - but it also doesn't work. Server: [code] DEBUG2: wrote 43 bytes DEBUG2: writef(ILOG%s) DEBUG2: wrote 569 bytes NOTE: accepted client connection DEBUG2: writef(ILOG%s) DEBUG2: sercure Connection established:1830736 DEBUG1: saying hello DEBUG2: writef(Synergy%2i%2i) DEBUG2: wrote 11 bytes NOTE: new client disconnected[/code] Client: [code]WARNING: failed to connect to server: Protocol error from server NOTE: connecting to '192.168.1.142': 192.168.1.142:24800 INFO: crypto mode: cfb WARNING: failed to connect to server: Protocol error from server NOTE: connecting to '192.168.1.142': 192.168.1.142:24800 INFO: crypto mode: cfb[/code] So is it back to 1.6.3 again or is there a magic solution? (I've turned off SSL, since the client won't support it). Ta!

Share this post


Link to post
Share on other sites
Talking to myself; it looks like the SSL support [i]replaces [/i]the previous bespoke encryption (rather than as an alternative) - so you can't talk to older clients with encryption turned on... Back to 1.6.3 it is then.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this