jellybeans

Synergy keeps on auto-restarting ("detected process not running, auto restarting)

5 posts in this topic

 

Devices:
- Server hosted on Late 2013 retina Macbook Pro on Mac OS Sierra (version 10.12) running Synergy version 1.8.8-stable-25a8cb2
- Client is a Surface Pro 4 running on Windows 10 (version 1703, OS Build 15063.483) running Synergy version 1.8.8

Error log:

[2017-07-26T21:57:30] ERROR: process exited with error code: 4
[2017-07-26T21:57:30] INFO: detected process not running, auto restarting
[2017-07-26T21:57:31] INFO: starting server
[2017-07-26T21:57:31] INFO: config file: /var/folders/ct/66lyjky92mncf983dpcvcp2h0000gn/T/Synergy.xr0586
[2017-07-26T21:57:31] INFO: log level: INFO
[2017-07-26T21:57:31] INFO: log file: "/var/log/synergy.log"
[2017-07-26T21:57:31] ERROR: cannot read configuration "/var/folders/ct/66lyjky92mncf983dpcvcp2h0000gn/T/Synergy.wr0586": read error: line 9: invalid screen name "John - Surface Pro 4"
synergys: no configuration available

Share this post


Link to post
Share on other sites

Please provide more details about your machines (OS, 32/64 bit, Synergy version installed, connected to the network via Ethernet or Wi-Fi, specify which one is the server). Also, post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine.

  • Like 1

Share this post


Link to post
Share on other sites
  • Surface Pro 4
    • Client
    • Windows 10 Pro, 64 bit, Version 1703, OS Build 15063.483
    • Synergy Version 1.8.8-stable-25a8cb2
    • Connected via Wi-Fi
  • Late 2013 13in. Macbook Pro Retina
    • Server
    • MacOS Sierra 10.12, 64 bit
    • Synergy Version 1.8.8-stable-25a8cb2
    • Connected via Wi-Fi

I have tried uninstalling & re-installing Synergy on both machines, but that did not work on either machine.

Macbook Synergy UI.png

Macbook Server Config UI.png

Surface Pro 4 Synergy UI.PNG

Edited by jellybeans

Share this post


Link to post
Share on other sites

Hi @jellybeans. Sorry for the late reply on this. Please try Synergy v1.9.0rc3 from the tagged thread below.

 

  • Like 1

Share this post


Link to post
Share on other sites

Hi Paul,

I tried uninstalled the latest version of Synergy from both my devices & installed the Synergy 1.9-rc3 version on both devices. This did not fix anything unfortunately.

  • Surface Pro 4
    • Client
    • Windows 10 Pro, 64 bit, Version 1703, OS Build 15063.483
    • Synergy Version 1.9.0rc3
    • Connected via Wi-Fi
  • Late 2013 13in. Macbook Pro Retina
    • Server
    • MacOS Sierra 10.12, 64 bit
    • Synergy Version 1.9.0rc3
    • Connected via Wi-Fi

 

 

 

MacOS Server Config.png

Surface Pro 4 Client.PNG

MacOS UI.png

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now