AndyLeeMeUk

Bug - Shift Key is MIA in Client Remote Desktop

2 posts in this topic

System Setup

My Server is a 2017 iMac and the client is a late 2012 iMac (both running 10.12.6), I also have a headless PC (This therefore does not have Synergy installed - running Windows 10 Pro and I log into that from Microsoft Remote Desktop), the server and PC are wired connections, the client is wireless.

I have tested this with 2.0 Beta 2 and both 1.8.8 and 1.9.0 RC3 and the bug appears in all of them.

 

Bug & Reproduction

If I connect to my PC using MRD on the server system everything functions correctly.  If I log in from the client Mac, whilst everything functions correctly outside of the MRD connection... In the connection, the [Shift] key, fails to function. Please see the attached screenshot where I have typed the same phrase.

  • As the [Shift] key functions on MRD when I use my Server System, I think I can rule out any configuration issues on the Windows 10 install.
  • Other keys like [CAPS] function correctly (a partial work around).

59587e219880d_ScreenShot2017-07-02at05_56_24.jpg.03d982f20665f2a49c458f7e6e431d13.jpg

Share this post


Link to post
Share on other sites

HI @AndyLeeMeUk. Upon further research on this, I found out that there's already an issue opened in our GitHub page for this problem. Our developers are aware of this issue and they are currently on the hunt for a fix for this problem. Please bear with us as we try to make Synergy even better for everyone.

Modifier keys stop working in Microsoft Remote Desktop #5841

Modifier Keys stop working on a VM on Mac client #3083

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now