epic

Change monitor that goes to client

14 posts in this topic

Hello! Using synergy with a windows server and mac client. windows laptop is running windows 10 and the latest version of synergy. Mac is running Sierra and the latest version of synergy. Both are connected to the network via Ethernet. Windows laptop has an external monitor connected to it (off to the right). Mac screen is directly above windows laptop screen. To get to the mac screen, i have to go to the external monitor, then go directly up (see attached picture). I'd like to have it where i go up from the laptop screen to get to the mac. can't seem to figure out how to do that, as the external monitor does not show up in synergy's server configuration. Thanks!

layout.png

Share this post


Link to post
Share on other sites

That's a bit tricky @epic if you'd want to have two entry points going in to a single machine. We can maybe set it up if you'd set the main Windows machine's monitor underneath the external monitor.

Share this post


Link to post
Share on other sites
43 minutes ago, Paul Suarez said:

That's a bit tricky @epic if you'd want to have two entry points going in to a single machine. We can maybe set it up if you'd set the main Windows machine's monitor underneath the external monitor.

Sorry, maybe i wasn't clear enough. I only need the one entry point, from the Windows laptop. See attached. The green arrow is desired. Red arrow is current, but I'd like to not have that entry point.

layout.png

Share this post


Link to post
Share on other sites

Ohw! gotcha then @epic! What are the resolutions of your Windows machine's monitors? Also, can you post what's inside your current configuration file? I can just delete it afterwards. ;)

Share this post


Link to post
Share on other sites
13 minutes ago, Paul Suarez said:

Ohw! gotcha then @epic! What are the resolutions of your Windows machine's monitors? Also, can you post what's inside your current configuration file? I can just delete it afterwards. ;)

Windows laptop is at 1920x1080, the external monitor is at 2560x1440. Here's the configuration file:

section: screens
	Mac:
		halfDuplexCapsLock = false
		halfDuplexNumLock = false
		halfDuplexScrollLock = false
		xtestIsXineramaUnaware = false
		switchCorners = none 
		switchCornerSize = 0
	RYANBUTLER:
		halfDuplexCapsLock = false
		halfDuplexNumLock = false
		halfDuplexScrollLock = false
		xtestIsXineramaUnaware = false
		switchCorners = none 
		switchCornerSize = 0
end

section: aliases
	Mac:
		1001567.epic.lan
end

section: links
	Mac:
		down = RYANBUTLER
	RYANBUTLER:
		up = Mac
end

section: options
	relativeMouseMoves = false
	screenSaverSync = true
	win32KeepForeground = false
	clipboardSharing = true
	switchCorners = none 
	switchCornerSize = 0
end

Share this post


Link to post
Share on other sites

Hi @epic. Please try to replace the section:links config with the config I wrote below.

section: links
	Mac:
		down(0,100) = RYANBUTLER(0,42)
	RYANBUTLER:
		up(0,42) = Mac(0,100)
end

Please let me know how it goes. ;)

Share this post


Link to post
Share on other sites

That seems to have disabled my ability to move to the Mac screen entirely. I moved the cursor around to every edge and couldn't get over to the Mac.

On a second note, is there a guide on how to edit these config files? I'd probably be capable of figuring this all out myself if there was a guide explaining it...

Share this post


Link to post
Share on other sites

Can you post a screenshot of your current Synergy interface on your server machine and one for the display settings of your Windows machine?

Share this post


Link to post
Share on other sites
8 minutes ago, Paul Suarez said:

Can you post a screenshot of your current Synergy interface on your server machine and one for the display settings of your Windows machine?

Sorry, are you referring to the "Configure Server" button underneath "Configure interactively"? That button greyed out when I switched it to "Use existing configuration". I assume that's what needed to happen for me to use the custom settings you gave me?

That being said, I've attached the main window and settings window of Synergy on the server (Windows), and also attached the display settings.

Display1.PNG

Display2.PNG

SynergyWindow.PNG

Share this post


Link to post
Share on other sites

I forgot to scroll down on the display 1 settings, but the box is checked for "Make this my main display" for display 1.

Share this post


Link to post
Share on other sites

Hi @epic. I'll try to reproduce this later. I'll mention you here when I figure out the best way to configure it on your end. ;)

Share this post


Link to post
Share on other sites
On 7/28/2017 at 4:11 AM, Paul Suarez said:

Hi @epic. I'll try to reproduce this later. I'll mention you here when I figure out the best way to configure it on your end. ;)

Hi @Paul Suarez, any luck on your end with figuring this out?

Share this post


Link to post
Share on other sites

Hey @epic. I just realized that you haven't chosen the config file that you have edited. It shows in the screenshot that you are still using the synergy.sgc file which is the default file. You'll need to click on browse and then choose the config file that you have edited where you have replaced the section:links with the config script I told you to use.

Share this post


Link to post
Share on other sites
3 minutes ago, Paul Suarez said:

Hey @epic. I just realized that you haven't chosen the config file that you have edited. It shows in the screenshot that you are still using the synergy.sgc file which is the default file

Hi Paul,

The file it's pointing to is one that I created with your custom settings. See screenshot.

Capture.PNG

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now