StefanS

Linux client cannot connect to Windows server. Both on seperete networks

4 posts in this topic

Hi,

Linux client on the separate network cannot connect to a windows server (see 01_Client_ image). Windows server seems to be OK (see 02_Windows_Server_image). It has 4 addresses and one of them is the actual IP address of the server machine (see 03_Server_ip_address). The server IP cannot be pinged from the client machine (see 04_Server_ip_image). However, the client machine has full access to www websites such as cnn.com, etc.

What should be done to connect the client with the server?

Thank you

01_Client_connection_error.jpg

02_Windows_Server.jpg

03_Server_ip_address.jpg

04_Server_ip_address_not_reachable.jpg

Share this post


Link to post
Share on other sites

Can you post a screenshot of your client machine's Synergy interface? Also, an IP address that has the format of 169.254.x.x does not really (mostly) reply to an ICMP ping. That's an APIPA IP address. Which means it could be provided due to an error on the actual machine or the DHCP server of the gateway/modem it is trying to connect to.

Share this post


Link to post
Share on other sites

Hi Paul,

The source of the problem was incompatibility of the client (v.1.8) and the server (1.5). I upgraded the Linux version to 1.8 and things are OK. I had to set up the server address manually using information from ipconfig because Synergy was not able to see the address during the start. I think in the future, you could improve the ability of synergy to acquire the correct IP. One option would be a database in the cloud with IPs of host machines against the software unique serial number as the key.

I am really pleased with the experience of using the same keyboard and mouse on both Windows and Linux machines.

Keep up the good work,

Stefan

Share this post


Link to post
Share on other sites

Hi @StefanS! Thanks for updating us on this. I guess what you are suggesting is in development right now. I'll send you a private message. Please check it in a bit. ;)

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now