phil fluffy

debian stretch9 client

2 posts in this topic

Hi all, just a quick post about debian 9 stretch and synergy.
If I install via apt, the version on the debian repos currently has a error when trying to use the copy paste function :-
invalid message from client "debian": DCLP

I tried the package listed in the forums above but it refused to install as libssl dependancy was missing.
So I decided to compile from source from the git repo

$git clone
as root
apt install qmake
apt install qt5-default
apt install libssl1.0-dev
apt install libavahi-compat-libdnssd-dev

then a ./hm conf, then a ./hm build, finally a ./hm package deb produced a .deb in bin that I could install with apt.

Its quite possible the stuff I installed to build it as dependancies will fix the missing libs on the original forum binary posted, but usually apt works that kind of thing out for itself and just does it, but I havent been back to check if its now possible.

I'll look update this post later to see if I've forgetten anything thats important, but have to go out now, but it appears to be working fine with working clipboard between it and the synergy server.

Just a fyi, I don't know if the openssl libs work, because I wrap synergy in a ssh tunnel and bind the clients/server to localhost, as otherwise I always seem to suffer jerking on the mouse pointer on some of my slower machines.

Edited by phil fluffy

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now