Tunjiy

Client needing manual reconnection

12 posts in this topic

I have my sever running on a Mac 10.12.5 and Client is Windows 7 PC. My PC stays in my office and I take my Mac home every night. Every day when I come in, synergy doesn't auto connect and I have to quit synergy and restart on the Mac to generate a new IP address and then re-enter the new IP address onto the client before it will connect. It really defeats the purpose of trying to have only one set of mouse and keyboard in my office.

Share this post


Link to post
Share on other sites

Please provide more details about your machines (OS, 32/64 bit, Synergy version installed, connected to the network via Ethernet or Wi-Fi, specify which one is the server). Also, post a screenshot of both/all machine's Synergy interface and the Server Configuration interface on your server machine.

 

Share this post


Link to post
Share on other sites

Synergy Version: 1.8.7-stabel-9799e96

Server: Mac; Connection: WiFi and Ethernet

Client: PC; Connection: WiFi

Attached: Mac and PC OS version, Mac and PC Synergy Interface, Mac Server Configuration

MacOS.png

PCOS.PNG

Mac Synergy Interface.png

PC Synergy Interface.PNG

Server Configuration.png

Share this post


Link to post
Share on other sites

That's an older version. Please try v1.9.0rc3. You can get it from the tagged thread below.

 

Share this post


Link to post
Share on other sites

That absolutely had the opposite affect!  Now I cannot connect at all. Using both IP addresses from the server, I now get the following error on the client:

 

ERROR: ipc connection error, code=19

ERROR: ipc connection error, connection refused

Share this post


Link to post
Share on other sites

Please post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine.

Share this post


Link to post
Share on other sites

All I did was update the SW to 1.9 as you noted. I didn't change anything on the interface or server configuration so its identical to what i posted before...

Share this post


Link to post
Share on other sites

Exactly my point @Tunjiy. There's a possibility that your machine(s) have received a different set of IP address(es) and could be the reason for this need to do a manual re-connection.

Share this post


Link to post
Share on other sites

I don't understand what you're saying here @Paul Suarez. I have manually gone in and updated the IP address on the client said to match what the server is indicating.

Share this post


Link to post
Share on other sites

I see @Tunjiy. Then please  post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine. 

Share this post


Link to post
Share on other sites

This is ridiculous, not only will my client on my PC not connect anymore, I also am unable to un-install it!!!

Edited by Tunjiy

Share this post


Link to post
Share on other sites

Can I get some help on this.  My synergy has been rendered unusable for over a week now.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now