Adam_He

Installation on Ubuntu 14.04

6 posts in this topic

The version of many dependencies is too old to install the trial 2.0. And I do not think they are upgradable.

 synergy depends on libqt5core5a (>= 5.5.0); however:
  Version of libqt5core5a:amd64 on system is 5.2.1+dfsg-1ubuntu14.3.
 synergy depends on libstdc++6 (>= 5.2); however:
  Version of libstdc++6:amd64 on system is 4.8.4-2ubuntu1~14.04.3.
 synergy depends on qml-module-qtquick-controls (>= 5.5.0); however:
  Package qml-module-qtquick-controls is not installed.
 synergy depends on qml-module-qtquick-layouts (>= 5.5.0); however:
  Package qml-module-qtquick-layouts is not installed.
 synergy depends on qml-module-qtquick-dialogs (>= 5.5.0); however:
  Package qml-module-qtquick-dialogs is not installed.
 synergy depends on qml-module-qtquick2 (>= 5.5.0); however:
  Package qml-module-qtquick2 is not installed.

 

So I guess this means it will not be able to be installed on Ubuntu 14.04?

So I guess I just wasted my money..

Edited by Adam_He

Share this post


Link to post
Share on other sites

At the moment we are only supporting Ubuntu 16.04 LTS and up. When v2.0 is stable and ready for final release, we will re-evaluate our requirements and port back to older OS's. While targetting the bleeding-edge now seems harsh, by the time we get to v2.0 release (and then to v2.1 etc), it's going to look conservative in retrospect.

For the same reason there are currently no 32-bit builds. It's going to happen of course, but at the moment supporting 32-bit platforms provides little value in getting to a final release.

If you are unhappy to wait, or test Synergy on a newer version of your preferred OS's in the meantime, Joe or Paul will be happy to arrange a refund.

Share this post


Link to post
Share on other sites
Quote

Joe or Paul will be happy to arrange a refund.

@Paul Suarez ^

@Adam_He Thanks for buying early access, we appreciate you taking a leap of faith on us.

You can also email [email protected] if you want your money back.

Share this post


Link to post
Share on other sites

I've just run into this issue myself. I would really appreciate support for 14.04 right now as I'm using a work machine and I'm not sure how soon/easily I'll be able to upgrade.

Being a developer myself, I can understand why you might not want to support older Ubuntu releases, but it would have been helpful if you were up-front about this on the website and in the beta invite, *before* users pay any money.

I felt a bit unsure about paying extra money for a product I'd already paid for lifetime access to. When I paid for Synergy 1 there was no suggestion that there would be a Synergy 2 and every suggestion that it was one product which would keep being improved. I went ahead with paying to trial Synergy 2 anyway because it's a good product, and because the benefits of the upgrade were appealing.

All I'm saying is: please ensure a smoother transition so your users don't lose faith!

Share this post


Link to post
Share on other sites
On 8/8/2017 at 9:23 AM, Leo said:

All I'm saying is: please ensure a smoother transition so your users don't lose faith!

Maybe we should include a warning on our email...

Warning: Beta versions are not the finished product, and are unstable. We also took some features out temporarily (so it's perhaps more like an alpha at this point). Please purchase only if you like trying out bleeding edge software that contains bugs.

Share this post


Link to post
Share on other sites

same issue here - ubuntu 14.04

i really like the product, can't upgrade to 16.04 - has anyone tried installing the dependencies one by one?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now