Nahian

Mouse lag on v2 beta

23 posts in this topic

I just paid the $5 for 2.0 Beta, installed it on both my Windows 7 machine and my Macbook pro and the mouse is still lagging on the mac. 

Share this post


Link to post
Share on other sites

Have you installed it on top of an existing v1.x? If so, please try to uninstall first and then re-install.

Share this post


Link to post
Share on other sites

@Paul Suarez Reinstalling will probably not solve a mouse lag problem, this is usually only a cure-all for not being able to connect.

@Nahian Do you know how to run a constant ping between your computers? Try pinging each computer from the other. If you're on Windows, you can use the /t switch to keep the ping running. This way you'll see any ping spikes. It's entirely possible that it could be a network issue (especially if you're using wifi).

If you're not happy and would like a refund, please email [email protected] to get your money back.

Share this post


Link to post
Share on other sites

@Nick Bolton I got it working today. After rebooting both machines and running the Mac as the server machine and then switching back, it is finally working normally again under 2.0 Beta. I love synergy and have been using it for years so I dont think a refund is necessary. Thanks for your help! 

  • Like 1

Share this post


Link to post
Share on other sites

Actually i realized that when i have the Mac as the server it has no problems but when i have the windows machine as the server...it lags. The connection is stable. Any idea of what could be causing this? 

Share this post


Link to post
Share on other sites

@Jerry Hou Any idea what could cause lag when Windows is server and Mac is client?

Share this post


Link to post
Share on other sites

@Nahian

Could you compare the CPU usage when you use your Mac as a server and client and let us know if there is anything abnormal? Thanks

  • Like 1

Share this post


Link to post
Share on other sites

I tried running both machines with almost no applications running (more than 50% free memory and 70% free cpu) and i still get the lag with the windows machine as a server. I also made sure that the connection is not an issue by connecting them both via ethernet and run a continuous ping while move the mouse back and forth between machines. I do not see any irregularity. 

Share this post


Link to post
Share on other sites

@Nahian

Thank you for the information.

Usually, people have multi core processors. Let's say you have 4 cores on your Windows machine. If for some reasons, Synergy max out 1 core, it would show 25% usage of CPU in task manager. In that case, even though you have another 3 cores idle, but this would still cause lag in Synergy.

Is this something you are experiencing?

Share this post


Link to post
Share on other sites

@Jerry Hou @Nick Bolton it spikes a lot when i move the mouse over to the mac from the windows machine. Is there any fix for this? 

Capture.PNG

Edited by Nahian

Share this post


Link to post
Share on other sites

.

Edited by Nahian

Share this post


Link to post
Share on other sites

@Nahian

Thanks for the picture. Could click on applications tab and find synergyd and synergys to see what CPU usage they are? Thanks

Share this post


Link to post
Share on other sites

@Jerry Hou synergy2.exe spikes from 2% to 5-8% when moving it over to the mac and synergys.exe maintains 2% cpu usage. i dont have a synergyd

Share this post


Link to post
Share on other sites

@Nahian

This is probably caused by clipboard sharing feature. On switching screens, Synergy would transfer clipboard data to the other side. Could you have a look at your clipboard context when spike happens?

Share this post


Link to post
Share on other sites

On my machine Synergy2 hogs up 12% (like half of a CPU Core) in sum I got constant 100% utilization of one core!

And its pretty much constant load from the synergy2.exe; no spikes from any action noticed.

Insert existing attachment

synergy2.jpg

cpu.jpg

constant.jpg

Edited by ohrly

Share this post


Link to post
Share on other sites
22 hours ago, ohrly said:

On my machine Synergy2 hogs up 12% (like half of a CPU Core) in sum I got constant 100% utilization of one core!

1

That's a bug. Probably caused by the temporary cloud code. We'll fix it in beta4 or beta5.

Share this post


Link to post
Share on other sites

Hi Nick, I am having the same latency issues.  I uninstalled vs 1 and installed vs 2Beta.  My file sharing is still not working but did a comment in another forum for this.

I see your comment regarding beta 4/5.  do you have an ballpark time frame these version might be out? 

I really like the product but the latency thing is sooooo annoying.

 

Thanx

Share this post


Link to post
Share on other sites

I know, the latency really sucks. We're working to fix it as fast as we can. Bear in mind we have a very small team. The beta4 release is due in about 2-3 weeks, whereas beta5 will be in about 5-6 weeks.

Share this post


Link to post
Share on other sites

Thank you Nick, i totally understand the 'small team' issue.  Appreciate the reply and will wait for the next few releases.  Keep me posted.

Have a safe day.

Von

Share this post


Link to post
Share on other sites

Is there any way to change which computer is the "server" manually? Every time I load the two apps, it keeps choosing my laptop now as the server but i need it to be the desktop. 

Share this post


Link to post
Share on other sites

Hey @Nahian. Ideally, when you press any keyboard keys or mouse buttons on the current client machine, it'll make it the server. Although we find it buggy right now. This will definitely be improved on the the next versions though. Also, if the other machine(s) doesn't respond to the machine claiming to be the server, you can press F12 on that machine for it to for the others to listen to it as the server.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now