Roadworrier

Any click on client brings me back to host computer

4 posts in this topic

After running for a little while I put W7 (synergy running as admin) machine to sleep. After I woke it back up, I could move the mouse from the W10 host to to the @7 client, but every time I clicked to try to launch an app, or to type '`' to get a log from synergy, I'd bounce back to the W10 host machine. Eventually, the connection was lost and even the F12 on the host would no longer work. (I see messages about the client big lenovo's shape changing, but the display size hasn't been changed at all.)

Restarting synergy on the client W7 didn't fix things.

After that restarting Synergy on the host machine DID fix things. Synergy is now working, but host hp is marked as green and client big-lenovo has the infinite progress bar going on it, on the synergy display on both machines. (despite this, synergy is working fine.)

 

HOST LOG: (client log follows)

[Core] [2017-07-10T12:44:51] DEBUG: clipboard changed: lost ownership

[Core] [2017-07-10T12:44:51] INFO: screen "hp" grabbed clipboard 0 from "big-lenovo"

[Core] [2017-07-10T12:44:51] DEBUG: send grab clipboard 0 to "big-lenovo"

[Core] [2017-07-10T12:44:51] INFO: screen "hp" grabbed clipboard 1 from "big-lenovo"

[Core] [2017-07-10T12:44:51] DEBUG: send grab clipboard 1 to "big-lenovo"

[Core] [2017-07-10T12:46:24] INFO: switch from "hp" to "big-lenovo" at 0,90

[Core] [2017-07-10T12:46:24] INFO: leaving screen

[Core] [2017-07-10T12:46:24] DEBUG: open clipboard

[Core] [2017-07-10T12:46:24] DEBUG: close clipboard

[Core] [2017-07-10T12:46:24] INFO: screen "hp" updated clipboard 0

[Core] [2017-07-10T12:46:24] DEBUG: open clipboard

[Core] [2017-07-10T12:46:24] DEBUG: close clipboard

[Core] [2017-07-10T12:46:24] INFO: screen "hp" updated clipboard 1

[Core] [2017-07-10T12:46:24] DEBUG: sending clipboard 0 to "big-lenovo"

[Core] [2017-07-10T12:46:24] DEBUG: sent clipboard size=2603

[Core] [2017-07-10T12:46:24] DEBUG: sending clipboard 1 to "big-lenovo"

[Core] [2017-07-10T12:46:24] DEBUG: sent clipboard size=2603

[Core] [2017-07-10T12:46:33] INFO: switch from "big-lenovo" to "hp" at 1873,461

[Core] [2017-07-10T12:46:33] INFO: entering screen

[Core] [2017-07-10T12:49:59] INFO: switch from "hp" to "big-lenovo" at 0,246

[Core] [2017-07-10T12:49:59] INFO: leaving screen

[Core] [2017-07-10T12:49:59] DEBUG: open clipboard

[Core] [2017-07-10T12:49:59] DEBUG: close clipboard

[Core] [2017-07-10T12:49:59] DEBUG: ignored screen "hp" update of clipboard 0 (unchanged)

[Core] [2017-07-10T12:49:59] DEBUG: open clipboard

[Core] [2017-07-10T12:49:59] DEBUG: close clipboard

[Core] [2017-07-10T12:49:59] DEBUG: ignored screen "hp" update of clipboard 1 (unchanged)

[Core] [2017-07-10T12:49:59] INFO: switch from "big-lenovo" to "hp" at 1890,452

[Core] [2017-07-10T12:49:59] INFO: entering screen

[Core] [2017-07-10T12:49:59] INFO: switch from "hp" to "big-lenovo" at 0,310

[Core] [2017-07-10T12:49:59] INFO: leaving screen

[Core] [2017-07-10T12:49:59] DEBUG: open clipboard

[Core] [2017-07-10T12:49:59] DEBUG: close clipboard

[Core] [2017-07-10T12:49:59] DEBUG: ignored screen "hp" update of clipboard 0 (unchanged)

[Core] [2017-07-10T12:49:59] DEBUG: open clipboard

[Core] [2017-07-10T12:49:59] DEBUG: close clipboard

[Core] [2017-07-10T12:49:59] DEBUG: ignored screen "hp" update of clipboard 1 (unchanged)

[Core] [2017-07-10T12:50:07] NOTE: client "big-lenovo" has disconnected

[Core] [2017-07-10T12:50:07] INFO: jump from "big-lenovo" to "hp" at 960,600

[Core] [2017-07-10T12:50:07] INFO: entering screen

[Core] [2017-07-10T12:50:07] DEBUG: active sides: 4

[Core] [2017-07-10T14:27:08] NOTE: accepted client connection

[Core] [2017-07-10T14:27:08] DEBUG: received client "big-lenovo" info shape=0,0 1366x768 at 16795,2046

[Core] [2017-07-10T14:27:08] DEBUG: active sides: 4

[Core] [2017-07-10T14:27:08] NOTE: client "big-lenovo" has connected

[ UI ] [2017-07-10T14:27:10] DEBUG: report to cloud: destId 648 successfulIp failedIp 172.16.11.117,172.16.11.119,192.168.56.1

[Core] [2017-07-10T14:28:40] INFO: switch from "hp" to "big-lenovo" at 0,222

[Core] [2017-07-10T14:28:40] INFO: leaving screen

[Core] [2017-07-10T14:28:40] DEBUG: open clipboard

[Core] [2017-07-10T14:28:40] DEBUG: close clipboard

[Core] [2017-07-10T14:28:40] INFO: screen "hp" updated clipboard 0

[Core] [2017-07-10T14:28:40] DEBUG: open clipboard

[Core] [2017-07-10T14:28:40] DEBUG: close clipboard

[Core] [2017-07-10T14:28:40] INFO: screen "hp" updated clipboard 1

[Core] [2017-07-10T14:28:40] DEBUG: sending clipboard 0 to "big-lenovo"

[Core] [2017-07-10T14:28:40] DEBUG: sent clipboard size=4

[Core] [2017-07-10T14:28:40] DEBUG: sending clipboard 1 to "big-lenovo"

[Core] [2017-07-10T14:28:40] DEBUG: sent clipboard size=4

[Core] [2017-07-10T14:28:51] INFO: switch from "big-lenovo" to "hp" at 1918,474

[Core] [2017-07-10T14:28:51] INFO: entering screen

[Core] [2017-07-10T14:31:42] INFO: switch from "hp" to "big-lenovo" at 0,703

[Core] [2017-07-10T14:31:42] INFO: leaving screen

[Core] [2017-07-10T14:31:42] DEBUG: open clipboard

[Core] [2017-07-10T14:31:42] DEBUG: close clipboard

[Core] [2017-07-10T14:31:42] DEBUG: ignored screen "hp" update of clipboard 0 (unchanged)

[Core] [2017-07-10T14:31:42] DEBUG: open clipboard

[Core] [2017-07-10T14:31:42] DEBUG: close clipboard

[Core] [2017-07-10T14:31:42] DEBUG: ignored screen "hp" update of clipboard 1 (unchanged)

[Core] [2017-07-10T14:32:01] INFO: switch from "big-lenovo" to "hp" at 1917,342

[Core] [2017-07-10T14:32:01] INFO: entering screen

[Core] [2017-07-10T14:32:02] INFO: switch from "hp" to "big-lenovo" at 0,194

[Core] [2017-07-10T14:32:02] INFO: leaving screen

[Core] [2017-07-10T14:32:02] DEBUG: open clipboard

[Core] [2017-07-10T14:32:02] DEBUG: close clipboard

[Core] [2017-07-10T14:32:02] DEBUG: ignored screen "hp" update of clipboard 0 (unchanged)

[Core] [2017-07-10T14:32:02] DEBUG: open clipboard

[Core] [2017-07-10T14:32:02] DEBUG: close clipboard

[Core] [2017-07-10T14:32:02] DEBUG: ignored screen "hp" update of clipboard 1 (unchanged)

[Core] [2017-07-10T14:32:18] INFO: switch from "big-lenovo" to "hp" at 1918,1199

[Core] [2017-07-10T14:32:18] INFO: entering screen

[Core] [2017-07-10T14:32:19] INFO: switch from "hp" to "big-lenovo" at 0,762

[Core] [2017-07-10T14:32:19] INFO: leaving screen

[Core] [2017-07-10T14:32:19] DEBUG: open clipboard

[Core] [2017-07-10T14:32:19] DEBUG: close clipboard

[Core] [2017-07-10T14:32:19] DEBUG: ignored screen "hp" update of clipboard 0 (unchanged)

[Core] [2017-07-10T14:32:19] DEBUG: open clipboard

[Core] [2017-07-10T14:32:19] DEBUG: close clipboard

[Core] [2017-07-10T14:32:19] DEBUG: ignored screen "hp" update of clipboard 1 (unchanged)

[Core] [2017-07-10T14:32:21] DEBUG: locked by "Left Button"

[Core] [2017-07-10T14:32:21] INFO: switch from "big-lenovo" to "hp" at 1908,207

[Core] [2017-07-10T14:32:21] INFO: entering screen

[Core] [2017-07-10T14:32:53] INFO: switch from "hp" to "big-lenovo" at 0,340

[Core] [2017-07-10T14:32:53] INFO: leaving screen

[Core] [2017-07-10T14:32:53] DEBUG: open clipboard

[Core] [2017-07-10T14:32:53] DEBUG: close clipboard

[Core] [2017-07-10T14:32:53] DEBUG: ignored screen "hp" update of clipboard 0 (unchanged)

[Core] [2017-07-10T14:32:53] DEBUG: open clipboard

[Core] [2017-07-10T14:32:53] DEBUG: close clipboard

[Core] [2017-07-10T14:32:53] DEBUG: ignored screen "hp" update of clipboard 1 (unchanged)

[Core] [2017-07-10T14:33:11] INFO: switch from "big-lenovo" to "hp" at 1918,8

[Core] [2017-07-10T14:33:11] INFO: entering screen

 

 

CLIENT LOG:

 

[Core] [2017-07-10T12:46:23] DEBUG: start receiving clipboard data

[Core] [2017-07-10T12:46:23] DEBUG: receiving clipboard 1 size=2603

[Core] [2017-07-10T12:46:23] DEBUG: received clipboard 1 size=2603

[Core] [2017-07-10T12:46:23] DEBUG: open clipboard

[Core] [2017-07-10T12:46:23] DEBUG: empty clipboard

[Core] [2017-07-10T12:46:23] DEBUG: add 1267 bytes to clipboard format: 0

[Core] [2017-07-10T12:46:23] DEBUG: add 1316 bytes to clipboard format: 1

[Core] [2017-07-10T12:46:23] DEBUG: close clipboard

[Core] [2017-07-10T12:46:23] INFO: clipboard was updated

[Core] [2017-07-10T12:46:32] INFO: leaving screen

[Core] [2017-07-10T12:49:58] INFO: entering screen

[Core] [2017-07-10T12:49:58] INFO: leaving screen

[Core] [2017-07-10T12:49:58] INFO: entering screen

[Core] [2017-07-10T12:50:06] INFO: suspend

[Core] [2017-07-10T12:50:06] INFO: leaving screen

[Core] [2017-07-10T12:50:06] NOTE: disconnected from server

[Core] [2017-07-10T12:50:06] DEBUG: retry in 1 seconds

[Core] [2017-07-10T12:50:06] INFO: suspend

[Core] [2017-07-10T12:50:06] NOTE: disconnected from server

[Core] [2017-07-10T12:50:06] DEBUG: retry in 1 seconds

[Core] [2017-07-10T14:27:07] INFO: resume

[Core] [2017-07-10T14:27:10] NOTE: connecting to '172.16.11.55': 172.16.11.55:24800

[Core] [2017-07-10T14:27:10] INFO: resume

[Core] [2017-07-10T14:27:10] INFO: resume

[Core] [2017-07-10T14:27:10] INFO: resume

[Core] [2017-07-10T14:27:10] DEBUG: open clipboard

[Core] [2017-07-10T14:27:10] DEBUG: empty clipboard

[Core] [2017-07-10T14:27:10] DEBUG: close clipboard

[Core] [2017-07-10T14:27:10] DEBUG: open clipboard

[Core] [2017-07-10T14:27:10] DEBUG: empty clipboard

[Core] [2017-07-10T14:27:10] DEBUG: close clipboard

[Core] [2017-07-10T14:27:10] NOTE: connected to server

[Core] [2017-07-10T14:28:42] INFO: entering screen

[Core] [2017-07-10T14:28:42] DEBUG: start receiving clipboard data

[Core] [2017-07-10T14:28:42] DEBUG: receiving clipboard 0 size=4

[Core] [2017-07-10T14:28:42] DEBUG: received clipboard 0 size=4

[Core] [2017-07-10T14:28:42] DEBUG: open clipboard

[Core] [2017-07-10T14:28:42] DEBUG: empty clipboard

[Core] [2017-07-10T14:28:42] DEBUG: close clipboard

[Core] [2017-07-10T14:28:42] INFO: clipboard was updated

[Core] [2017-07-10T14:28:42] DEBUG: start receiving clipboard data

[Core] [2017-07-10T14:28:42] DEBUG: receiving clipboard 1 size=4

[Core] [2017-07-10T14:28:42] DEBUG: received clipboard 1 size=4

[Core] [2017-07-10T14:28:42] DEBUG: open clipboard

[Core] [2017-07-10T14:28:42] DEBUG: empty clipboard

[Core] [2017-07-10T14:28:42] DEBUG: close clipboard

[Core] [2017-07-10T14:28:42] INFO: clipboard was updated

[Core] [2017-07-10T14:28:47] DEBUG: desk Default window is 0x00020560

[Core] [2017-07-10T14:28:47] DEBUG: switched to desk "Default"

[Core] [2017-07-10T14:28:47] DEBUG: desktop is now accessible

[Core] [2017-07-10T14:28:53] INFO: leaving screen

[Core] [2017-07-10T14:31:44] INFO: entering screen

[Core] [2017-07-10T14:32:03] INFO: leaving screen

[Core] [2017-07-10T14:32:03] INFO: entering screen

[Core] [2017-07-10T14:32:20] INFO: leaving screen

[Core] [2017-07-10T14:32:21] INFO: entering screen

[Core] [2017-07-10T14:32:23] INFO: leaving screen

[Core] [2017-07-10T14:32:55] INFO: entering screen

[Core] [2017-07-10T14:33:13] INFO: leaving screen

[Core] [2017-07-10T14:33:26] INFO: entering screen

[Core] [2017-07-10T14:33:26] DEBUG: start receiving clipboard data

[Core] [2017-07-10T14:33:26] DEBUG: receiving clipboard 0 size=26072

[Core] [2017-07-10T14:33:26] DEBUG: received clipboard 0 size=26072

[Core] [2017-07-10T14:33:26] DEBUG: open clipboard

[Core] [2017-07-10T14:33:26] DEBUG: empty clipboard

[Core] [2017-07-10T14:33:26] DEBUG: add 6566 bytes to clipboard format: 0

[Core] [2017-07-10T14:33:26] DEBUG: add 19486 bytes to clipboard format: 1

[Core] [2017-07-10T14:33:26] DEBUG: close clipboard

[Core] [2017-07-10T14:33:26] INFO: clipboard was updated

[Core] [2017-07-10T14:33:26] DEBUG: start receiving clipboard data

[Core] [2017-07-10T14:33:26] DEBUG: receiving clipboard 1 size=26072

[Core] [2017-07-10T14:33:26] DEBUG: received clipboard 1 size=26072

[Core] [2017-07-10T14:33:26] DEBUG: open clipboard

[Core] [2017-07-10T14:33:26] DEBUG: empty clipboard

[Core] [2017-07-10T14:33:26] DEBUG: add 6566 bytes to clipboard format: 0

[Core] [2017-07-10T14:33:26] DEBUG: add 19486 bytes to clipboard format: 1

[Core] [2017-07-10T14:33:26] DEBUG: close clipboard

[Core] [2017-07-10T14:33:26] INFO: clipboard was updated

[Core] [2017-07-10T14:33:41] INFO: local input detected

[Core] [2017-07-10T14:33:41] INFO: local input detected

[ UI ] [2017-07-10T14:33:42] INFO: write configuration file complete

[ UI ] [2017-07-10T14:33:42] ERROR: process exited with error code: 62097

[Core] [2017-07-10T14:33:42] INFO: drag and drop enabled

[Core] [2017-07-10T14:33:42] DEBUG: opening configuration "C:/Users/stefan/AppData/Local/Symless/Synergy/synergy.conf"

[Core] [2017-07-10T14:33:42] DEBUG: configuration read successfully

[Core] [2017-07-10T14:33:42] DEBUG: screen shape: 0,0 1366x768

[Core] [2017-07-10T14:33:42] DEBUG: window is 0x0004049e

[Core] [2017-07-10T14:33:42] DEBUG: using desktop for drop target: C:\Users\stefan\Desktop

[Core] [2017-07-10T14:33:42] DEBUG: adopting new buffer

[Core] [2017-07-10T14:33:42] DEBUG: opened display

[Core] [2017-07-10T14:33:42] DEBUG: active sides: 2

[Core] [2017-07-10T14:33:42] DEBUG: active sides: 2

[Core] [2017-07-10T14:33:42] DEBUG: clipboard changed: synergy owned

[Core] [2017-07-10T14:33:42] DEBUG: desk Default window is 0x00030492

[Core] [2017-07-10T14:33:42] DEBUG: switched to desk "Default"

[Core] [2017-07-10T14:33:42] DEBUG: desktop is now accessible

[Core] [2017-07-10T14:33:42] DEBUG: registered hotkey ScrollLock (id=ef14 mask=0000) as id=1

[Core] [2017-07-10T14:33:42] NOTE: started server, waiting for clients

[Core] [2017-07-10T14:33:42] DEBUG: event queue is ready

[Core] [2017-07-10T14:33:42] DEBUG: add pending events to buffer

[Core] [2017-07-10T14:33:42] DEBUG: screen "big-lenovo" shape changed

Share this post


Link to post
Share on other sites

Can you try running Synergy normally rather than as admin and let's try if it still does the same thing.

Share this post


Link to post
Share on other sites

I'm not sure I can attribute this issue to "sleep" anymore, as I've experienced this issue again with Synergy running on W10 host and W7 client both as regular users, not administrators without ever sleeping the W7 client (just after a reboot).

Seems I sometimes need to click on the background screen of the host machine before I can switch to the client machine. Also, I experienced an issue where when the Synergy window was minimized this kind of behavior occurred. But I've even experienced it with Synergy not minimized.

I've tried to isolate to using Services on the client machine or running Virtualbox on the host machine, but so far no luck finding a smoking gun.

Share this post


Link to post
Share on other sites

I have a hunch this is caused by the auto-switch feature. When you click on a client, it tries to make that computer the server. Sometimes the other machines are unable to connect to this new server, hence the progress bar. The UI is also very temperamental at the moment, so auto-switching a computer back and forth to server and client mode can cause some weird UI bugs.

If the UI gets into a weird state, try closing Synergy on every computer, then start Synergy back up again.

@Andrew Nelless and @Jerry Hou will be fixing the auto-switch feature and also the UI bugs in beta4 (which is due in about 7 or so weeks).

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now