strom

Can't connect - endless progress bars

54 posts in this topic

I've installed Synergy 2 on a PC and a Mac. The program loads on both machines but all I can see are two boxes, each with one computer's name in it (see screenshot). The boxes have endless progress bars, but there doesn't seem to be any way to connect.

Screenshot 2017-07-03 16.46.06.png

Share this post


Link to post
Share on other sites

Yeah I can't seem to get it work as well. For me, one of my laptop is a green box, and the other has an infinite progress bar...

Share this post


Link to post
Share on other sites

Hi @strom and @D_Pain! Can you try dragging one of your machines to any direction for it not to be beside each other. Wait for a couple of seconds then try to drag it again to have them side by side. It might be better if you move the other machine.

Please let me know how it goes. :)

Share this post


Link to post
Share on other sites

Unfortunately, it's still not working. Both devices do detect the monitor movement in the Synergy program though.

Thanks for looking into the issue!

1.png

2.png

Share this post


Link to post
Share on other sites

Hi @strom. Please provide more details about your machines (OS, 32/64 bit, Synergy version installed, connected to the network via Ethernet or Wi-Fi, specify which one is the server). Also, post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine.

Share this post


Link to post
Share on other sites

I am having this same issue with the constant loading screen. 

My Mac seems to be loading just fine but my windows 10 computer has the constant loading bar. 

My Mac is on Wifi and my PC is hard wired into the same wifi router. I would like my PC to be the server but never was given an option to chose when i installed them

Share this post


Link to post
Share on other sites
42 minutes ago, Asur said:

I am having this same issue with the constant loading screen. 

My Mac seems to be loading just fine but my windows 10 computer has the constant loading bar. 

My Mac is on Wifi and my PC is hard wired into the same wifi router. I would like my PC to be the server but never was given an option to chose when i installed them

Actually, just simply clicking the mouse on any clients (if you have multiple clients) or pressing a keyboard key triggers for it to switch roles and be the server. Although, this is only applicable for machines that have already established connection through Synergy v2. Have you already rebooted the Windows machine though?

Share this post


Link to post
Share on other sites
2 minutes ago, Paul Suarez said:

Actually, just simply clicking the mouse on any clients (if you have multiple clients) or pressing a keyboard key triggers for it to switch roles and be the server. Although, this is only applicable for machines that have already established connection through Synergy v2. Have you already rebooted the Windows machine though?

The 2 machines are not linking, i have started my own thread for this issue. The PC continues to have an endless progress bar. 

 

Share this post


Link to post
Share on other sites

For everyone following this thread. If you have Windows machine, can you try opening Synergy v2 as an administrator?

Removing this suggestion....

Share this post


Link to post
Share on other sites

Can you post a screenshot of Synergy-v2 user interface @D_Pain?

Share this post


Link to post
Share on other sites

@Paul Suarez I'm not really sure what kind of user interface there are apart from this one. I can't really find any "How to's" to use version 2. Whenever I start Synergy v2, this is the only screen I can get to. There are no menu buttons nor are there any other executable for me to run and get to any other screen.

Picture0001.png

Edited by D_Pain

Share this post


Link to post
Share on other sites

That's really how it was designed. Our developers designed it that way since it usually does not require any buttons since it is purely launch and connect and it is designed to automatically connect. Do you have your user account set as an admin?

Share this post


Link to post
Share on other sites

Yes, I have all lthe admin rights. I've also tries running as administrator.

Edited by D_Pain

Share this post


Link to post
Share on other sites

What OS version are you using?

Share this post


Link to post
Share on other sites

Windows 10 Home 64bit and a Windows 7 Enterprise 64bit. Both of them have admin rights and the Windows 7 one had a green box (I assume this means that the pc is connected if its green?)

Share this post


Link to post
Share on other sites

Same issue Macbook connected fine, windows computer infinite progress bar.

1.png

Share this post


Link to post
Share on other sites

My windows is also always running.

MacBook Pro 2016 without TB with macOS Sierra 10.12.3

ACER notebook: windows 10 Home

 

And there are 2 Mac icon, but actually there is only one macbook.

I'm not sure why it shows 2 Mac (with one running)

螢幕快照 2017-07-04 下午3.16.06.png

Share this post


Link to post
Share on other sites

Hi Guys,

I had been having the exact same issues.  It is however working after doing the following 2 simple steps:

1. Restart each PC (running Windows 10 on both)

2. Running Synergy as Administration on both PC's (Note i did not try closing Synergy and running as admin, maybe dont need to restart the PC's)

That is it, its now working

Share this post


Link to post
Share on other sites
11 hours ago, Paul Suarez said:

Hi @strom. Please provide more details about your machines (OS, 32/64 bit, Synergy version installed, connected to the network via Ethernet or Wi-Fi, specify which one is the server). Also, post a screenshot of both machine's Synergy interface and the Server Configuration interface on your server machine.

Machine 1:

  • MacOS Sierra, 64 bit
  • Synergy 2.0.0-beta2
  • Connected via wifi
  • Server

Machine 2:

  • Windows 10, 64 bit
  • Synergy 2.0.0-beta2
  • Connected via wifi
  • Client

Share this post


Link to post
Share on other sites

Screenshot from machine 1 attached, machine 2 is identical apart from the computer name at the top.

If I change screen positions on one machine, the other one will update, but nothing more than that.

Screenshot 2017-07-04 10.50.40.png

Share this post


Link to post
Share on other sites

I restart my pc.

But it is still in endless progress bar. :(

And I find that if I change position in windows,

the changing position on Mac would also display.

So I guess there is still some connection between them.

but not enough to work.

  • Like 1

Share this post


Link to post
Share on other sites

Same issue here. 3 win 10 Computer 's. Reboot has no effect. Admin has no effect. 

  • Like 1

Share this post


Link to post
Share on other sites

Hi @strom,

It looks like your computers are having trouble seeing each other, are you using a VPN for either of these machines?

Share this post


Link to post
Share on other sites

I'm not really sure what the issue was, but I've connected another desktop (Windows 10 Pro 64bit) from a different network environment with my laptop (Windows 10 Home 64bit). It's glitchy, but I got both of them to work.

I can get the keyboard and mouse to work on both machines, but it seems like the Input share feature (keyboard + mouse sharing) would stop working when I have the synergy 2 program minimized. (I'm not really sure if this is the exact reason.) The connection between the synergy server is still fine when the input share feature isn't working. The two boxes in the synergy app is still green, but when I move the mouse to the other computer, it stops working. (The host pc think the mouse is in the other computer since it takes a bit for the mouse to come back to the host machine when I move it like how it normally works.)

Oh and copy&paste works well.

I really like the idea of this program so even if I feel like just getting synergy 1, I'll keep work on to get synergy 2 up and running lol. Should I create a separate thread? I feel like it would be really helpful if you guys post something regarding all the features that are implemented and how things should be working. Then we can all test it out and give back info to debug with.

Edited by D_Pain
  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now