Brent

ERROR: ssl error occurred (system call failure)

4 posts in this topic

I get the synergy system to work great without ssl encryption, but when I turn on encryption I get a system call failure which also causes the cursor to get jumpy.

The ssl option is turned on for both client and server.

 

Is this a bug or is there some other setting I need to change?

Thank you.

Below is the log error:

I'm running linux mint versions of Ubuntu 14.04 on server computer (Jane) and Ubuntu 16.04 on the client computer (Miner00)

[2017-07-01T01:53:40] INFO: accepted secure socket

[2017-07-01T01:53:40] INFO: AES256-GCM-SHA384 TLSv1.2 Kx=RSA Au=RSA Enc=AESGCM(256) Mac=AEAD

[2017-07-01T01:53:40] NOTE: accepted client connection

[2017-07-01T01:53:40] NOTE: client "Miner00" has connected

[2017-07-01T01:53:50] INFO: switch from "Jane" to "Miner00" at 1919,523

[2017-07-01T01:53:50] INFO: leaving screen

[2017-07-01T01:53:50] INFO: screen "Jane" updated clipboard 0

[2017-07-01T01:53:54] ERROR: ssl error occurred (system call failure)

[2017-07-01T01:53:54] ERROR: eof violates ssl protocol

[2017-07-01T01:53:54] ERROR: failed to accept secure socket

[2017-07-01T01:53:54] INFO: client connection may not be secure

[2017-07-01T01:53:55] INFO: OpenSSL 1.0.1f 6 Jan 2014

 

Share this post


Link to post
Share on other sites

What Synergy version do you have running on each of your machine? Also, what version of OpenSSL do you have on each of them?

Share this post


Link to post
Share on other sites

Great! Just what I expected it to be. ^_^ Thanks for the update on this @Brent

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now